Opensuse 13.2 openvpn not routing correctly

I have been using opensuse 13.1 for some time vpn working fine
I installed new root partition with 13.2
I have also tested same problem on virtualbox install of opensuse 13.2 64 bit kde.
I have been using vpn provider with no trouble on opensuse 13.1 ,ubuntu 12.10,14.04 all work fine with same config file.

I have ran as root on cli same problem
On cli
The vpn comes up file and works but if you check command.
The default gateway is not set so all traffic still goes through default local lan not vpn provider.

On kde desktop through networkmanager the vpn connect properly but yet again default route not changed and when i drop connection it leaves a tun0 in networks that i have to delete manually

If I manually add a default gateway that points to vpn provider ip the vpn works as it should.

I Don’t think this is the vpn provider problem
I think its got something to do with openvpn as problem exist on cli command .
Nothing to do with firewall as i have tried disabled and enabled.

If others are using vpn can you check for me if you route is correct as you may not realise that traffic is not going through vpn.

Is there anyone else using openvpn with no problems . not through third party software but using build in openvpn

Found a solution when using in networkmanager on kde desktop
not sure why it does the same thing on command line
Hello again,

I found a description how to solve the issue using the NetworkManager frontend:

This works form me (under KDE):

  1. Open connection editor from the plasma widget.

  2. Select OpenVPN connection

  3. Select Edit from Connection menu.

  4. Select IPv4 tab

  5. Click Routes button

  6. Uncheck: Use only for resources on this connection


Thank you so much for posting the solution! Worked for me.