opensuse 13.2 openvpn connected but some sites still display isp ip number

Hello,

I installed opensuse 13.2 kde and setup openvpn.
openvpn working, some web sitesi display vpn ip, but for example
whatismyipaddress.com
still display isp ip.

VPN provider suggest these:

  • geo.enabled is false in firefow about:config
  • open the web site using private window
    i completed these task, but result same.

Any suggestions ?

thanks,

what vpn provider do you have?

in my case, i have an vpn provider where i can choose servers wolrdwide. All online ip/geo location checkers showing my fake destination and IP adress

You need to look at what DNS whatismyipaddress.com is looking at.
If it’s looking at the DNS used by ISP providers, they will almost always be the originally assigned name of the IP address. This is why you always need to ask your ISP to modify <their> DNS records when you deploy a mail server with mail delivered directly to it… because many mail servers only use these records instead of the commonly used records published by your own public domain as an anti-spam measure. This prevents just anyone from deploying a mailserver recognized as authoritative by all.

If you can verify whatever service you use (or simply point to a public DNS yourself using nslookup) is using <your> Domain records and still find you have a problem, then the problem is usually on the server machine itself using the common DHCP client option “change the IP address vi DHCP” or worded something like that.

Less common, someone could also be deploying DNS with custom name mappings.

TSU

I am having problems opensuse 13.2 kde.64 bit

start vpn
open a root terminal and type
route

see where you default route is going it should be pointing at vpn provider ip not you internal default gateway.

Don’t hijack some else’ thread. Each time someone does this, it creates chaos in what advice applies to which problem.
Open your own new thread.

TSU

Sorry did not mean to highjack just sounded like his ip traffic was not going through vpn route.won’t comment on this thread any more