opensuse 13.2 no desk workspace after resume

Hi,

Yesterday the PC go in sleep mode, after résume, i get the login screen as usual, and after login the kde desk stay empty, with the green opensuse 13.2 wallpaper and no icons.
Right and left click gives nothing.
The problem is still the same even if i restart the PC.

Thank for your ideas.

Elie

Sounds like corrupted KDE configuration files. Try adding a different user and see if they have the same problem??

With an other user it’s ok.
How can i correct m’y first user loging.

Ok good

First see if perhaps your activities are set wrong. Right click desktop (That work??) and select activities and try different ones.

If that does not fix things then you need to remove/rename ~/.kde4 (~ is short hand for your home note the period before the name)

You can’t be running KDE logged in as your self to preform this (like changing tires while driving)

So log out (right click desktop- leave)

Once at the log in screen press CTR-ALT-F1. Log into the terminal as yourself then

mv ~/.kde4 ~/.kde4.bak
reboot

This will take things back to the default openSUSE KDE desktop

Sorry for not having replied instead.

You’re right, after having followed your indication I could find my kde desktop.

Thanks

Hi

I have no luck, today i restart the Pc and the problem is still here.
I think there is a problem with activity, there is one undefined that I couln’t erase and when i try to create a new one, kde create not the one I choose.

On the desktop which doesn’t work you can’t make a right click, you have no bottom bar and no possibilité to create a new activité or add a panel. So you can’t do nothing you have only the green opensuse wall papier.

You must have another activity selected as current before you can delete another. The widget in the activity list should show a wrench and another icon. select the other one and it should prompt you if you want to delete.

Removing ~/.kde4 should also reset all activities. Got no clue what may create a bad activity. Perhaps one of the templates is bad.

Check the file ~/.kde4/share/config/activitymanagerrc It may hold a clue and may also allow you to remove the bad activity

If it keeps coming back I don’t know

i found the problem, it’s not kde but .bashrc, i put a lign to call node js server a startup.
This line prevent kde to start , is it a normal behavior ?

How can i add a program at startup in a normal way ?

Where did you put the line?? and exactly what. Did you add && at the end to start in what ever in a new thread?? Otherwise it may stop the start up process.

What program to start a GUI or some other??

It is always best to show use the exact code

Here is the .bashrc file, i add, the command to start node server for cloud9 ide

node ~/c9sdk/server.js

Sample .bashrc for SuSE Linux

Copyright (c) SuSE GmbH Nuernberg

There are 3 different types of shells in bash: the login shell, normal shell

and interactive shell. Login shells read ~/.profile and interactive shells

read ~/.bashrc; in our setup, /etc/profile sources ~/.bashrc - thus all

settings made here will also take effect in a login shell.

NOTE: It is recommended to make language settings in ~/.profile rather than

here, since multilingual X sessions would not work properly if LANG is over-

ridden in every subshell.

Some applications read the EDITOR variable to determine your favourite text

editor. So uncomment the line below and enter the editor of your choice :slight_smile:

#export EDITOR=/usr/bin/vim
#export EDITOR=/usr/bin/mcedit

For some news readers it makes sense to specify the NEWSSERVER variable here

#export NEWSSERVER=your.news.server

If you want to use a Palm device with Linux, uncomment the two lines below.

For some (older) Palm Pilots, you might need to set a lower baud rate

e.g. 57600 or 38400; lowest is 9600 (very slow!)

#export PILOTPORT=/dev/pilot
#export PILOTRATE=115200

test -s ~/.alias && . ~/.alias || true
node ~/c9sdk/server.js

The ~/.kde4/Autostart folder is where you should put a script (of any name) that executes your command. Also adding the & at the end of command is important. So you could run this in a terminal


cd ~/.kde4/Autostart
echo "node ~/c9sdk/server.js &" > my_autostart.sh
chmod ug+x my_autostart.sh

Then, logout. The next time you login it should be running.

thanks
do i have to add & at each end of command line or only for the last one

Which difference you make between bashrc and autostart script.

Yes, you have to add & after every command (assuming you want to perform this command asynchronously, in another thread).

The contents of .bashrc are executed every time you login to the system by a terminal. So, every time you open a ‘konsole’ window, .bashrc is executed (you can check this by adding ‘echo greetings from .bashrc’ in your .bashc). The contents of the .kde4/Autostart on the other hand are executed every time you perform a KDE login on your system.

I also forgot to say that if you add your command at a script in .kde4/Autostart, you can (and probably should) remove it from .bashrc.

is it the same for bashrc do i need to put & at each an of command
How do yo explain that the node command without & bloc kde start up

have yo a tuto for all these tips

Yes, it is the same with &. A script (like .bashrc or my_autostart.sh) is just a set of commands, and any command can be executed on the foreground or the background. Executing on the foreground means that you (or the system running them) has to wait for the command to finish before continuing. For example, the following script


cp a_large_file another_large_file
echo "Copying done!"

copies ‘a_large_file’ to ‘another_large_file’, then prints a message to let you know its done. However, the following script


cp a_large_file another_large_file &
echo "Copying done!"

executes the copy command (cp) in a separate thread. Thus, if you execute this second script, the system will start the copying, but won’t wait till it’s done to execute the echo command. Thus you will get the message earlier.

I hope this clears things.

On 2015-06-21 22:36, billypap wrote:
>
> Yes, you have to add & after every command (assuming you want to perform
> this command asynchronously, in another thread).
>
> The contents of .bashrc are executed every time you login to the system
> by a terminal.

And by all terminals and all shell processes…


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

thanks it’s ok