Opensuse 13.2 no audio today!

Hi all,

Today my PC not play System sound. I’ve a laptop and I’m using an USB audio card.

The speaker works because if I go to the youtube site i can hear the audio of video.
When I try to put volume up/down with keyboard buttons it not work (yesterday this features works fine).

The strange thing is this when I go to Yast>Hardware>sound I can hear the sound test.

I’ve tried to re-install drivers but nothing is changed.

So I’ve switched the USB port of audio card, and the Yast>Hardware>sound say me that I’ve another sound card and when I try to install it, following the wizard, “the System say me that the kernel module snd-usb-audio for sound support could not be loaded. etc…”

What happen :O? What can I do?

Thanks in advance

Such problems were mentioned today also on mailing list but I’m not sure if it is same… It’s weird. For me, removing and reconfiguring sound card in YaST worked.

Thanks for your notification, I’ve just installed the fix, but nothing is changed…

What can I do?

Have you rebooted after installing the fix? (Logout/Login should be sufficient, but still…)

What pulseaudio package do you have installed exactly?

rpm -qi pulseaudio

Yes i’ve rebooted 2 time.

When I type the command that you have written, I receive the output message but the terminal become frezed…

It’s so strange…

Name        : pulseaudio
Version     : 5.0
Release     : 4.18.1
Architecture: x86_64
Install Date: Tue 21 Apr 2015 02:17:39 PM CEST
Group       : System/Sound Daemons
Size        : 3365115
License     : GPL-2.0+ and LGPL-2.1+
Signature   : RSA/SHA256, Tue 21 Apr 2015 10:48:58 AM CEST, Key ID b88b2fd43dbdc284
Source RPM  : pulseaudio-5.0-4.18.1.src.rpm
Build Date  : Mon 13 Apr 2015 02:49:52 PM CEST
Build Host  : cloud121
Relocations : (not relocatable)
Packager    :
Vendor      : openSUSE
URL         :
Summary     : A Networked Sound Server
Description :
pulseaudio is a networked sound server for Linux, other Unix like
operating systems and Microsoft Windows. It is intended to be an
improved drop-in replacement for the Enlightened Sound Daemon (ESOUND).
Distribution: openSUSE 13.2

Which one?
The rpm command in the other thread?
It shouldn’t “freeze”, but it installs the fixed update which will take a while.

It’s so strange…

Name        : pulseaudio
Version     : 5.0
Release     : 4.18.1

It’s not so strange. This is the buggy package you still have installed.

Run this to install the fixed update, this time with a progress bar, so that you don’t think the terminal froze:

sudo rpm -Uvh

Thanks m8 using “sudo rpm -Uvh” the issue is resolved!!

(the command “rpm -qi pulseaudio” has freezed the console)

Thanks again!!

Hm. Then you seem to have bigger problems (probably unrelated to pulseaudio) than just not-working sound… :\

The bug should be fixed by today’s update. Install and reboot.

Actually the fixed update has been released yesterday already.
And andreacatania did write in his previous reply that the update solved his issue… :wink: (he installed it from the update-test repo, but that’s exactly the same package that got released as update)