OpenSUSE 13.2 Monitor Out Of Range

so i just attempted to install opensuse 13.2 i have a gtx 560 with max res of 1680 by 1050 i’m able to reach the menu install upgrade etc but once i click install my screen boots into a black screen with 3 green boxes then once that is finished loading my screen goes black and throws me an error Out Of Range… i’m assuming there is some way of changing the resolution with grub? if someone could help that would be great thanks keep in mind I’m to this so try keep everything as formal as possible thanks.

Additional information
Monitor input VGA
Cable VGA
Graphics Card Input VGA to DVI

So you cannot even install it?

Try to select “No KMS” in the installation disk’s boot menu by pressing ‘F3’:


If you can’t do that (i.e. you have an UEFI system), press ‘e’ instead (when “Installation” is selected), search for the line starting with “linuxefi” and append “nomodeset” at the end, then press ‘F10’ to boot and start the installation.

After the installation you should add the proprietary nvidia driver to get the fullest out of your graphics card, but let’s keep that for later…

I guess you’re using an older monitor, and that you have a DVI-VGA converter because the monitor only offers VGA input? Anyway, it might be useful to try installing using ‘text mode’

https://en.opensuse.org/SDB:Installation_help

[F3 ]Video Mode - Select various graphical display modes for the installation. Select Text Mode if the graphical installation causes problems.

Once the installation is complete, you may need to boot using failsafe mode, and consider installing the proprietary NVIDIA driver from there.

Hey so I’ve managed to install it but now i need to some how get drivers I’m stuck on like 640 res lol

See here:
https://en.opensuse.org/SDB:NVIDIA_drivers

You need the first one, “For GeForce 8 and later”.

Thanks for the super speedy reply :slight_smile: great community.
http://i.imgur.com/4kpAYyh.png

I got a new error now i tried running in recovery mode but didn’t work so well gave me an error something like no error logs or something.
http://i.imgur.com/SGi0s2i.jpg

Does your system work otherwise?

This message on your picture seems to come from your hard disk controller (ata7) or a connected drive.

yes my pc works i have uefi is that why? legacy is on and secure boot is off

UEFI should not have any relation here I think.

So the problem is just this message? Or do you only get it in recovery mode?

I would just ignore it then.
Some BIOS settings or boot options might help, but I’m not really sure what you could try.

Do you have anything connected to ata7?
Is this a RAID controller? Maybe try switching it to normal mode or off completely (in the BIOS/UEFI firmware).

Hey i’m not sure what ata7 is, is that my sata port? i have 2 satas plugged in but is plugged in but had nothing on the end of it? but i leave it like that so i can easly plug my windows 8 hard drive back in once i’m finished using linux hard drive.

Ok so i managed to fix the ata7 error i now get this error o.O I tried running recovery but i get same error and the issue that was causing ata7 was my dvd rom don’t know why it’s not working with linux but i had this problem in the past i think my cd rom is corrupted. soo does recovery actually fix anything? or is it for safe mode? ill need to reinstall this to fix?
http://i.imgur.com/O1fVadZ.jpg

No, Recovery mode does not “fix” anything magically.
It just boots with “failsafe” options that should work in any case and uses a generic graphics driver.

But GNOME absolutely needs OpenGL support, and having the nvidia driver installed breaks Mesa’s software renderer.

So, does normal boot work?
Have you changed anything?

This dialog normally indicates problems with the graphics driver.

Have you updated the nvidia driver to the 13.2 version? The one for 13.1 will not work.
You’ll have to change your nvidia’s repo URL to 13.2 as well and reinstall the driver.

You could try to boot some older kernel (“Advanced Options” in the boot menu).

If all else fails, uninstall the nvidia driver packages, and will hopefully get into GNOME then (at least in recovery mode).
You can use YaST in text mode, or run this:

sudo zypper rm nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop x11-video-nvidiaG03

Since you apparently are using gnome (that is a gnome error) this usually is the result of a NVIDIA driver installed before an upgrade . Reinstall the NVIDA driver should correct the problem.

Yes i installed Nvidia drivers How do i get into this text mode? where i can write commands since i said i can’t get into the desktop i can only boot and get this error oops something is wrong.

Press Ctrl+Alt+F1, or add ‘3’ to the boot options (press ‘e’ at the boot menu and append it to the line starting with “linux”).

ok i did that and it opens the grub terminal i typed the command that the guy above said and it just says command not found with pretty much everything i type sudo not found zypper not found :confused: i press e when it loaded then press f2 to get the terminal

Well, if those commands are not found, then your system is in a badly broken state.
But I doubt that you would even get as far as that GNOME error screen then… :wink:

Sure you made no typos?
But judging for your next sentence, I don’t think you really logged in to a text mode shell.

GRUB of course doesn’t know that commands. You have to boot your openSUSE system (to text mode) and login.

i press e when it loaded then press f2 to get the terminal

Hm?
Where did you do that? At the boot menu?
I never told you to press f2.

Again, press Ctrl+Alt+F1 when that GNOME screen shows up, that should get you to text mode. Login there, maybe as root even (you can omit the “sudo” then), and run that zypper command.

Or alternatively, press ‘e’ at the boot menu, search for the line starting with “linux” and append ‘3’ to it, then press ‘F10’ to boot. The system should stop in text mode then before GNOME is started, and you should be able to login and run that zypper command.

I reinstalled the openSUSE but now I need the right nvidia drivers I have gtx 560 MSI can anyone link me the right drivers pls

nvm i managed to install the drivers everthing is working fine :slight_smile: thanks for everyone’s help.