OpenSUSE 13.2 freezing with black screen

Hi there,

I’ve been able to install and run OpenSUSE 13.2 successfully on my Dell Precision M6700 notebook. However when its running, it sometimes freezes completely with the screen going black. Once it displayed an error dump from the console after a while, with the caps lock flashing. I can’t recall what was contained in the error dump. It tends to freeze like this when I’m running torrent applications. I’m going to test running it without downloading torrents for a while and see if it still freezes.

Are there any log files I can view that will help in diagnosis of this? Or any patches I should apply to the system or anything else I should do?

I don’t have an answer. Perhaps somebody does.

You need to tell us which desktop you are running (Gnome or KDE or something else). Since you suspect torrents, you need to tell us which software you are using for that.

There’s a good chance that the freeze is actually related to your graphics card and driver. So you need to tell us about your graphics cards and which drivers (if not the default open source drivers).

I got a similar problem:
Sometimes, my screen suddenly shows pink and other-coloured stripes [they go vertical and have a horizontal break all al one line] and then nothing works. So I press the “boot buttom” until it’s off and reboot. The computer forgot that I used it since the last savings. For me, this bug is quite scary.

I don’t think it’s overheating because I haven’t changed anything with my workplace for over 20 months and this appears since I changed from openSUSE 13.1 to 13.2. Yesterday was the ~4th time this happened.

“the computer forgot that I used it since the last savings” means: I work with office e.g. and my screen crashes (the rest doesn’t work/react either, at least the CD drive doesn’t) then I reboot and I open office again. It shows me a message saying something like “I noticed that office crashed, let’s try rebuilding what you typed in this document.” But this doesn’t work although office thinks it worked.

My “YaST2 - Hardware Information” says:
Framebuffer Device -> Intel(r) 82945G Chipset Family Graphics Controller -> Model+Device: Intel(r) 82945G Chipset Family Graphics Controller; Subvendor: Intel(r) 82945G Chipset Family Graphics Chip Accelerated VGA BIOS
Does this help? (I’m reall ybad at learning names, SORRY!)

My PC is an emachines EL1600 everything original (except the screen, but it’s too old and worked too well for being the problem).


You were suggested to start a thread of your own in the Graphics sub forum.
You really should have followed that suggestion rather than posting in an
unrelated post in the Laptop forum. Your problem is almost certainly graphics
related, and your computer is certainly not a laptop. Further I would suggest a
title for your new post that describes your problem and will attract the
attention of those with expertise in that sort of issue. Perhaps “my screen
shows pink and other-coloured stripes”

Your computer is very old, a 2009 model, and it was the cheapest similar model
on the market at the time by a whole order of magnitude. It fact it’s
really just a cheap nettop box in a big case to allow a full sized optical
drive to be added. The problem you describe is very, very typical of a failing
video card that is overheating. I could go on at great length describing how
components age over time, but it would be of no value. Suffice to say it’s

IMHO: You’ve more than gotten your money’s worth out of that PC, and
continuing to trust it as your primary work machine is like juggling a ticking
time bomb. The graphics card is not the only component nearing the end of its
life expectancy (for instance the hard drive and all that data you don’t want
to lose.) You do have up to date backups. Right?

I’m running OpenSUSE 13.2 on a Dell Precision notebook with an AMD graphics card, I’m not sure of the exact model however when I run hardware information in yast control center it gets stuck on “framebuffer device” when probing hardware. I’m running a KDE desktop and the freeze happend when I was logged in as root user and running ktorrent/transmission/qbittorrent. I’ve also had it happen when logged in as a standard user and putting my computer to sleep and waking it up, no torrents running. I’ll boot into Windows to get my specific model of graphics card. I think there’s a problem with the graphics drivers; when I run VMWare workstation in OpenSUSE and attempting to load VM’s, I get the message “hardware graphics acceleration is not available” and “No 3d support is available from the host” when starting my Guest VM’s.

My graphics driver in Windows is AMD (ATI) FirePro M6000 (FireGL V) Mobility Pro Graphics

Are you using the nouveau driver only or have you installed your AMD drivers?
As a test - at the Grub2 boot menu press the “e” (for edit) key, and use your arrow keys to navigate to the end of the line beginning with linux.

After the last word in the line, add a space and type in:


Press F10 to initialize the boot process and see if that helps.

Please ensure that your have installed the AMD drivers for your specific graphics card.

You are using the old “Poulsbo” open-source Intel GMA500 driver supporting the Intel Poulsbo, Oaktrail, Cedarview, and Medfield hardware.
The driver has always had minimal support in Linux.

Please read:

Memory allocation optimization

You can try editing /etc/default/grub and add the line below to the line “GRUB_CMDLINE_LINUX_DEFAULT=”

GRUB_CMDLINE_LINUX_DEFAULT="quiet console=tty1 acpi_backlight=vendor acpi_osi=Linux mem=896mb"

In the console type:

grub2-mkconfig -o /boot/grub2/grub.cfg

Shutdown and restart your laptop by typing:

shutdown -r now

Good Luck!

How do I go about installing the AMD drivers for my graphics card? Should I try to download them from the DELL website or is there an OpenSUSE repository I can use?

You can use the ones provide by the Community Repositories in Software Repositories.

  1. Open Yast -->Addon Repositories or Software Repositories
  2. Click on the Add button and choose Community Repositories
  3. Select AMD/ATI Graphics Drivers and click on the OK button
  4. When prompted to Import Untrusted GnuPG Key, click on the Trust button

This will update and add the AMD/ATI proprietary driver repository to the Yast Software Manager.
Navigate to the View tab and click on Repositories to enable the Repositories tab.

In the left column select the AMD/ATI Graphics Drivers and on the right side select the package:

fglrx64_xpic_SUSE132 - X Window display driver for the AMD graphics accelerators

This package is a meta package to installed fglrx-core, fglrx-graphics, fglrx-amdcccle (AMD Catalyst Control Center) and fglrx-opencl.

After installation restart your laptop and use the AMD Catalyst Control Center to configure your card.

Follow Up – Before installing your drivers

Don’t forget to install gcc, gcc++, make, cmake, patch, kernel-source, kernel-syms. The installation will pull in some extra packages.
This will allow you to install your AMD/ATI Graphics Drivers and auto-install/compile them into the kernel-source.

I updated my graphics drivers by installing the package fglrx64_xpic_SUSE132 - X Window display driver for the AMD graphics accelerators. When starting my system (I have luks encryption on my volume group containing my root partition and swap partition) prior to the driver update the console text was in full 1920x1080 resolution and there was my blue/green desktop background with a padlock on it, requesting my disk encryption passphrase. After installing the graphics driver update the resolution in the console went crappy and the padlock screen for entering my passphase is gone, replaced by a text console in bad resolution. The resolution of KDE once it starts is fine though, however when I press ctrl-alt f1 to f6 to change console terminals, the console resolution is still crappy.

How do I fix the resolution for my console terminals, including on startup, and how do I get my blue/green padlock screen back for the luks passphrase?