Opensuse 13.2: fglrx with newer kernel?

Hello everyone!

I’d like to ask if the fglrx drivers located in the official repos are compatible with newer kernels than the one installed by default? (3.16.x).

I was thinking of adding the kernel:stable repo.

Any help would be greatly appreciated!

On Thu 02 Jul 2015 01:06:01 AM CDT, pneuma00 wrote:

Hello everyone!

I’d like to ask if the fglrx drivers located in the ‘official repos’
(http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/) are compatible
with newer kernels than the one installed by default? (3.16.x).

I was thinking of adding the ‘kernel:stable’
(http://download.opensuse.org/repositories/Kernel:/stable/standard/)
repo.

Any help would be greatly appreciated!

Hi
Your better to build via the rpm method, this has a script that will
rebuild the fgrlx kernel module on a kernel update and reboot…
https://en.opensuse.org/SDB:AMD_fglrx


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel
3.12.43-52.6-default If you find this post helpful and are logged into
the web interface, please show your appreciation and click on the star
below… Thanks!

So if I install the driver with Sebastian’s method, fglrx will update automatically after every kernel upgrade?

Are the drivers found in the official repo not capable of this?

Hi
They should be, with the script you can select options for building if you need them;


Usage : makerpm-amd-15.5.sh [options...]
Options:
  -b/--build                    build only the RPM-Package (default)
  -c/--configure <type>         configure only the X-Server.
                                (IMPORTANT: Use it only if you have problem with the default configuration of X-Server)
                                Follow monitor types are available:
                                  single = configure X-Server for single monitor.
                                  dual   = configure X-Server for dual monitors.
  -d/--downloadonly             download only the AMD-Installer
  -i/--install                  build and install/update the RPM-Package
  -igf/--install-gdm-fix        install a fix for the gdm issue with fglrx driver
  -k/--kernel <kernel-flavor>   define explicitly the needed Kernel flavor devel package(s).
                                Following values are available (Default: syms): default, desktop, pae, xen, syms, none
                                Important note: The values <syms> and <none> is only a exclusive value.
                                Example parameter: --kernel default,desktop
  -/--kms <yes|no>              enable or disable Kernel-Mode-Setting
  -nohw/--no-hardware-detect    Don't count on hardware detection (vm building)
  -/--old2ddriver <yes|no>      enable or disable the older 2D-Driver
  -r/--report                   generate a report from this system
  -u/--uninstall                remove AMD Catalyst and clean up completely all possible AMD files and directories
  -ugf/--uninstall-gdm-fix      uninstall a fix for the gdm issue with fglrx driver
  -ur/--uploadreport            same as --report, additionally the report will be uploaded to sprunge.us
  -h/--help                     this help text
  -V/--version                  show version number