Opensuse 13.2 bumblebee not working.

I’m trying to run bumblebee with nvidia and nouveau but always get the same error, Cannot access secondary GPU.
I googled and try many possible solutions without luck.

I’m using defaults repositories.
This are the messages errors.

dxrxaxx@linux-zji5:~> optirun glxspheres
 2073.821424] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

 2073.821470] [ERROR]Aborting because fallback start is disabled.
dxrxaxx@linux-zji5:~> systemctl status bumblebeed
bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since Sat 2014-11-22 17:40:58 CLST; 34min ago
 Main PID: 839 (bumblebeed)
   CGroup: /system.slice/bumblebeed.service
           └─839 /usr/sbin/bumblebeed

dxrxaxx@linux-zji5:~> primusrun glxspheres
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

Any input?

As far as I know you can’t use nouveau with bumblebee

You do not install the normal NVIDIA packages you must install the NVIDIA-bumblebee package

here is the correct set of instruction I think that smithfarm is no longer relevant and those instruction may not work any more

First remove any and all NVIDIA packagges you may have installed then follow exactly the instruction on the above page

Apparently you don’t have direct access to the graphics card.
Add your user to the groups “video” and “bumblebee”.

See also:

Yes, you can.


The question is whether it makes any sense to do it.
You mainly need the nvidia chip for full 3D performance, and this practically implies the proprietary driver.

And something similar to Bumblebee is built into the latest kernels and Mesa anyway (PRIME)., which also states:

Poor performance when using the Nouveau card Right now, Nouveau does not support reclocking and other power management feature. This cripples the performance of the GPU a lot along with increasing the power consumption compared to the proprietary driver.
Using Prime with Nouveau may not result in any performance gain right now, but it should in a not-so-distant future.

I thought there was a heat problem with it ie the NVIDIA chip never shut down and it drank battery and over heated. But that was a while back. That is why bumblebee and NVIDIA-bumblebee were needed. Then again maybe just bumblebee was needed to control the hardware. I don’t know it is been a while and I don’t own such Rube Goldberg machines LOL

Yes, you needed bumblebee also to just shut down the nvidia card and save power (for this you do not need the nvidia driver installed I think).

But recent kernels should be able to do so on their own.

I don’t know it is been a while and I don’t own such Rube Goldberg machines LOL

Me neither.
And I don’t want one either… :wink:


With NVIDIA-bumblebee i’ve the same result.
If i try to install de NVIDIA packages the boot process take more than 3 minutes… the Xorg log fills with the message:

   262.941] (II) config/udev: Adding drm device (/dev/dri/card1)
   262.941] (II) xfree86: Adding drm device (/dev/dri/card1)
   262.941] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
   262.942] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
   262.942] (II) config/udev: Adding drm device (/dev/dri/card1)
   262.942] (II) xfree86: Adding drm device (/dev/dri/card1)
   262.942] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
   262.942] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1

This don’t happen with previous proprietary NVIDIA driver.

My user is in both groups… I follow this guide too, and didn’t work…

Well, did you install the bumblebee packages included in 13.2, or did you install those from the Bumblebee repo?

Try to switch all to the versions from the repo, or the other way.

Apparently the bumblebeed doesn’t have access permissions then.
Is it enabled and running?

systemctl status bumblebeed

Did you install bbswitch as well?
I have heard reports saying this is necessary, but it is not mentioned in the tutorial for some reason.


dxrxaxx@linux-zji5:~> systemctl status bumblebeed
bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since Sun 2014-11-23 20:57:06 CLST; 7min ago
 Main PID: 2924 (bumblebeed)
   CGroup: /system.slice/bumblebeed.service
           └─2924 /usr/sbin/bumblebeed


I’ve try both repo without success…
I think the problem is a recent opensuse update… with the first release of opensuse 13.2 (with previous proprietary NVIDIA driver) bumblebee works ok.
With the current release of NVIDIA driver my notebook take nearly 3 minutes to start.

Try to revert all updates one-by-one to see what causes it.

Strange though that nobody else has reported something like that yet. If it would be a general problem caused by some official update, (at least some) other people must have the same problem.

And what do you mean with “previous proprietary NVIDIA driver”? AFAIR 343.22 was already the latest (and in the Bumblebee repo) before 13.2 was released. And I just checked, the last change to the nividia-bumblebee package was made 2 months ago…

What does “systemd-analyze blame” say when your notebook takes 3 minutes to start?

NVIDIA in Bumblebee repo never have worked in my notebook (HP Envy15). The proprietary NVIDIA driver actually is 340.58. With proprietary version 343.22 bumblebee work.

systemd-analyze show me a loop with this lines:

           335ms opt.mount
           307ms systemd-remount-fs.service
           293ms systemd-random-seed.service
           279ms systemd-journal-flush.service
           255ms systemd-tmpfiles-setup.service
           253ms systemd-backlight@backlight:intel_backlight.service
           252ms systemd-backlight@backlight:acpi_video0.service
           231ms systemd-readahead-done.service
           228ms systemd-readahead-replay.service
           173ms plymouth-read-write.service
           164ms iscsi.service
           161ms boot-efi.mount
           147ms dev-disk-by\x2duuid-bafacde4\x2de125\x2d42e9\x2db32a\x2dc20acae6858a.swap
           135ms systemd-update-utmp.service
           129ms auditd.service
           115ms systemd-sysctl.service
           112ms DNLD.mount
           111ms upower.service
           101ms lvm2-lvmetad.service
            75ms user@1000.service
            62ms systemd-modules-load.service
            54ms systemd-logind.service
            53ms boot-grub2-i386\x2dpc.mount
            41ms boot-grub2-x86_64\x2defi.mount
            35ms systemd-readahead-collect.service
            30ms home.mount
            24ms packagekit.service
            21ms rtkit-daemon.service
            16ms plymouth-start.service
            14ms lvm2-activation.service
            10ms systemd-udevd.service
             4ms systemd-vconsole-setup.service
             3ms kmod-static-nodes.service
             2ms systemd-update-utmp-runlevel.service
             1ms sys-fs-fuse-connections.mount
             1ms systemd-rfkill@rfkill0.service
             1ms systemd-rfkill@rfkill1.service

If I uninstall the NVIDIA driver my system start normaly.

That would be expected the normal NVIDA driver change a program called mesa which is important to the graphic stack That change breaks the Intel driver. Uninstalling it put mesa back to normal and the Intel driver can work. You can not use the normal NVIDA driver you must use either the NVIDIA-bumblebee driver or the OS driver.It does not make sense to use the nouveau driver since 3D performance may actually be worse then the Intel’s and some 3D game won’t work because not all the extensions expected are there. In any case bumblebee itself is need to control the hardware. Without it you may have over heat and/or short battery life.

You must first of all remove any trace of the normal NVIDIA driver be sure all packages with NVIDIA in the name are removed.

You must then go to the referenced Bumblebee page and follow exactly the instructions in the order they appear. Do not improvise or follow instruction from any where else.

Baring that you will have to turn off one or the other GPU in the BIOS if it is possible for your hardware. If that does not work I’d mention the problem to the idiots that made the machine since they did it wrong. Ok be nicer then that :stuck_out_tongue:

You mean nvidia-bumblebee?
But that just downloads the .run installer (343.22) from nvidia and installs it in a way that’s compatible with XOrg,Mesa and Bumblebee.
And it sets up dkms so you don’t have to bother re-installing the driver after kernel updates.

The proprietary NVIDIA driver actually is 340.58.

No. The proprietary NVIDIA driver is available different versions.
The current ones are 343.22, 340.58 (G03), 304.123 (G02).

If you meant the version in the nvidia repo, then yes, the G03 in there is 340.58 at the moment.
And it cannot just be upgraded to 343, as 343 dropped support for many cards not supported by the G02 driver, everything below GF400.

And AFAIK you should never install the standard driver on a Bumblebee system, as it breaks the Intel driver’s OpenGL support.

With proprietary version 343.22 bumblebee work.

Where did you install that from now?
Download from nvidia’s site?
Maybe that’s what caused your problem.
Try to reinstall it. Some updates overwrite files from nvidia, that nvidia overwrote in the first place.

But still, I would rather recommend to install nvidia-bumblebee.
It should work. What problem did you have with that?

Maybe your issue is caused by the broken intel driver.

systemd-analyze show me a loop with this lines:

Doesn’t show any “hang” unfortunately.
And “systemd-analyze critical-chain”?

I agree with you, The HP UEFI bios is made for Windows. You can´t manage the discrete GPU from bios.
My first option was use nvidia-bumblebee, but the system can´t create the device /dev/dri/card1 (i change the bumblebee-nvidia config file adding the PCI:01:00:1 line). Because of this i try the NVIDIA proprietary driver. With early NVIDIA Opensuse repo. and a fresh Opensuse 13.2, bumblebee work.

Wolfi, NVIDIA driver (from opensuse repo) works when Opensuse 13.2 was released. Later came an update for NVIDIA and blumblebee stop working.

I clean up the system from NVIDIA but nvidia-bumblebee can’t load de nvidia driver.
I re-install Opensuse without luck.
If i check the dev/dri directory there is only card0.

Maybe you had Intel driver black listed. LOL Not sure that would work since the NVIDIA actually renders through the Intel So the Intel has to be in the hardware chain If I understand Optimus right. But there is no way for the Intel driver to work when the NVIDIA driver is installed because the NVIDIA driver has always (in recent memory at least) modified the mesa program and the modified mesa will not work with the Intel. So if you had it actually running it was a fluke since there is no way it should work with the Intel.It might work if you managed to not load or use the Intel driver and only use the NVIDIA. But in that case you are covering ground not covered here before. SO far all that have followed the bumblebee instruction exactly have had success. even though it may have taken a bit to get them to that point LOL. Why it is not working for you I don’t know I do know that there were a few rough edges when bumblebee first arrived but they have all seemed to have been fixed. So have you actually tried the bumblebee install or did you skip it because it did not work sometime in the past???

Intel driver is not blacklisted.
Checking journalctl i find a message about NVIDIA, it say that the driver it’s not compatible with my card (750m).