openSUSE 13.2 + Broadcom 4352 (rev 03) + wl kernel = broken Wifi

Installed openSUSE 13.2 with Plasma 5 on my desktop rig which uses a Broadcom Network Controller. Wifi wasn’t working, so I installed all the broadcom software I could find on YaST’s software manager. Still didn’t work, so I uninstalled them. Then I ran this:

/sbin/lspci -k

Which output this:

Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device 855c
        Kernel driver in use: wl

So looks like it’s still using the broadcom-wl somehow. Could use some help, this is my first time messing around with openSUSE (I had been on Ubuntu-Gnome 15.04 and the BCM4352 worked there somehow). YaST seems pretty robust, but I’m a little unfamiliar with its intricacies and the different syntax still.

Any help would be appreciated.

Well, installing “all the broadcom software I could find” is not necessarily the best to do.
But apparently you did the right thing, as lspci shows that the wl driver is in use. :wink:

Still didn’t work, so I uninstalled them.

You shouldn’t have.
You need the broadcom-wl driver for that device.

lspci still shows wl in use because you didn’t reboot yet I suppose, so it is still loaded even though you uninstalled it.

So, install the packages broadcom-wl and broadcom-wl-kmp-desktop, that should be enough (and is necessary) to make your wireless work.

You write that it “still didn’t work” after installing broadcom-wl, but how do you determine that? I.e. how did you try to establish a connection?
In a default installation (if no supported wireless device is detected), wicked (a successor to the old ifup) is used as network service. You have to configure it in YaST.
If you want to use your desktop’s network icon/settings, you need to switch to NetworkManager (in YaST->Network Devices->Network Services->Global Options).

Okay, so I uninstalled all broadcom packages I could via YaSt, reinstalled JUST the following:

the two it brought up by default upon loading the YaST Software Management (b43-fwcutter & iscsiuio) and

the “broadcom-wl” and “broadcom-wl-kmp-desktop” packages.

Nothing happened, so I rebooted in dismay.

Then upon loading up and reading your post, I followed your directions to configure KDE Plasma’s Network Manager via YaST->Network Devices->Network Services->Global Options and VIOLA!! After it finished I could see wireless networks and connect! Thank you kindly wolfi323. You are a gentleman and a scholar.

Crossing fingers now in hopes for good connectivity and performance. I’ve read snippets of disgruntled BCM4352 owners with Linux systems. We shall see.