openSUSE 13.2 and GTX 970


I have a problem with GTX 970 driver.
I first tried the x11 driver from nvidia repository but my card doesn’t seem to be supported (the pc didn’t even boot after installing it).

Then I have downloaded the last driver on nvidia website - 343.22 - but I have to stop X to install it.
Ok… But run “init 3” in a console give me a black screen and I can’t do anything, I just can restart the pc to get back to the desktop.

Is there some packages to install to have a console with init 3 or ctrl+alt+F1 ?

In GRUB2 hit “e” go to the line where it says “showopts” at the end, add " 3" and hit F10 to boot.
Mind, someone posted on FB that NVIDIA has released a new stable driver. You may need that one for your card.

Thanks for your answer.

I get a black screen too by this way, I have waited a long time but nothing, had to reboot again…
This driver - 343.22 - works well on windows 10.

Here’s my hardware :

  • Asus ROG maximus VII Ranger
  • Intel i7 4970K
  • Gigabyte Windforce GTX 970
  • 16GB DDR3
  • 64GB SSD for linux

So, are you saying you can get to the desktop???

Yep, I have a low-res desktop with X and I have nothing if I stop X or if I try to start console mode or init 3.

I can’t install the driver because it needs to stop X server.

Hi, kpounot](

I am in the same boat you are. I am newcomer to this forum as well as to openSUSE, so, I suspect my way isn’t ‘optimal’. But, at least, I got my GTX970 woking.
As you said, long lived driver branch from nvidia doesn’t support video card yet, but I didn’t use driver you can download from nvidia website as well.
Instead, I used driver from x11-video-nvidia repository ( Under unstable packages it has 343.22 driver (yes, Bumblebee).
I used one click install for that particular driver. The tricky part is that, it seems it installs only 64 - bit driver (I have 64 bit system), so, I had to instal 32 bit driver as well ( Otherwise, Steam will complain that OpenGL GLX context is not using direct rendering, despite the fact, that glxinfo says opposite.
At the end I ran nvidia-xconfig as well.
I tried to play borderlands for an hour and it worked fine.

Only problem is that I don’t get nvidia control panel. It is not in the menu. :frowning: Don’t know how to get it.

Maybe some more experienced SUSE users could share, how to install nvidia drivers properly if card isn’t supported?

On the other hand, when I installed drivers from nvidia I used systemd command systemctl stop someservice.service to stop display manager (gdm or kdm) and it was usually enough to install driver.
Don’t know if it works in openSUSE

I have finally succeeded !!! \o/

It was really simple :

  • download the driver 343.22 on nvidia website.
  • make it executable
  • start it with this sudo sh ./ –no-x-check.

By reading the options in the .run file, I found this advanced magic option !

PS : how can I edit the title to write [SOLVED] ?

No need to add that, it is not normally done here.

I just got myself a GTX 980 and also had to do it that way. It took me a while to figure out why the kernel module wouldn’t load with 340.58!

I was expecting 343.22 (which happens to be the first driver supporting 970/980) to be on nvidia’s stable repos by now to be honest, it was released two months ago.

Well, file a bug report: (same username/password as here)

But the 343.xx driver dropped support for many older (though not so old) cards, probably that’s the reason why it isn’t in the standard repo yet.
And it therefore should not replace the 340.xx driver in any case. It should rather be an additional G04 version IMHO.
IIANM, 343 only supports cards higher than GeForce 400…

That’s a reasonable explanation for the delay, I didn’t know about that. Thanks.