opensuse 13.2 / 64 crashing when doing rsync and large copies over USB 3.0 hard drives.


opensuse 13.2, 64 bits, AMD quad core, 12 GB RAM. I have added a PCI USB 3.0 card to the mobo, and a set of 4TB and 5 TB USB 3.0 drives as well as a couple of internal sata drives.

I have mostly pictures (JPG and RAW from a DSLR) and large .mp4 files from family pictures and activities. When I rsync the files between the drives, quite often the mouse first goes quiet (the arrow no longer moves on the screen) then all drive activity ends and the system is hung. I need to reset it in order to have it boot again. Keyboard input is no good either.

On one internal drive, I still had opensuse 12.2 x64 (iirc) and when copying to/from the same drives, it works. I tried multiple times and on 12.2 works every time. That seems to somewhat rule out an obvious hw failure.

The 13.2 OS is patched to the latest level. It takes some 3 to 5 minutes to crash when I start the rsync between the usb drives.

Now, I received three large USB 3.0 drives and tried to do a raid 5 on them. After I create it and start the rsync, it crashes within a minute. Not sure if the error is the same (I couldn’t get to the crash screen) but the one I’m adding is the crash from copying between non-raid LVM/usb3.0/xfs drives.

Here’s the link:

The image mentions a “kernel bug at blk-core.c 1275”.

Does this seem like an actual OS issue or should I look some place else?


Have you fully updated?

You may want to try a different kernel. Note also that many copy function may make use extensively of /tmp for temp files so check space available on root also memory usage also I’m assuming the target file system is Linux based not Windows


Right now I’m running:

3.16.7-24-desktop #1 SMP PREEMPT Mon Aug 3 14:37:06 UTC 2015 (ec183cc) x86_64 x86_64 x86_64 GNU/Linux

All file systems involved are xfs. At once, when trying options for the raid array, I tried btrfs, same results (corruption of the array after freeze, won’t mount after reboot). I have + 5GB left on /tmp, I’m using rsync to copy.

Let me know if there is anything else I need to do to fully update, and I’ll check it out.

Maybe try a USB 2 port some USB 3 hardware may be problematic

I use rsync (via luckbackup) to back up around 25gig but I don’t have any really huge files in the backup set. Also I use ext4 and the USB is a 2 I think. I have not seen a problem

I can try, but I have multiple 4TB and 5TB usb 3.0 drives. There’s reason for the 3.0 and that’s that 2.0 is way too slow for this amount of data.

Also, I tried iotop while rsync’ing the drives, and it does not show any activitiy on /tmp: only on the usb drives involved.

Again, for what it might be worth, the same copy on the same hardware works every time under opensuse 12.x/usb 3.0.

Just in case, here’s the link again of the crash on opensuse 13.2:

As I said there may be problems with USB 3 on some hardware. Some recent posts implied that reverting to a 13.1 file may fix the problem. You may want to do a search