OpenSuse 13.1 won't display login

PS: another thing I would suggest to try is to disable plymouth, the boot splash.
If you boot to text mode, it won’t be running any more when you start the login screen/Xorg.
But if you directly boot to runlevel5 it is still running at that point and might cause problems.

I.e. try to add “plymouth.enable=0” to the boot options.


“autofs” is a service to automatically mount things.
If you don’t know what it is, you likely won’t be using it though, as you would have to set it up manually.

Anyway, “systemctl status autofs.service” should tell.

I do have some lines I added to /etc/fstab, but it turned out that those volumes couldn’t be mounted on this system. I think I’ve seen error messages about them not being mounted along with the “can’t start X” error when I tried to start from safemode (and in the journalctl output obl1x mentioned), because I never got around to removing them. But that command reports that autofs is disabled/inactive.

I wouldn’t uninstall the radeon drivers. But adding “nomodeset” to the boot options would disable them.

On the linux line?

I.e. try to add “plymouth.enable=0” to the boot options.

This just boots me into text mode.

Alright, I think we are coming closer to the actual problem now.
There were other people that experienced the login screen not being started any more after the systemd upgrade.
The reason: xdm.service requires the $remote_fs “service”, and the new systemd apparently handles that more strict or something.

So if you have a remote filesystem mount in fstab and that fails, xdm.service will not be started at all.

Try to comment out all unnecessary lines in /etc/fstab (i.e. put a ‘#’ at the beginning), I hope the login screen will appear then.
Maybe also post the content of the file.

On the linux line?

Yes, like you did with ‘3’ before to boot to text mode.
But as I said, I don’t think it is a graphics driver problem, as Xorg/the login screen works fine if you start if manually.

This just boots me into text mode.

Right. This probably means that xdm.service isn’t started at all as mentioned.
And the “blank screen” you saw before probably was just plymouth, the boot splash, and not Xorg.

Hey, that worked! Thanks. The login screen is completely different-looking now, though.

So I’d suggest to find out which one fails and reactivate the others.

Also adding “nofail” to the mount options should prevent such a problem.

The login screen is completely different-looking now, though.

Well, I suggested trying to switch to “xdm” in /etc/sysconfig/displaymanager.
If you did that, you need to switch back to the previous one again, i.e. DISPLAYMANAGER=“kdm”.