opensuse 13.1 won't boot after mysql install

Hi all,after a hassle I was able to dual boot opensuse 13.1 and the preinstalled windows 8 that was shipped with the toshiba s50-10-v laptop.I have been trying to install mysql in the opensuse and while the installation seems flawless from here I can’t run the

mysqld start 

command as instructed here.(I’m sorry i can’t post the error message as i’m locked out the linux partition at the moment).After restarting the machine it only gets to the chameleon splash wallpaper then goes off without any error message. I have tried the mysql installation twice now with the same results .The first time I resulted to reinstallation of opensuse 13.1 but now I don’t want to go down that road again could anyone please give me clues on how I should go about this

On 2014-02-09 15:36, mik a wrote:

> --------------------
> command as instructed ‘here’
> (http://en.opensuse.org/SDB:MySQL_installation).(I’m sorry i can’t post
> the error message as i’m locked out the linux partition at the
> moment).After restarting the machine it only gets to the chameleon
> splash wallpaper then goes off without any error message. I have tried
> the mysql installation twice now with the same results .The first time I
> resulted to reinstallation of opensuse 13.1 but now I don’t want to go
> down that road again could anyone please give me clues on how I should
> go about this

I don’t see how installing myslq from the repo could impede booting to
complete.

We’d need to see error messages…


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Thanks for the reply but how would I go about making it show error message while booting since it only gets to the wallpaper then shuts down

On 2014-02-09 16:26, mik a wrote:
>
> Thanks for the reply but how would I go about making it show error
> message while booting since it only gets to the wallpaper then shuts
> down

Try using a live or rescue system.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

If you see the chameleon splash wallpaper, press “Esc”. Then you should see messages.

regards,
Hendrik

Hi,sorry for the late reply .Here are the errors that are spit out.Imgur: The magic of the Internet

The laptop doesn’t shut down completely. Press the power butten for > 4 secs and it will turn off. Then press it again and the laptop will boot.
Another thing: this can indeed be mysql related. Question: is this on KDE?

yep its running on KDE ,I tried what you suggested and nothing happened .

mik a wrote:

>
> Thanks for the reply but how would I go about making it show error
> message while booting since it only gets to the wallpaper then shuts
> down
What does this command say?
CODE:

systemctl status mysql.service

Mine says:

x5b8:~> systemctl status mysql.service
mysql.service - LSB: Start the MySQL database server
Loaded: loaded (/etc/init.d/mysql)
Active: active (running) since Tue 2014-02-11 08:00:03 PST; 55min ago
Process: 2953 ExecStart=/etc/init.d/mysql start (code=exited,
status=0/SUCCESS)
CGroup: /system.slice/mysql.service
├─3060 /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld –
user=mysql --pid-file=/var/run/mysql/mysqld.pid…
└─3273 /usr/sbin/mysqld --basedir=/usr –
datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin …

If it is not active, try substituting stop then start and see if it
starts.
Hope this helps
Russ

openSUSE 13.1(Linux 3.11.6-4-desktop x86_64|
Intel(R) Quad Core™ i5-4440 CPU @ 3.10GHz|8GB DDR3|
GeForce 8400GS (NVIDIA-Linux-x86_64-331.38)|KDE 4.12.2

Thanks for the reply but where would I put these commands since upto now i cannot boot .I tried pressing esc as adviced earlier when the wallpaper appeared but nothing happened then pressed F2 which showed the above errors

I see some nouveau error messages on your photo. Have you tried recovery mode already? (“Advanced Options” in the boot menu)

Another thing I would find likely given your screenshot is that somehow you set “shutdown.target” as default target your system should boot to.
Add “init=/bin/sh” to your boot options and you should get in a text mode system.
(press ‘e’ at the boot menu, search for the line starting with “linux”, append “init=/bin/sh” at the end, and press ‘F10’ to boot)
Then please run the following command and post a picture of the output:

ls -l /etc/systemd/system/default.target

If it points indeed to “/usr/lib/systemd/system/shutdown.target”, run the following to fix it:

ln -sf /usr/lib/systemd/system/runlevel5.target /etc/systemd/system/default.target

I tried the recovery mode at first but that did not change anything.Through the procedure you’ve given here’s the output

 /etc/systemd/system/default.target  -> /usr/lib/systemd/system/runlevel0.target

Right, so your system boots to runlevel0, which is poweroff.target, that’s why it immediately shuts down on boot.

So run that line I posted earlier in that text mode to make it boot to the standard runlevel5 (i.e. graphical system) again:

ln -sf /usr/lib/systemd/system/runlevel5.target /etc/systemd/system/default.target

Or, (this might be easier to do) append the number “5” to the boot options (like you did before with “init=/bin/sh”) to do a normal boot, and then change the default target to “runlevel5” in YaST->System->Services Manager.

You may have accidentally changed the default target when trying to enable the mysql service.

Thanks man,it worked :).Yeah I do remember looking for the mysql service in Yast but couldn’t and still can’t find it .But what are the odds i could do this twice since this is the second time its happened to me with mysql installation

Have you installed all updates? (YaST->Online Updates f.e.)
There was a bug in the shipped version that it didn’t show old-style sysvinit services (like mysql is). But that’s been fixed with an official update.

You can also enable mysql (and other services) like this:

sudo systemctl enable mysql.service

This will start it automatically on boot.

If you want to start it now, run this:

sudo systemctl start mysql.service

But what are the odds i could do this twice since this is the second time its happened to me with mysql installation

Well, something like this never happened to me.
But at least you know now what to look for and how to fix it if it happens… :wink:

The update is what I needed thanks a lot for the help

DATE : 17/09/2014

Hi! I also encountered same problem yesterday and in same situation i.e. after installing mysql community server and mysql-client.
My error messages were same(identical) as those got by person asking this query.
I followed all steps starting from(on page 2 of thread)
(a)“Press e at the boot menu. search for line starting with linux, append “init=/bin/sh” at the end, press F10 to reboot”


Followed exactly same steps, got exactly same result, in my case also system was booting to runlevel0 which is poweroff.target and hence system was shutting down without even getting to the chameleon splash wallpaper.

After changing runlevel as described in post, i could easily reboot normally.
The solution described in the post worked EXACTLY lol!. THANKS A LOT FOR THIS POST. IT PROBABLY SAVED MY HOURS/DAYS.

I AM POSTING THIS JUST TO RECORD THAT THE BOOTING PROBLEM STILL EXISTS AFTER INSTALLING MYSQL COMMUNITY SERVER AS ON 17/09/2014]. SO SOMEONE MAY FILE BUGREPORT (I am still a novice and do not know how to do it properly). ALSO GOOD THING IS THAT PROBLEM IS SOLVED BY FOLLOWING INSTRUCTIONS IN THIS POST WORD-TO-WORD. HATS OFF TO THE GUY WHO SOLVED THIS.

THANKS TO ALL OF YOU.

I don’t think that the installation of mysql-community-server changes the default target to runlevel0.
The package does not mess with the default target/runlevels at all AFAICS.
And I never experienced anything like that here at all.

Probably you did it yourself by mistake when trying to enable mysql in YaST->Services Manager?

I cannot reproduce this issue in a VM either - I’ve used both MySQL 5.6 and MariaDB without any issues - startup or shutdown.

On 2014-09-17 11:36, minusquare wrote:

> I AM POSTING THIS JUST TO RECORD THAT THE BOOTING PROBLEM STILL EXISTS
> AFTER INSTALLING MYSQL COMMUNITY SERVER AS ON 17/09/2014]. SO SOMEONE
> MAY FILE BUGREPORT (I am still a novice and do not know how to do it
> properly). ALSO GOOD THING IS THAT PROBLEM IS SOLVED BY FOLLOWING
> INSTRUCTIONS IN THIS POST WORD-TO-WORD. HATS OFF TO THE GUY WHO SOLVED
> THIS.

Only a person that has this issue can report it… Only you can provide
logs and details.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)