OpenSUSE 13.1 wireless problem with firmware Ralink RT3290 (kernel

I did not see any post on this (except one on Dec 2013 with on OpenSure 12.3 I believe) and I hope this is not a repeat. If so please redirect me.

I am having a problem with wireless network on OpenSUSE 13.1 (64 bit)
The computer I have is HP Envy h8-1534 and the wireless pci card is Ralink RT3290.

I have done an update of kernel which installed 4.0.0-1.1.g49e42b3.x86_64.rpm

The behavior of the wlan network is as others reported in these forums: wlan will sometimes be on, it will broadcast all available wireless devices, and it will connect to the router I have (Belkin 1200 AC). Then, either immediately, or after half an hour or so, it disconnects, my router disappears from the list of available wireless devices. After a while All wireless devices disappear and I can t see ANY broadcasting wireless devices.

I am controlling wlan via NetworkManager as Global options in Yast Networks settings is set to “User controlled with NetworkManager”

The driver is rt2800 for some reason (i.e. not rt3290) as lsmod Command gives

rt2800pci 16384 0
rt2800mmio 20480 1 rt2800pci
rt2800lib 94208 2 rt2800pci,rt2800mmio
crc_ccitt 16384 1 rt2800lib
rt2x00mmio 16384 2 rt2800pci,rt2800mmio
rt2x00pci 16384 1 rt2800pci
rt2x00lib 61440 5 rt2800pci,rt2800mmio,rt2800lib,rt2x00mmio,rt2x00pci
mac80211 790528 3 rt2800lib,rt2x00pci,rt2x00lib
eeprom_93cx6 16384 1 rt2800pci

dmesg command gives

ieee80211 phy0:rt2800pci-set device state:Error Device failed to enter state 4 (-5)
rt2800-wait.wp dma ready: Error WPDMA TX/RX Busy

I don’t quite understand what these say but I thought they would be useful to expert people like yourselves.

On the Dec 2013 report on the same device the solution found, if I understood correctly, was to remove the secure boot and boot OpenSUSE via UEFI.
This is how my system is set up and I still cannot have a stable wlan. Any help will be appreciated.

Actually I too had this problem an year ago and What I did was installing kernel-firmware instead of ralink-firmware to sort out the issue. I am not sure whether this will help you

nishanth9042, thank you for answering my problem.

While I was waiting for answers I did recall reading someone in these forums suggesting to remove 802.11n from the router .

So I tested that today it it worked.

That is, I set the router to broadcast only 802.11g. ( Previously 802.11n was among the protocols it broadcasted.)

And it WORKED. wlan has been on since this morning with no glitch. :slight_smile:

Thanks again.