Opensuse 13.1 Thunderbird, Firefox and update not working

I installed OpenSuse 13.1 for a friend on raid based hardware. Everything worked fine until she tried to do an update and things started to go wrong. Normally this is not a problem as I can see what is happening, but this time she lives 500 miles away.
Anyway when she tries to load thunderbird or firebird using the normal short cut nothing happens apart from a jolly icon bouncing up. Konqueror works OK. If she tries to start thunderbird using the terminal she gets the message

XPCOMGoueLOAD error for file /usr/lib64/thunderbird/ can not open shared object file no such file or directory
Couldn't load XPCOM

Similar for firefox
So what have I done
Deleted Bluetooth software as this was also throwing error messages and tried to delete flashplayer which it would not do.
Tried an online update which was stopped because of flashplayer update
Run zypper patch, rpmdb --rebuilddb
Deleted .cache, .kde, .kde4
Rerun online update and ignored the warning about flashplayer
What do I need to do?
It is possible that I have missed something obvious if so please let me know
An alternative that I was wondering about was whether to install Remote administration VNC and try to make the changes myself remotely. I have never done this before so it involves some risk. So again any help or pointers gratefully received

Thanks in advance

Apparently something (or someone) deleted
This is contained in the package “libcairo2”, so re-install that to fix it:

sudo zypper in -f libcairo2

I don’t understand that part about bluetooth and flash-player though.
How did you delete the bluetooth software?

Which warning do you get when installing flash-player?
Flash-player needs you to accept a license agreement. Is this the “warning” you mean?
If you use Apper (KDE’s update applet) to install/update it, a popup is shown that you didn’t agree to the license even before the license is shown.
Ignore that, it’s a cosmetical flaw in the applet. Click on “I agree” (or whatever it is called) in the license agreement window that appears, and it (and all the other updates) should install fine.

Or use Yast->Online Update or “sudo zypper up” to do the updates, but those would require you to accept the license as well.

Thanks Wolfi for such a rapid reply
Will get her to re-install libcairo

Used software services to delete bluetooth.
The warning was that the update required the deletion of flash player that could not be done. It was not the licence thing.
Will also invoke the zypper up after the installation of libcairo

But what package(s) exactly?
Removing bluetooth should not have any influence on flash-player or libcairo.

I take it that with “software services” you mean YaST, right?

The warning was that the update required the deletion of flash player that could not be done.

I don’t understand why an update would require the deletion of flash-player.
I guess the exact wording of that “warning” would shed more light on the issue… :wink:

Maybe try to re-install flash-player as well:

sudo zypper in -f flash-player

This should also install possibly missing dependencies.
Missing dependencies, i.e. uninstalling a package that is required by flash-player, would be the only reason I can think of why it would be “required” to delete flash-player.

Thanks again Wolfi
I will post the results of the actions when my friend returns (as I said there is 500 miles between us)
Yes Yast.Bluedevil and bluez and associated libraries but not the libbluedevil2 because it was used by too many other packages
I did not understand why it needed to delete flash player either but I can not give exact wording at present as I do not have direct access to the computer
Will let you the results, hopefully soon

Well she has returned and the problem has been solved. It turned out it was elswhere and it was caused by two instances of the same repository the repo/oss one. Deleted one and it all worked apart from a couple of other small problems which were easily solved

Thanks again for your help

Hm, having the same repository twice should not cause any problem.
But maybe one of them was from a different openSUSE version?

Anyway, glad to hear it’s sorted now! :slight_smile: