openSUSE 13.1: There is no update candidate for kernel-desktop-3.11.10-11.1.x86_64

since one or two days the auto-update application (indicated by a little bug icon next to my system clock in the openSUSE 13.1 KDE Desktop) shows me a list of update,
mostly nvidia driver related, but an error keeps all of them to get applied.
The error is:
openSUSE 13.1: There is no update candidate for kernel-desktop-3.11.10-11.1.x86_64

iam not so worried at the moment because i read that this can happen from time to time if the updates are very new, because sometimes the repositorys are not fully updated.

But maybe it has a different reason in this case, is there something i can do to check?

Probably caused by the problem that nvidia-uvm-gfxG03-kmp-desktop is now installed by default, and that requires kernel 3.11.6.
See also:

Try to install the updates with YaST->Software Management or “sudo zypper up”.
If in doubt, please post the conflict messages you might get.

Or maybe installing kernel-desktop-3.11.6 manually (in YaST->Software Management, or by running “sudo zypper in kernel-desktop-3.11.6”) might solve your problem as well.

PS: the dependency issue with the nvidia packages has been fixed already, but it might still take some time until the fixed packages appear in the repo of course.

So just wait and the problem should resolve itself. :wink:

Updating via sudo zypper up worked.
I never used that way before so iam not sure if all of the console output from which some looked very similar to compiler/valgrind error outputs but in the end it finished without any regular error message. after a reboot all seems to work fine.

Zypper is actually better then Apper (the one that notifies you) But either will do an up the Yast version does a patch only . Yes there are differences.

An up (date) brings in newer packages as available
patch only brings in patches to current versions of software to correct bugs

In zypper you can do zypper patch

there is also dup to do a distribution upgrade Use this one only if moving to a newer OS version or using Tumbleweed.

YaST->“Online Update” does a patch only.

YaST->“Software Management” and choosing “All Packages”->“Update, if a newer version is available” from the “Package” menu will do the equivalent of Apper/zypper up.

And you can configure Apper (or PackageKit rather) to only do a “zypper patch” as well, but I’m getting off-topic now… :wink:

On 2014-06-06 20:56, wolfi323 wrote:
> YaST->“Software Management” and choosing “All Packages”->“Update, if a
> newer version is available” from the “Package” menu will do the
> equivalent of Apper/zypper up.

And it is easier see and solve conflicts in there, IMO.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Yes, I fully agree with that. :wink:

And you can revisit all updates and unselect specific ones interactively f.e., or choose to change certain packages to a version from a different repo instead.

“There is no update candidate for kernel-desktop-3.11.10-11.1.x86_64”

Different user, same problem. Tried Yast Updates, did not solve problem. I am running a production system and cannot afford to break it. Is this a major problem for many users, or just a small percentage?
I have 31 updates that I cannot install, and I think that the Kernel and/or NVidia updates should be separate from the others.

You won’t break your system by not installing the updates.

I have 31 updates that I cannot install, and I think that the Kernel and/or NVidia updates should be separate from the others.

The nvidia and/or kernel updates are separate, but the nvidia packages have too strict dependency (on kernel 3.11.6) at the moment, which causes this problem.
See also:

Just deselect the nvidia packages in the update applet and you should be able to install the other updates.
And then wait until the fixed packages appear in the nvidia repo. They have been fixed by openSUSE yesterday already, but I don’t think anybody at NVidia will put them on the server during the weekend.

Or install the package “kernel-desktop-3.11.6” (select the package in YaST->Software Management and click on “Versions” below the package list, or run the line below), then you should be able to install all updates including the nvidia driver.

sudo zypper in kernel-desktop-3.11.6

Installing that kernel will not change anything on your system, you will still boot the latest 3.11.10 kernel afterwards (as long as you don’t select 3.11.6 manually in “Advanced Options” in the boot menu).

I deselected the NVidia options and got the same message as before. Seeing that it will only take a couple of days, I will wait. Thanks for the quick response.

I’m running OpenSUSE 13.1 x64 with KDE and Nvidia 9500gt Video . . .

I used Yast to install some waiting updates instead of Apper, and left the Nvidia stuff alone. Most of the others were some multimedia, etc.

I was getting the same “no update candidate” error on my non-production system so I tried the “sudo zypper up” command for the Nvidia stuff . . . it didn’t crash the system, but now I’m stuck with a very low-res KDE desktop that I cannot adjust the screen res on. The app menu now takes the entire screen when it comes up.

Not sure where to start fixing this one . . .

Try booting a different kernel. (“Advanced Options” in the boot menu if you use grub2)

And please post the output of:

rpm -qa | egrep "(nvidia|kernel)"

I’ve had to revert to G02

For some reason G03 is broken for me

And I’m using the Lord_LT repo (I couldn’t even try the G03 from this repo because it complains of a dependency issue)

I too had the screen res issue

But fortunately have the experience to fix it

BTW: Where did kernel 3.11.6-4.1 come from?

You “fixed” it by changing to the G02 driver from the Lord_LT repo? But that’s hardly a fix, is it? :wink:
Would be interesting to see the Xorg.0.log if the driver installation is ok and the issue appears despite of that.

But what’s not quite clear to me:
Did you use that repo before? Or did you switch to using that repo now?

If there is a problem with the driver, this should be reported.
The wrong dependency has been reported and is fixed already, but the fixed packages are not yet in nvidia’s repo.

BTW: Where did kernel 3.11.6-4.1 come from?

That’s the kernel that is shipped with openSUSE 13.1.

I don’t have time to dig in to this ATM
I was using the nvidia repo not Lord_LT before

‘nvidia-gfxG03-kmp-desktop-331.79_k3.11.6_4-26.1.x86_64’ works OK with the GeForce 8600 GTS I’m using.

Sorry that took so long, but I had family stuff to deal with. :slight_smile: Here’s the output you requested:

bruces@linux-wwtm:~> rpm -qa | egrep "(nvidia|kernel)"


Now, here’s another little kink . . . I rebooted the machine a second time after turning on SSH to make it easier to read a regular terminal screen and discovered that the screen res issue seems to have fixed itself. I changed nothing that had to do with the display adapter, screen, or any of that either. I have my regular screen back and everything seems to be working properly at the moment. Strange, to say the least.

Maybe a hard reboot reset the hardware

This is how it looks with 03 or 02 from nvidia repo, neither work
That kinda doesn’t look that bad but that is the entire width of the 24 inch screen

This is the log

02 from LT works with this log