openSUSE 13.1 Remote Desktop: Documentation Needed

Hi,

I’m trying to find a guide for setting up remote desktop access on openSUSE 13.1, but everything I’ve found is outdated and a lot of the documentation is poorly written. If someone can start a wiki on remote access and openSUSE 13.1, I can edit and add to it. What is the best solution for remote access of an openSUSE 13.1 computer? Is TightVNC the preferred solution*?*

Remote access setup on Linux is a bit of a pain, whereas with Windows you can just download a portable .zip of TeamViewer or use the built-in RDP client and it just works after opening 1 port*.*

Hi
So if your familiar with teamviewer, then use that on your linux machine?

Well what is the SUSE preferred way? When enabling remote desktop in YaST, it wants to install a ton of Xorg packages. Is this necessary? I am trying to stay away from proprietary software.

Hi
I use ssh and NX on my SUSE Linux Enterprise systems, openSUSE ssh and NX, vinagre would be the other. So many choices, which again is dependent on your network, bandwidth considerations etc.

It all depends on your requirements, most stuff I do is via the command line or use ssh -X…

I occasionally have to connect to a remote (Windows) server via VPN for work. I’m a KDE user, and use KRDC (Remote desktop client) using the RDP protocol. Some users like using VNC for remote desktop access.

Here’s a VNC guide (KDE-orientated)

So if I were to want to connect via VNC from one SUSE box to another, do I have to have all that xorg bloat install just because of ticking one option in Remote Administration in YaST?

I get an error when I try to run vncserver; what does this mean?

pirithous@linux-hkxg:~> vncserver
**xauth: (argv):1:  bad display name "linux-hkxg:2" in "add" command**

New 'linux-hkxg:2 (pirithous)' desktop is linux-hkxg:2

Starting applications specified in /home/pirithous/.vnc/xstartup
Log file is /home/pirithous/.vnc/linux-hkxg:2.log


I get the same, but when I then invoke the client with

vncviewer linux-bbgi:2

it does work.

You didn’t mention whether you’re trying to access graphical desktop, or just require CLI access? Which desktop environment? KDE has a nice tool that lets you configure desktop sharing using krfb?

How can you expect to have a remote GUI… without actually having GUI on the machine you’re trying to administer?

You could always tunnel X applications via SSH and use them on the server that way instead of running a full interface.

I’m using KDE, but the openSUSE box I want to connect to is running Xfce.

I see your point, but all I was wanting to do was view the screen, not have a totally separate session. Why are all the xorg packages being installed through YaST when enabling remote administration, whilst invoking the vncserver command via the command line works (I tested using localhost) without all those packages being installed?

I’ve never investigated the YaST Remote Administration utility or its requirements. Hopefully, someone else can advise further about that.

BTW, As there are security disadvantages with some remote desktop connection methods, you may want to clarify about whether you need to connect over the internet, or just within a secure LAN environment.

I want to be able to connect over a secure LAN as well as over the internet, and I don’t need to have a separate X session. Where I’m stuck now is with the Xfce box. I’ve opened the ports in the YaST firewall by selecting the predefined rule set “VNC” and “VNC Server” under “Services to Allow”. Concerning the YaST firewall settings on my KDE box, there is only “VNC” listed. Which one am I to use, and why the differentiation between the two DE’s? YaST isn’t telling me which ports the predefined rule sets are opening which would be a nice feature, so I’m in the dark until I figure out what it’s actually doing, finding where the file is that YaST writes to for firewall settings; I’m guessing it’s located at: /etc/sysconfig/SuSEfirewall2

When I try to connect to the Xfce box from my KDE box after doing what I did above with the predefined YaST firewall rule set, as well as running the command “vncserver” on the Xfce box, all I get is a blue background and that’s it. I’m obviously doing something wrong. I’m guessing I need to open 5900 and/or 5901.

http://paste.opensuse.org/images/3187144.jpeg

Well, I found that it’s running on port 5904 (probably because of other active X sessions on the machine) and was able to connect to the Xfce machine from my KDE box with KRDC. However, all I get is X. Is there a way I can get the actual video of the screen?

I found out that you have to edit the xstartup file located at ~/.vnc and replace this:

#!/bin/sh
xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

With this:

#!/bin/sh
dbus-launch /usr/bin/startxfce4

And it now works. Except, is there a way to set vncserver to only use 5900 or 5901 so I don’t have to have 100 ports open (or however many the predefined YaST Firewall rule set opens), as well as sharing the session with what’s already on the physical machine?

Interesting and a reminder for me. My main server(now 13.1) have been running sins openSUSE 12.1 and rolling updates after that.

My ~.vnc/xstartup:

#!/bin/sh

unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &


I always start vnc with:

vncserver -geometry 1100x900

and receive a terminal number in return. Ineffective? Maybe but it works for me.

regards