openSUSE 13.1 RC2 DVD Installation Issues

So, wanting to test out some software on the next openSUSE 13.1, I have installed openSUSE 13.1 onto an external, USB3 PC port, using an USB3 hard drive enclosure which has a 128 GB SSD inside. Disk details …

1. /dev/sdb MBR formatted with Generic Boot code in MBR 
2. /dev/sdb1, primary  swap Partition, SWAPprimary Partition,  
3. /dev/sdb2, primary ext4 Partition, marked active and loaded with Grub 2, / root partition 
4. /dev/sdb3, primary ext4 Partition, /home partition  

I do have it up and running, but I had the following issues:

1. Generic boot code was not placed into the MBR disk as requested.  Had to fix 
2. Partition / root was not marked active for boot, grub 2 was loaded there.  Had to fix 
3. fstab file was missing several default settings which I added. 
4. KDE was not set as default desktop  

Has anyone else tried the full install from the openSUSE 13.1 RC2 DVD by chance?

Thank You,

I have, but not to an external drive. I did install RC1 to an external drive.

For my regular install, I wanted grub stored in the “/boot” partition, which it did.

As for “fstab” – I am not seeing any problems. There are less entries than previously. It looks as if some system mounts are now handled without corresponding “fstab” entries.


On my RC1 install to an 80G external drive, it wanted to install grub in the MBR of the wrong disk. I was able to fix that by clicking on “boot loader installation details” and making the external drive the first. That worked, grub was installed in the MBR of that external drive and it booted fine when I told the BIOS to boot the external drive.

The following was missing from the fstab file.

proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

After I made the first post here, openSUSE 13.1 RC2 seemed to crater for some reason. I am not sure how good the DVD image is, but I do not have a good feeling right now.

Thank You,

Those were not in my “fstab” either. But they are not missing. They are merely absent. They are only missing if they are needed. They do not seem to be needed.

My 13.1 system has all of the usual mounts, similar to what I see with 12.3. So evidently, those “fstab” entries are not needed.

I have not had any “seemed to crater” problems.

They are even removed on upgrade (but not when doing it via “zypper dup”) and that’s on purpose.
They are not needed (on 12.3 already) because systemd mounts those filesystems automatically.

If they are in the fstab, they can even cause problems (at least in GNOME apparently):
Re: [opensuse-factory] release notes 13.1 review

On 2013-11-04 20:56, jdmcdaniel3 wrote:
>
> The following was missing from the fstab file.

Those entries are deprecated. Don’t create them, as systemd now handles
that.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

In reply to the question, I have, to an internal second hard drive in a desktop PC. I reported on it here in post#73: https://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/491654-opensuse-13-1-rc2-release-candidate-2-post-observations-here-2.html#post2595308

It was for a 32-bit PC (w/2GB RAM), to an LXDE desktop, and the install was successful.

Thanks for the info oldcpu. Mine was a 64 bit full DVD install and so far I have been trying every openSUSE 13.1 install on my small Dell XPS 13 Ultrabook which may have issues though openSUSE 12.3 has worked like a champ on it. I do have a genuine concern for the final openSUSE 13.1 release though the KDE LiveUSB I made did work OK for me. I do wonder about the final art work also as to what it will look or if we already have what we will get.

Thank You,

As far as I know, we already have the final art work.

Yes, it is not much different from 12.3. I gather they decided that good art work was hard enough that it did not need to be changed for every release – maybe every second release.

So I tried a new external hard drive, burned a new DVD, but used a DVD-R this time and reinstalled three times, but in the end, my attempt to have an external MBR partitioned hard drive boot disk with openSUSE 13.1 was not successful. It starts, but after a short while, the KDE desktop goes away and you have a locked up terminal screen. On the last install, I did get a full online update to work, but the busted KDE setup was the result. This laptop, a Dell XPS 13 Ultrabook, worked like a champ with 12.3, internal and external. The issue for me may be a bad KDE update, but what ever it is, it is bad, for me anyway.

Thank You,

I was successful last night in helping a colleague install on a Sony Viao Pro 13 Ultra’s SSD drive, the 64-bit openSUSE-13.1 RC2 using the Installation .iso via a USB stick (created via ImageWriter). The install was successful.

The one major hiccup requiring a work around was the need to copy the openSUSE ‘shim.efi’ on top of the ‘bootx64.efi’ (and I wrote about this install elsewhere).

I confess the ‘ease’ of the install surprised me significantly. So much so, that after a openSUSE -> Windows8 -> openSUSE boot test, my colleague looked at me and asked “whats wrong ? you look disappointed that the install worked” . I noted that I was ‘not disappointed’ , rather I was very surprised. I’ve read in a few places (the forum, and buzilla) how users tried many things and failed to get openSUSE-13.1 beta/RC versions (including RC2) to work on this Sony Ultrabook, so for it to succeed so easily was a very BiG surprise to me (and maybe a big thankyou to ‘nrickert’ for posting on this subject and basically teaching me about UEFI/EFI implementations with openSUSE).

So my openSUSE 13.1 installs have went OK and allowed one online update. I am willing to put my openSUSE 13.1 problems to some sort of hardware issue with my new Dell laptop. Because openSUSE 12.3 had no such problems, whatever is wrong just came up with openSUSE 13.1 in my opinion. I see we will get a newer kernel (3.11.7) and we get one last round of fixes. I was unable to determine the problem with my laptop setup and can only hope for the best on the final release. Normally I skip over a PC issue and try a different computer. Due to my present situation, I am sticking with the laptop testing and hope someone else will find and report the problem I ran in to.

Thank You,

I was able to install successfully on a Sony VGN-FW235D laptop the openSUSE-13.1-KDE-Live-Build0041-i686 version and it seems to be working fine on the Virtual Machine. I installed the same version on my desktop which is a 64 bit machine. I tried to install on the desktop (VM) the 64 version, first openSUSE-13.1-KDE-Live-Build0041-x86_64 which hangs with the bottom green bars. I downloaded the same version with my laptop and attempted again and it hanged on the same spot. I downloaded openSUSE-13.1-KDE-Live-Build0084-x86_64 and it hangs again this time giving some info:
openSUSE-13.1-KDE-Live-Build0041-x86_64.iso(i forgot how to insert images) but basically is a call trace which provides some info and it hangs.

Never had any problems with any versions in the past on this hardware and I used it since ver 12.0. What should I do? open a bug? Please let me know.
Thanks

If you are able define the problem, I would file a bug report. I actually got a LiveDVD install to work in a VM for openSUSE 13.1 and its the only thing I can play with for now. Not sure what else is wrong but I greatly appreciate users like you willing to help test openSUSE 13.1. Thank you VERY MUCH!

Thank You,

Hi jdmcdaniel3,
I can reproduce the error so I can (I think) define the issue. As I said I was able to install on a VM on the same hardware 13.1 -32 bit, so there is something specifically to my hardware that the 64 bit in hangs on. I will add the picture with the error tonight as soon as I get home. Where should I open the bug. I will fill the bug tonight(in like 10 hours).
thanks

well i can reproduce the error, cause it never gets finished. The thig is that at first attempt(the other day) i got a screen with some steps and errors which unfortunately i didn’t save.
is there a way to get what was executed up until it gets stuck? i get the green bar moving up to a point and then it’s stuck. not sure what and how to report the bug. any suggestions?

definitely there is something wrong with the KDE live 64 version as I’m able to install the NET for the 64 bit. How to find out what is wrong? that is the question!

Well I was not able to place blame myself, but a KDE problem is very likely indeed in my mind. And, it seems to pop up after you do an update the first time. Switching to GNOME or another desktop might allow more trouble shooting perhaps.

Thank You,

i guess i was talking to early. this failed a bit later on during the installation. In fact i had to kill it remotely as I didn’t have any control on the VM any longer.

So, one more install for openSUSE 13.1 RC2 to an external USB 2.0 hard drive seems to working well this time. My other try’s used an external USB 3.0 enclosure and got a questionable KDE 4 update after the install. Today, the first update pulled in more than 1600 files for a humungous update that seems to be working properly this time. Yea!

Thank You,