openSUSE 13.1-rc1 observations

I downloaded and installed the live kde version of openSUSE 13.1-rc1.
The boot problems are fixed YEA!!!
The live usb does not boot in efi mode work around is to set bios to legacy boot

Still downloading here. I’ve downloaded the live isos, but the DVD iso download is still in progress. I’ll wait till all is downloaded before I try installing.

I will test the live USB on my EFI box.

I’ve noticed that when I close an application in a GNOME installation that the background stays white or sometimes it looks like the screen does not redraw itself and an image of the application continues to show on the screen. Has anyone else seen this?

Played around a bit with the KDE Live USB, x86_64. Looks good, works OK in both UEFI and Non-UEFI

Just got Xfce 64 bit up and running on my Optimus netbook. Had only minor problems with Overman79’s factory repo, we still need to add user to the bumblebee group, run “systemctl enable bumblebeed” and, very important, remove nvidia from INITRD_MODULES and DOMU_INITRD_MODULES. Having done that bumblebee works great so far. Oh, there’s a problem with lightdm, probably language related, so I’m usig xdm instead.

Installing I got this error

EFI distributor id isn't specified

Happens here too, especially if using multi-monitor setup. Only sometimes, and in multi-monitor case I got it working again by turning secondary monitor off and then on again. I have Intel Sandy bridge HD graphics 3000.

I still have the problem running 32-bit java environments under 64-bit OpenSUSE (IBM Lotus Notes, and other commercial software uses bundled 32-bit java). That is quite a showstopper for me at this moment.

Other than that, Gnome 3.10 new status menu has multiple problems with network handling:

  • My mobile broadband does not work (sim pin code unlock does not work), also after suspend/resume there is multiple entries for mobile broadband connection
  • Lan connection is not selectable from menu at all, and its status is not shown correctly. Only way to choose which LAN connection to use is to go to network settings

If I’m not mistaken, I think that might be the graphics I am using here as well for graphics. Maybe it is an issue with the Intel drivers in the mainline kernel. Oh well, it DOESN’T seem to affect KDE and there were no issues in openSUSE 12.3 GNOME or SUSE Linux Enterprise Desktop 11 SP3 so I might stick with something that works until the GM is out and then give it another shot.

“Happy” to hear I’m not the only one.

Impressive, I just got an update for lightdm, working great now. Now you guys overthere don’t expect too much testing tonight from us guys over in soccerland tonight, there’s some very decisive events going on tonight, World Cup you know!

I installed from the KDE Live 64-bit iso within VBox 4.2.18 on an OS X host. Installation went fine. During the configuration stage, the status bars while the repos were being configured/updated stayed at 0%. If I recall, the same thing happened with Beta 1.

I installed plasma-nm to give it a go. It removes the NetworkManager/KDE4 packages during installation. I added it to the panel from the panel tool box. The icon is bigger than the NM icon. Clicking on it only shows the active connection but there are several other panels available by clicking on the wrench icon. Check it out.

Running from a live KDE on USB looks okay. The problems with that seem to have been corrected. I did not try an install, and I have not yet tried on a UEFI box.

I installed from the 64bit DVD, into an encrypted LVM. These are the main problems I have seen:

  • Cannot answer the prompt for the encryption key, so the system is unbootable. This is bug 839071. Apparently, the fix was not in time for RC1. I went into rescue mode, added “ohci_pci” to initrd modules in “/etc/sysconfig/kernel” and rebuilt the “initrd”. Thereafter booting works properly so I could complete the install.
  • I still have 13.1Beta1 installed on a separate partition on that box. There is no menu entry to boot it. Grub2 is configured to probe-os.
  • Running “grub2-mkconfig” gave an error about unable to mount the root volume of my LVM. I’m not sure why it tried, since that is already mounted and is the running system. Perhaps that error is why the os probing did not find Beta1.
  • Everything is using UTC. “/etc/localtime” seems to be a bad symlink (to “…/…/America/Chicago”). Fixing “/etc/localtime” corrects the problem.
  • After installing “ecryptfs”, the “Private” directory is still not being mounted. It looks as if the pam rules for ecryptfs were not configured.

I have not yet reported any bugs on these.

The install itself was fine. The number of packages remaining is being updated (unlike what happened with Beta1).

Same here with UTC time. It’s been reported as bug #845530. Editing /etc/localtime fixed it for me also.

One more problem.

I cannot log out of XFCE.

The first time that I logout, nothing happens. The second time, there is a popup that session manager is busy.

Aborting with CTRL-ALT-Backspace (twice) does get me out.

https://forums.opensuse.org/english/get-technical-help-here/pre-release-beta/491138-screen-drawing-issues-gnome.html

That is where I am trying to work through my graphical issues with GNOME. If anyone else is having the same issue, please jump in there so we can put our heads together.

My guess about a language problem for lightdm was wrong, it’s definitly a problem with sessionmanager. Switch to xdm and it will work, xdm is always there.

grub hangs on loading kernel in the install phase, didn’t that get fixed? (EFI system)

Okay, tried this. It hangs while trying to load the kernel.

I then disabled secure-boot. I could then boot the live USB. I did not try with the DVD image, but I expect that would behave similarly since the booting is done the same way. This looks like bug 841426 (from the Beta). Apparently, the attempts to fix it did not succeed.

I should have mentioned that I was using “kdm”. I’m mainly a KDE user, so I’ll stick with “kdm” for now.

On 10/11/2013 01:56 PM, pilotgi wrote:
>
> nrickert;2590709 Wrote:
>>
>>> > >
> - Everything is using UTC. “/etc/localtime” seems to be a bad
> > symlink (to “…/…/America/Chicago”). Fixing “/etc/localtime”
> > corrects the problem.
> > > >
>>
> Same here with UTC time. It’s been reported as bug #845530. Editing
> /etc/localtime fixed it for me also.

I added this bug to the Most Annoying Bugs list. An upgrade from Beta 1 did not
have this problem.

All this time, I thought it was VirtualBox acting up. Huh.