openSuSE 13.1 random hangs

I’ve just reinstalled my opensuse 13.1 because of an issue where windows removed grub from efi boot. Now, I installed the latest beta driver for Sapphire AMD 7850HD, and since then, I am getting random hangs. I first noticed it when I tried accessing a link sent by a friend, It opened with chrome and as soon as any 3D came into picture the system froze completely. I had to force reboot it. I first thought it was the browser, but I also tried firefox with both this link and At first none caused any issues, but after closing one app on and opening another, it hanged again. I thought perhaps there is something with the beta driver and how the rendering is done in the browsers. So I went ahead and rebooted, did not open those websites but installed alien arena and played. Everything went smoothly and kept working after I closed the game. But 10 minutes later it hanged again.

I then removed the driver using amd’s scripts from /usr/share/ati and then installed the stable version using the fglrx repo on After installation I immediately tried and again it opened with chrome and the system instantly hanged.

System: AMD FX-8320 8core@3.5Ghz, Sapphire HD7850 OC edition, 8GM Ram Kingston@1333mhz, 1TB HDD with both openSuSE13.1 64bit and Windows 8.1 64bit, both installed in EFI mode.

Now, I did OC the ram to 1600mhz and undergone extensive testing both in windows and memtest with the dvd. Both passed without any issues. The RAM is stable. I only increased the frequency, and I did noticed the MB automatically increased the latency as well so i’m not sure if OCing made much of a difference. Point is the system wasn’t hanging prior to having to reinstall.

Does anyone have any ideas on what I might be able to try? I’ve already tried to different fglrx versions and both with the same result(unless perhaps running the amd uninstall script didn’t do the job properly).

Kind Regards:)

Back off on the OC

I’m at work now, but I’ll set it back to default when I get home and test again. I just hope it is this and not something else. I was wondering if there may be a software issue also, but I’m not really sure what could cause this as there isn’t anything there that wasn’t there the last time. Except of course the latest updates but I think someone else would have reported that by now.

Is it possible the PSU might have something to do with it? I mean, if it did, wouldn’t it show issues like that in win also? I played Crysis 3 on the rig with OCed ram and there were no crashes or hangs. Shouldn’t it have shown there?

Over clocking changes timings and small differences in timings can mess things up.