openSUSE 13.1, minimize garbled screen

Good morning guys!

Firstly, thank you for an AMAZING opensource OS! Hands down THE best one out there!

I’ve been experiencing issues with KDE, and I was hoping someone can help me. When I minimize any window, at any time, just after fresh startup or hours later, the screen is always garbled.

I’ve attached an image to this post taken with the phone. I’ve got all the standard stuff enabled, and the ATI graphics card proprietary drivers loaded. I even tried to install the beta to see if it would make a difference. I’ve also played around with the desktop effects rendering options (native, raster, opengl, etc) and nothing seems to work.

The only way to remedy the issue is to perform a restart. Any suggestions?

Exactly what video card???

Hi, It’s a custom built PC, with a MSI ATI 6970 card

QUOTE=gogalthorp;2605085]Exactly what video card???[/QUOTE]

Disable desktop effects…
In system settings> desktop effects
You could selectively disable and find the one which is causing the problem.

Hi, thank you. I determined that the ‘Magic Lamp’ effect is the culprit. By disabling this effect, I no longer have the issue. Thank you!. Is there any merit in enabling it again, make it crash again, and collect info that you guys can use to maybe fix the issue? let me know what I can do to help.


Maybe but we can not fix it you have to report it to bugzilla

openSUSE:Submitting bug reports - openSUSE

this does not occur only with opensuse ever had problem with ubuntu too. I believe that is the problem with the amd drivers have to wait new driver appears. : (

Ubuntu uses a different way of managing desktop effects, although I guess kubuntu will be the same. However it is possible that the root cause lies with the AMD drivers.

I have had the same problem in 13.1 with minimizing using the magic lamp animation only from the very top of the display. I am using a AMD 7790 with the 13.12 catalyst driver. This was not an issue in opensuse 12.3 using the same 13.12 drivers.

Sounds like it should be reported in bugzilla

I can confirm the same issue on my laptop with a generic ATI 6610m graphics chipset. I had to disable all openGL altogether. Let me see what disabling “magic lamp” does.

Try selecting several icons (about 10) on your desktop, and moving them around. Same issue?

Those that are having the problem need to report it. We are just users here so you need to go to Bugzilla

openSUSE:Submitting bug reports - openSUSE