opensuse 13.1 - kde, security questions

I have setup where I have one partition for transferring data between Suse and windows. Now, i’m getting a request for a password. I don’t want it broad access across Suse by using the check-box. How do allow just this partition accessible by Suse. I’v haven’t had any need to deal with drive security until now. So, i’m new at this. Can someone help here? Thanks.

Add it to /etc/fstab.
You can use YaST->System->Partitioner if you don’t want to edit fstab manually.

I tried the yast – > partitioner. I couldn’t find anything security related in it. A few versions back, I could just click on the (windows) directory to view it. Can you make that more clear?

What do you mean with “security related”? I thought you wanted to mount your partition?

Just click on “Hard Disks” on the left, select the partition and click on “Edit”. Enable “Mount Partition”, then choose a mount point (e.g. /windows/C).
It will then get automatically mounted on boot and you should not need a password to access it.

When I tried to click to open the drive, I get a password prompt. This didn’t happen on the last version of suse. I only want this windows drive open to suse. Using save password, I don’t want to use the save password. How do I get suse to change the security to allow it to view without a password. The partitioner has no reference to security and this drive is mounted.

Paste the relevant /etc/fstab entry. I would expect it to include ‘user,auto.’

If the drive is already mounted, you don’t have to enter a password.

But you need to specify the root passwork for mounting it.
You have two possibilities to overcome this:

  • create an entry in /etc/fstab, maybe with YaST->System->Partitioner. The drive will be mounted at boot then, or if you specify the “noauto” option, you can mount it yourself when you want to. Specify “user” to allow a user to mount it.


  • Put this line to /etc/polkit-default-privs.local:
org.freedesktop.udisks2.filesystem-mount-system yes

Then run “sudo /sbin/set_polkit_default_privs” for this to take effect.

Afterwards you should be able to mount system drives with udisks2 (i.e. what KDE uses) without a password.

Ok, I understand now. I changed the settings. It was mounted in partitioner. I found the correct controls and set temp1 to mount on boot. I can view the suse/windows partition as normal. Thanks for the assistance to all.


This solution is the closest thing I can find to a similar problem that I am having. I am booting the KDE live SuSe 13.1 USB for X86. On my USB I have one partition that is NTFS, the rest are udf for /livecd and ext3 for /read-write. I mount my NTFS on /home. The idea is that user data on /home can easily be shared between the live boot and windows machines. I’m using the USB to do upgrades from WXP to W7 by dd’ing a syspreped W7 image onto the machine booting the USB. Old profiles are first pulled from the local hard drive and copied into /home - so you can see my motivation for having something that is NTFS - After the upgrade the same USB can be used by the freshly loaded windows machine to recover stuff from the old WXP profiles.

But here is my issue: Occasionally - udev/udisks will attempt to auto-mount the NTFS partition on the USB. It will also attempt to do that to NTFS partitions on the hard disk that I wish to image. Typically when that happens, I see the pop-up window on the KDE desktop asking me what I want to do with the device/partition. On an occasional boot, that same process will automount the NTFS partition BEFORE it can be mounted on boot and the automatic login for the linux user will either fail (He has no /home to go to) or he’ll login and not get his desktop with all the application links I’ve made to help dd the image to disk.

Often, after successfully dd’ing the image to disk and then doing a partprobe to read the new partition table, udev/udisks will once again attempt mounts on ALL NTFS partitions and lock-out my script which wants to immediately mount the “C” drive partition to add modifications to the unattend.xml before rebooting to finish the W7 install.

This may not be the correct forum or thread for this post, but most of the sites I’ve googled simply belittle and deride anyone not wanting to automount NTFS and offer no solutions. Any help you all might have would be greatly appreciated.

Udisks/udev WILL NOT auto_mount_ anything at all.
And KDE4 won’t either, unless you configure it for certain disks in the removable media settings. A disk/partition only gets mounted if you click on it in the file manager or device notifier.

That said, there is the package “udisks-glue” which may automount things:

udisks-glue is a tool that can associate udisks events to user-defined
actions. In that sense, udisks-glue is almost "glue code"[1], hence the name.

udisks (formely known as DeviceKit-disks) is an abstraction layer on top of
the Linux disks subsystems that, in conjunction with the other DeviceKit
subprojects, aims to be a replacement for the now almost defunct HAL project.

Like most other recent Linux desktop frameworks, udisks exposes its API via
DBus to its clients (often desktop environments). Users wishing to have more
control about what happens when specific disk-related events often have to use
a tool like halevt[2] or ivmon[3], which work on top of HAL. Now that HAL is
no longer being actively developed and most distributions are considering
dropping support for it, those users will have to migrate to a new tool, and
udisks-glue might as well fill that gap.

udisks-glue should eventually offer the most useful features found in the
aforementioned projects. As of now, however, only the most basic functionality
is available (mounting and unmounting removable media). Contributions are

I think this is mainly used by KDE3 for automounting (not sure if that’s the current status though) or maybe other desktops that have not been upgraded to use udisks2 yet.
If you have this installed, try to uninstall it to prevent its interference.

Or maybe your problem is caused by “autofs”?

AutoFS is a kernel-based automounter for Linux.  It automatically
mounts filesystems when you use them, and unmounts them later when
you are not using them.  This can include network filesystems, CD-ROMs,
floppies, and so forth.

Check if “autofs.service” is enabled and disable it if necessary. (either with “systemctl” or in YaST->System->Services Manager)
Or uninstall “autofs” to be sure it does not mount anything.