opensuse 13.1 installed on HP notebook2000 asking for help to post info in laptop section

Hello!

While browsing the suse support page i noticed the laptop section where they requested anyone who installed suse OS on a laptop

notify the laptop section in order to help other suse users.

i knew nothing about laptops and bought one because i could not use a desktop in my work as a truck driver.

Since 2013 i started with opensuse 12.3 OS in a HP notebook2000 laptop and due to my lack of knowledge had to re-install many times. This is how i am learning :expressionless: .

Also, the machine i bought came with windows 7 installed so i erased the hard drive and used only opensuse 12.3.

i tried other OS’s but the wireless refused to function properly.

Now my current OS is opensuse 13.1. There are some glitches and quirks bit it works for now…

any info shall be gratefully accepted .

thanks…

If your wireless is not working - open konsole or xterm and type:

# su -

Next:

# echo blacklist "acer_wmi" /etc/modprobe.d/50-blacklist.conf

Shutdown and restart your laptop. You should have access to your wifi.

If it’s still not working. For more advanced settings - navigate to Yast -->Network Devices -->Network Settings.
Click on the Overview tab. Select you wifi card and click on the Edit to set up your wifi card’s IP settings.
On the Global Options tab - under Network Setup Method, change Wicked Service to NetworkManager Service.

This will allow you to use the Network Management settings icon located in your systray.

hello romanator,

thanks for reply and competent advise…

wireless is working…

so i tested the wireless function by downloading opensuse 13.2. it took about 5.5 hrs. to download using uget…

then i erased the drive (yet again, phew!) and install 13.2.

wireless works much better.

one of the glitches(?) i discovered on hp notebook laptops when using opensuse OS is

the only desktop environment that has internet function is LXDE.

the desktop environments all install but except for lxde there is no wireless function…

now i’m using suse 13.2 and am busy discovering, testing. i’ll probably have to learn how to send a bug report.

respectfully,

technopuritan

First off. Welcome to the openSUSE Forum. It’s good to hear you are up and running.
Using Linux (especially the openSUSE distro) allows the user to learn and understand everything about their system and hardware.

I always make it a habit to read the release notes. There was a minor glitch when we transitioned to “wicked.service” as the replacement for “ifup”.
Wicked.service is now used if you are using the regular ethernet cable.

Please read the file in: /usr/share/doc/release-notes/openSUSE/RELEASE-NOTES.en.html or RELEASE-NOTES.en.pdf

1.2 Network After an Update With YaST #

After updating from 13.1 to 13.2 using YaST, there are good chances that the new Wicked network method is running together with the old
NetworkManager, if you are using a laptop with a wifi connection.

To solve this, first disable Wicked and enable again NetworkManager. Open konsole (I prefer konsole) or xterm:

systemctl is-active network.service && systemctl stop network.service
systemctl is-active wickedd.service && systemctl stop wickedd.service
systemctl disable wicked.service
systemctl --force enable NetworkManager.service
systemctl start network.service

I added it to my local ~/home/your_username/bin folder, and created a script file in case I needed to run it again.
Assign a name such as netman.sh. Make sure you chmod +x netman.sh

#!/bin/bash
#
systemctl is-active network.service && systemctl stop network.service
systemctl is-active wickedd.service && systemctl stop wickedd.service
systemctl disable wicked.service
systemctl --force enable NetworkManager.service
systemctl start network.service

You can run it as root by typing:

sh netman.sh

or

./netman.sh

BTW Learning how to submit Bugzilla reports. It’s easy once you submit your first or second bug report.

Good Luck!