OpenSuSE 13.1 Install on Intel HM77 (IMSM) Raid 0

I’m having an odd issue installing OpenSuSE 13.1 on my ASUS G75VW laptop. It doesn’t seem to want to install on my raid 0 array (2x 500GB 7200RPM HDs)

The partitioner sees it when I use dmraid mode (/dev/mapper/xxxxx-Phoenix-ASUS)
The partitioner also sees it in mdraid mode, but will NOT see the partitions already on it, seeing it as empty.

Now, if I try to install in dmraid mode, GRUB fails to install on the /boot or / partitions
It will however install in the MBR.

In dmraid mode, grub will refuse to boot from the partition however, saying that /dev/disk/by-id/xxx is missing.

I obviously can’t install in mdraid mode, however I tried an OpenSuSE Factory snapshot which only used mdraid. It installed perfectly and grub booted.

The OpenSuSE 13.1 Rescue DVD also sees my partition perfectly, but forcing me to use mdraid mode. It makes no sense that the Rescue DVD would see it but not the normal install disc.

Can someone please tell me what the heck is wrong here?

Oh, during testing I also tested the latest Ubuntu and Linux Mint. They both see the /dev/mapper partition and grub works fine.

Only guessing that the current RAID is FAKE (BIOS assisted) and not true hardware RAID. It is possible, I don’t know as a fact, that a newer kernel will play nicer with your FAKE RAID then the current one. Reason that factory image worked maybe.

To be honest I never understood trusting in a 50 cent chip to do simple RAID and it still depends on the OS to supply drivers. True RAID is OS agnostic and simply looks like a single disk to the OS. No special drivers needed