openSUSE 13.1 hugin - cannot open shared object

I upgraded 12.3 ==> 13.1
Since then hugin doesn’t work anymore (and Digikam has problems with these parts, too).

Starting from command-line gives me:

xxxxxx@DellPC:/home/xxxxxxx> hugin --version
hugin: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried to re-install hugin (and finally digikam) but didn’t help.

One idea is that changes in might have caused the problem. So here my

xxxxxxx@DellPC:/etc> cat
include /etc/*.conf

/lib64, /lib, /usr/lib64 and /usr/lib gets added

automatically by ldconfig after parsing this file.

So, they do not need to be listed.


Any idea?
Does anybody have similar problems after upgrade 12.3 ==> 13.1 final?


Please post output of

rpm -qa | grep hugin

On 2013-11-23 13:46, fiesta88 wrote:
> I upgraded 12.3 ==> 13.1

Which type of upgrade? Online upgrade (zypper dup) or offline upgrade (DVD)?

Online upgrade

Offline upgrade

Chapter 16. Upgrading the System and System Changes
openSUSE 12.3 Release Notes
openSUSE 13.1 Release Notes

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

This is a bug in the hugin package.

See here for a fix:

And actually, this was already reported a while ago (and fixed in Factory, but not 13.1):

Hi wolfi 323!

your answer

solved this one, too! :wink:


Of course. It is the same problem. Those tools that digikam uses/needs do come from the hugin package and use libhuginbase.

I’ll mention it here as well, maybe someone else reads this thread:
A fixed package has already been created and should be released as online update soon (next week maybe?).

I just tried it and it works fine.