openSUSE 13.1 HUGE fonts on TV

Hello everyone!

I have been running MythTV for years on openSUSE. Since once of my Myth frontends was dying, I got some different hardware to make another one. (HP DX5150 with Gigabyte GE Force 210 VGA/DVI/HDMI) I plugged it into a VGA monitor, installed 64 bit openSUSE 13.1 with KDE, installed MythTV, installed nvidia drivers and it all worked perfectly.

So I took it to my JVC 37" TV and plugged in the HDMI cable. It boots just fine, splash looks good, but then the fonts turn HUGE, as in 8-10 inches tall on the screen. Desktop icons are massive as well. (But when I click the bottom of the 12 inch tall MythTV icon on the desktop, MythTV starts and runs perfectly!) If I click the start geeko in the lower left, the menu is a good 8-10 inches tall and impossible to navigate. I can only see part of the first two lines.

So I plugged my 20" monitor back in, rebooted, and it came up fine on the monitor, except the icon for myth on the desktop was now massive. I deleted it, and recreated a normal sized one again. I ran the nvidia settings and saved both the monitor and TV setting. Everything was normal sized on both the monitor and TV. But as soon as I reboot without the 20" monitor, I went right back to the massive fonts on the TV.

Does anyone have an idea on how I can get the fonts to behave on my TV without having to have a monitor hooked up?

Thanks for any help.

Matt

From what you’re describing, I’d guess that the JVC screen resolution needs to be set in KDE, seems to be set properly on your other displays and the display resolution during bootup is configured elsewhere because KDE hasn’t loaded yet.

TSU

Thanks for the reply. I did go into the fonts section of YaST when I had both monitors hooked up. Everything looked ok and all the fonts displayed correctly on both monitors. But on reboot with just the JVC TV, they turn huge again.

Is there someplace in KDE where I can force the fonts to stay at the smaller size? Or maybe turn off the automatic adjustment?

Matt

KDE Menu > System Settings > Application Appearance > Fonts

Enable ‘Force fonts DPI’ and try ‘96’ DPI to start with, then ‘Apply’. Open ‘Dolphin’ or similar to observe font size. See how that goes.

AWESOME! That did it! It looks just fine now. Thanks for the help!

Matt

My pleasure :slight_smile: