Opensuse 13.1 guest in a Windows 8.1 Vmware Workststion 10 host - No shared folders

I have installed opensuse 13.1 as a guest on a Windows 8.1 system using Vmware Workststion 10.1 Vmtools installed automatically and everything works fine all except being able to find the shared folders created in VM Manager. I have looked under mnt/hgfs in File Manager and it is empty. I have tried adding .host:/ /mnt/hgfs as spelt out by Vmware for suse and this crashes the virtual machine and prevents boot up. Sometimes I get through to the host on Samba and other times it tells me there is nothing there. Crazy or what ? Other distros show the shared folders under /mnt/hgfs, I am assuming Opensuse is the same…or am I wrong again ?

Any help or guidance would be most gratefully received.

On 2014-05-11 15:46, spamnchips wrote:

> Any help or guidance would be most gratefully received.

I’ve never used that shared folder feature. Instead I use networked
shares. As, in my case, the host is Linux, I use NFS. You can use samba
instead, and in some Windows versions you can also set up NFS.

If you only need to transfer some files, I use putty in Windows. Rather
a variant of it, WinSCP, which can copy files in either direction. It is
far easier to set up, unless you really need a shared folder that other
programs can use transparently.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

First, I recommend you always browse to the location (/mnt/hgfs/) from a command line. It removes at least one possible layer of possible malfunctionality (ie Does your File Manager need to be refreshed/reloaded?)

Simply “adding .host:/ /mnt/hgfs” won’t crash your machine unless you added it to your fstab which is highly unrecommended on many levels…

  • Never add something to fstab unless you’ve tested manually mounting first (and are able to do so successfully)
  • That documentation is outdated (and AFAIK never been fixed by VMware). Nowadays if you check the “always enabled” radio button, on a systemd Linux like openSUSE, it’s mounted by the mount unit file, not fstab.

If the folder is empty, then your shared folders aren’t mounted.

  1. Verify in the Guest’s properties that Shared Folders hasn’t been disabled, and that at least one Shared Folder is configured. Also, be sure to check the box “always enabled”
  2. if the above doesn’t enable the Shared Folder to be mounted in the Guest, the most likely reason is that the Guest Tools need to be re-installed. For this reason, I always clone my machines with the Guest Tools install files included so I don’t have to re-mount the Tools virtual cdrom. I have to re-install Guest Tools every time there is a kernel update (which is fairly often). There is a workaround for this described in the VirtualBox documentation (which also applies to VMware in this case) but I haven’t bothered to implement.