openSUSE 13.1 GM and Nvidia drivers

Hi guys.

I need some help please. I attended the SUSEcon 2013 this week, and I was given a 13.1 disc (Special edition) early release version. Really excited I went out and purchased a new Asus notebook with integrated intel card with nvidia discreet. After flawless install, I downloaded the nvidia drivers from the website, and commenced following the process depicted in the SDB (Hard way). After reboot, I got a ‘something’s gone wrong’ error message, and I messed up the system. I’m new to nvidia, and how it works under openSUSE (normaly use ATI cards), and I’m usure at the moment what I need todo? Can anybody help me with getting my card going? Also, how do I know if my current configuration is using the intel card, or nvidia card with nouveau?

Thanks guys,

On 2013-11-14 21:36, dabump wrote:
> Hi guys.
> I need some help please. I attended the SUSEcon 2013 this week, and I
> was given a 13.1 disc (Special edition) early release version. Really
> excited I went out and purchased a new Asus notebook with integrated
> intel card with nvidia discreet.

You need bumblebee. Or equivalent proprietary thing, not the standard
driver. Somebody else may explain better than me.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

The proprietary Nvidia driver does not support optimus tecnology in Linux (at least, until now) …
What’s the model of your Asus notebook?
What options have you got in the bios (or UEFI firmware)?
I suppose you can choose between optimus and dedicated GPU.
If you select the latter the system should boot (if the installation of the driver is correct).
I’d also like to know if there is an option to select only the integrated graphic card …

Hi PiElle, thank you for replying. The notebook’s model number is: Asus Q550L with UEFI firmware. I looked at the BIOS, and cannot see any location for selecting the preferred graphics card. I must say, I’m not too fussed about battery life, and switching between the two graphics cards based on performance requirements. I just want the nvidia drivers to be installed and function, and use the nvidia graphics card.

Any ideas? AGain, thanks for helping

On 2013-11-14 22:36, dabump wrote:

> Any ideas? AGain, thanks for helping

Bumblebee - NVIDIA Optimus support
for Linux!

They have an utility to switch driver. The plain nvidia driver will not
work, you need one for optimus.

Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

If the laptop is that new I’d say the best option is to return it and go for a non hybrid system, note there are AMD hybrids too, not much better for Linux than Optimus systems.
If you still prefer to keep it there’s nowadays good help, go for this guide:
Smithfarm - the Brain: openSUSE 12.3: How to install ‘bumblebee’ for NVIDIA Optimus VGA

As you installed The Nvidia driver the “hard way” in addition to unistall it you will also have to reinstall the package xorg-x11-server, the nvidia-installer overwrote an opengl file.

Oh, I forgot you’re on 13.1, but Overman79 has a working repo for that too, just change 12.3 to 13.1 in the adress.
Also don’t use zypper to install dkms-nvidia, x11-video-nvidia and x11-video-nvidia-32bit, zypper will install the 331.20 versions which don’t work yet. Use Yast where you can select the 325.15 versions for those packages.

Hi, I bought a dell inspiron 7537 laptop. and I can’t get the nvidia gt 750M driver working. I installed the same driver like at the beginning of this post, with the same result. Can you help me with this ? In the bios is no option to me to turn up the optimus technology. I installed opensuse in legacy boot mode, and I formated my harddrive, and deleted windows 8, it’s urgent, thanks…

Hi, welcome.

You need bumblebee to get the NVIDIA driver working on an Optimus config laptop. has instructions to get it working, but mind to remove all traces of the current NVIDIA install, reboot after that before following instructions. Plus, don’t forget to add your user to the bumblebee group after having performed the dkms-nvidia install.

HI, thank you your answear, I haven’t installed any Nvidia driver, because Opensuse used automatically the Intel Haswel graphics driver, so I have nothing to remove, right ? Because I wan to be sure.

I installed bumblebee but I got black screen after. I guess I had no nvidia driver before installing bumblebee, I had something for Intel GPU. At boot sass something like: no DSM call found…

The problem seems to be with the gt 750.
You’ll have to upgrade kernel to 3.12 as I understand it.

Yes I search for something that resolves this issue, and I have seen that installing kernel 3.12 helpes, but it didn’t helped in my case…
After installing the kernel, and makeing “mkintrid” and reboot, I get a short boot screen for 3-4 seconds, then black screen with the lights on.

Could anyone give me some instructions from adding the correct repository etc ?
I hate windows and It seems I can’t use anything else…

Nvidia closed driver for openSUSE 13.1?

There is a “one-click” installation:
for new cards →

The repository way:
Add repositorie:

zypper ar -f Nvidia

Install the driver

zypper install x11-video-nvidiaG03

More info @

Actually its possible to use nvidia GPU without bumblebee ( but you will get no powersaving and ocassional tearing )
I am running opensuse 13.1 with kernel 3.12 from kernel/stable repo, 1.15 from x11/ repo and latest nvidia driver 331.38 from nvidia driver page
GPU: Nvidia 540M

Just follow instructions in nvidia driver readme for optimus, but instead of using .xinitrc for xrandr stuff you must use /etc/X11/xdm/Xsetup (maybe not the best place to put this things, but it works) ( i put it somewhere near top )

(special thanks to gentoo forums)

Thanks your help, the one-click install method doesn’t worked and I installed probably not the right versions, but now it works, but I guess I must uninstall whatever I installed before…
Can you give me a link with the steps ? I found Smithfarm’s blog but there are references on other posts which somehow are suggesting the steps which I must take in a linear time period.

i did this ( after 5 failed attempts, key was using /etc/X11/xdm/Xsetup instead of .xinitrc )

  1. add yourself to video group
  2. blacklist and unload nouveau
echo "blacklist nouveau" | sudo tee -a /etc/modprobe.d/blacklist-nouveau.conf
  1. create xorg.conf file
  2. change to runlevel 3
sudo systemctl stop xdm
  1. run nvidia installer
chmod +x
sudo ./
  1. installer asks you if it should run nvidia-xconfig or something like this → NO
  2. add this to /etc/X11/xdm/Xsetup
xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

I added it at the begining after line “./etc/sysconfig/displaymanager”
7. reboot (or maybe just load nvidia mod start xdm)

sudo modprobe nvidia
sudo systemctl start xdm

to fix DPI in KDE, just enable Force fonts DPI in System settings/Application appearance/Fonts

nvidia gpu should work now

if you want rollback changes just do this:
if you have black screen then press CTRL + ALT + F1

  1. remove xorg.conf (or move to xorg.conf.old)
  2. remove /etc/modprobe.d/blacklist-nouveau.conf
  3. remove xrandr calls from /etc/X11/xdm/Xsetup
  4. sudo ./ --uninstall

by doing this you may break plymouth and mess kdm login :smiley: and dont forget about tearing
I have no idea if it will work with stock kernel and server

L4D2 runs pretty nice ( fps drop after begining, maybe too much zombiers after i joined game :smiley:

maybe is bumblebee better solution, but i dont like it

Thanks your well organized end punctual answear, I can finaly see what are the steps which I must take.
I need nvidia just at a few times, mediaplayer at high resolution, movies etc so I would use bumblebee if it’s works. Now everytime I start my system and after 2 minutes the screensaver starts I get an unresponsive black screen witch I can’t pass trough. Unless i close the laptop lid and I reopen it…

And could you tell me pros and cons for using bumblebee ?