Opensuse 13.1 configuration always stuck at 3% / 11%

I tried installing Opensuse 13.1 KDE now for like 4 times, while redownloading and rewriting the iso on the USB but everytime the automatic configuration (which comes after the automatic reboot after the installation) will be stuck at 3% on the top load bar and 11% on the bottom load bar.

Is this a know problem? Can anybody tell me how to fix this?
I really dont wanna configure everything manually, since I am not so experienced and furthermore I would also have to manually install the WLAN drivers. I had very big problems with the WLAN on Opensuse 12.3, so i switched to Ubuntu, where I sadly again had the same problems… I tried the KDE live opensuse 13.1 and finally the WLAN worked fine _ Thats why I decided to install it.

I know of two things that can cause this:

  • A non-existing floppy drive, try to disable it in the BIOS settings if you don’t have one, or add “brokenmodules=floppy” to the boot options (just type that at the boot menu)
  • Certain WLAN devices.

Workarounds for the latter:

  • disable the wireless device (in the BIOS settings or via the hardware switch if available)
  • add “brokenmodules=b43” (or whatever driver is used, we would have to know which device it is, but I’ve only heard of this problem with the b43 driver until now) to the boot options
  • apparently manually selecting the package “kernel-firmware” in the installation overview might help as well

You should of course be able to get the wireless working after the installation never-the-less, since it worked when booting from the LiveCD.

Can you explain to be how adding boot options exactly works? I think you probably mean GRUB, but i cant figure out how to type there anything

Select the advanced options from the Grub menu
Then press e which means edit
This will take you to the current boot perimeters. It is here that you can add yours.

I’d probably check your BIOS to see if the Floppy is enabled (it doesn’t matter if you have a floppy drive or not).

There’s no need to select “Advanced Options”.
And the question was about the Installation-Medium.

Normally you should just be able to enter them at the boot menu.
But if you’re using UEFI, then there’s no input line.
In that case you have to press the ‘e’ key on your keyboard as caf4926 wrote, search for a line starting with “linux” and append them at the end, then press ‘F10’ to boot.

But again, you should be able to disable the non-existent floppy drive (or the wireless) in the BIOS settings.

It would have been easier and nicer for the new users if only the old boot menu from the good old legacy grub is still there, e.g. you have an option to just enter the parameters and boot without going to do anything more :slight_smile: everyone knows what im talking about right? lol!

Well, actually it DOES matter. :wink:
If you have one there should be no problem.

If you don’t have one, but the BIOS tells the kernel you have one, that freeze happens (well, actually it’s just a long hang when the installer tries to access the floppy drive, not really a freeze).
In that case you should disable the floppy drive in the BIOS settings or add the “brokenmodules=floppy” boot parameter (or wait an hour or so until the installation continues…)

Yes, but the “good old legacy grub” does not work with EFI.

OTOH, the installation medium never used grub, it’s using a different boot loader and that input line is provided by “gfxboot”.
And grub legacy doesn’t have this input line either, it is patched by (open)SUSE to use “gfxboot” as well, that’s why this line is there. :wink:

Thanks for that.
My BIOS doesnt show a floppy disk. Still i tried with the bootparameter, but didn`t work sadly.
I tried to disable the Wireless Device in the BIOS, but the only option I could found is called “Network Stack” and this one was already disabled, so tried enabling it, didnt help anything.
Finally I tried with the borkenmodules=b43 parameter, still stuck at 3/11% :frowning:

The parameter is called “brokenmodules”, not “borkenmodules”. Did you make a mistake there?
Otherwise it would be nice to know what kind of wireless device this is.
Is it internal or external?
If it’s internal there should be some way to switch it off.
If it’s external, just disconnect it.

And have you tried to manually select “kernel-firmware” for installation?
People have reported this has helped.