openSUSE 13.1 cannot find /dev/root during boot up II

Installation and upgrade OK for Opensuse 13.1.
GRUB changed from graphical to text version for no obvious reason.
Multiboot with Windows XP (=OK).
Tried all (4) options for Opensuse. Boot starts but freezes.
Text version: “RAID set for … pdc_xxx”. Next line
RAID not set for … pdc xxx.

Appreciate all suggestions.


Are you using RAID? If so what kind?

Are you using either BTRFS or LVM partitions?

Just to be sure we understand

  1. your grub changed to text
  2. you can boot to XP
  3. you can not boot to openSUSE you get the noted error

Thanks for your answer!

  • I use RAID 0, Promise PDC 20378 on an old motherboard (Asus PC-DL Deluxe), with 2 Intel Xeon CPU:s.
    Promise BIOS says “Functional”, and installation (tried twice), was all OK.
    At first everything worked well, I was able to boot either Windows or Suse, but after installing NDIS-wrapper from Yast,
    I was unable to boot Suse, and Grub changed in appearance.

  • I don’t use BTRFS or LVM.



NDIS-wrapper should not be needed any more. Do you have some really exotic network device?

I assume you are using FAKE RAID ie BIOS assisted = That what is found on the MB

FAKE RAID can be tricky and depends on the actual MB chip

Have you tried running a live Linux and see if you can mount the partitions

ndis-wrapper includes a kernel module package. I guess you installed the wrong one which pulled in an additional kernel, probably a -base flavor which lacks most drivers?

Please try a different kernel in Grub2’s Advanced Options.

And then post a list of all installed kernel packages (and which ndiswrapper package you installed exactly):

rpm -qa | egrep "(kernel|ndis)"

Thanks for your suggestion. However, I have used the same kernel module in ndiswrapper as I have in Opensuse 13.1.

Now, I 'll try to move installation to another harddisk, which is non-RAID.


Thanks, but I’ll try to move the installation to a non-RAID harddisk.

Best wishes

Ok, but what kernel package is it actually? Make sure you don’t have any kernel-xxx-base installed and boot that, as that would miss (probably) necessary kernel modules for your system.

Another thing to check is that /boot is not full.
If the initrd couldn’t be written completely, such an error might occur, because the kernel modules needed to access your LVM might not be available at the time they are needed (i.e. before / is mounted).
Your mention of “GRUB changed from graphical to text version for no obvious reason.” could point to this as well, as grub’s theme files are also stored on /boot.