openSUSE 13.1 - boot to black screen after installing NVIDIA proprietary drivers

I was wondering if anybody could help me with my issue. I’m pretty new with openSUSE and Linux in general, so go easy on me if you can help it.

I am running a dual-boot openSUSE 13.1 / Windows 7 desktop, but each OS is under its own hard drive. Installation of openSUSE went without incident, and so far I hadn’t had any driver problems (nouveau worked fine for what I needed them). I’ve tried a few times to install NVIDIA proprietary drivers, but every time I install them openSUSE boots to a black screen. Most people that posted this issue online have this problem right after the OS install, so their problem usually is a wrong driver, which I don’t think it applies here.

Anyway, in short:

OS: OpenSUSE 13.1, KDE (Windows 7 on a separate hard drive)
GFX: GeForce GTX 670
Display: 27" monitor connected via DVI-D cable
Any other info just ask

**Reproduction: **I installed the drivers following the instrucctions at (the repository way). Tried first with x11-video-nvidiaG02, then uninstalled those and tried again with x11-video-nvidiaG03 (currently installed). Both are supposedly supported for my video card.

**The Problem: **after boot, there’s the briefest glimpse of the usual KDE desktop background and then a black screen. Ctrl-Alt-F2 and Ctrl-Alt-F1 still return a black screen, but I can input commands blindly (such as reboot) and they work. Rebooting in recovery mode does work, however. That’s how I’m posting this plea for help.

This is what the command /sbin/lspci -nnk | grep VGA -A2 returns:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 670] [10de:1189] (rev a1)
        Subsystem: Gigabyte Technology Co., Ltd Device [1458:355a]
        Kernel modules: nvidiafb, nouveau

xrandr output:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
   1920x1080      77.0*

This is the paste of the contents of /etc/X11/xorg.conf. Not sure if it is helpful, but just in case…

Screencap of YAST Software Manager installed NVIDIA packages:

Return of sudo /usr/sbin/fdisk -l

Disk /dev/sda: 120.0 GB, 120034123776 bytes, 234441648 sectors                                                                       
Units = sectors of 1 * 512 = 512 bytes                                                                                               
Sector size (logical/physical): 512 bytes / 512 bytes                                                                                
I/O size (minimum/optimal): 512 bytes / 512 bytes                                                                                    
Disk label type: dos                                                                                                                 
Disk identifier: 0x000c8930                                                                                                          
   Device Boot      Start         End      Blocks   Id  System                                                                       
/dev/sda1            2048      206847      102400    7  HPFS/NTFS/exFAT                                                              
/dev/sda2   *      206848   234440703   117116928    f  W95 Ext'd (LBA)                                                              
/dev/sda5          208896     4417535     2104320   82  Linux swap / Solaris                                                         
/dev/sda6         4419584    46362623    20971520   83  Linux                                                                        
/dev/sda7        46364672   234420223    94027776   83  Linux                                                                        
Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors                                                                    
Units = sectors of 1 * 512 = 512 bytes                                                                                               
Sector size (logical/physical): 512 bytes / 512 bytes                                                                                
I/O size (minimum/optimal): 512 bytes / 512 bytes                                                                                    
Disk label type: dos                                                                                                                 
Disk identifier: 0x4ef7db28                                                                                                          
   Device Boot      Start         End      Blocks   Id  System                                                                       
/dev/sdb1   *        2048  1953521663   976759808    7  HPFS/NTFS/exFAT

Thanks in advance for any help you can offer.


Did you use the precompiled driver from the Nvidia Repo, or home-build?

Did you see
7.911] (EE) Failed to load /usr/lib64/xorg/modules/ /usr/lib64/xorg/modules/ undefined symbol: _glapi_tls_Context

and follow
(just a proposal where to start)

Hi, I installed the precompiled version using the repository, as per instructions here:

As for the link you provided: I checked that all the packages in comment #7 were installed, and also followed the instructions in comment #8. Upon reboot I could not even get the graphical desktop to load, not even in recovery mode. I launched a text terminal (Control-Alt-F1) and uninstalled the nvidia drivers. Now I am able to get a graphical desktop and post this, but KDE is crashed so I’m still dealing with the aftermath.

Any other ideas? I’m not sure my (initial) problem has to do with some obscure error, perhaps I am missing something simple in the driver install? A conflict with something else?

That error is normal when the nvidia driver is installed, and caused by the fact that the nvidia driver replaces certain libraries with its own version.
But you can just ignore that message.

Unfortunately the Xorg.0.log you posted is useless in error diagnosis, as that is from a recovery mode boot, i.e. the nvidia driver is not loaded.

Do the following please:

  • Boot normally, until you get to the black screen.
  • then reboot to recovery mode, and post /var/log/Xorg.0.log.old, this is the log from the previous boot, the failed one in that case.

And please also post the output of:

rpm -qa | grep nvidia

I suppose you still have both the G02 and the G03 driver installed.
This cannot work, so you should remove all of them, and then only install exactly the following packages:
nvidia-gfxG03-kmp-desktop, x11-video-nvidiaG03, nvidia-glG03, nvidia-computeG03

Hey wolfi323, unfortunately by following the bugzilla link instructions I messed up more than one dependency and the install was seriously compromised. Let me get back to you later when I have finished reinstalling and updating everything.

By the way…

This is not the case. As I stated above, I uninstalled G02 before installing G03. However, because of what I said above, at this moment I am on a clean reinstall with nothing else but the nouveau driver installed.

Thanks for the help, I’ll follow your instructions and report back asap.

Ok, but did you uninstall every G02 package?

Oh, and I noticed now, that you had nvidia-gfxG03-kmp-default installed (I missed your YaST screenshot before), but according to your Xorg.0.log you are using kernel-desktop. So you HAVE to install nvidia-gfxG03-kmp-desktop for the driver to work.

Another note, you DO NOT need an /etc/X11/xorg.conf, the nvidia driver is automatically loaded when it is installed.
Better do not run nvidia-xconfig.
If /etc/X11/xorg.conf is present and specifies to load the nvidia driver, your system will not boot when you uninstall the driver.

Okay, back to it.

I reinstalled openSUSE and updated it. Then added the repo using the console, but installed the packages using Yast (curiously they were already marked for install when I searched for them).

rpm -qa | grep nvidia output:


Yast packages look like this:

I’m gonna reboot now, wish me luck…

Edit It works! Nice one man, I knew it had to be some stupid mistake I had made. Maybe like you said, I missed some packages when uninstalling, or perhaps the default driver instead of desktop. Likely a combination of **** ups.

Well it worked once… no more. It seems I’m really stuck with this.

Now I don’t have a black screen, but it boots straight to a text console. Control + Alt + F7 shows a bunch of green OK’d entries, last one being:

Starting ifup managed network interface emp5s0…

Do you get a login prompt in text mode? You might have to press ESC or Ctrl+Alt+F1 for that though.

Is recovery mode still working?

But if “Starting ifup managed network interface emp5s0…” is the last line, it doesn’t even seem to try to start the graphical mode any more, but hangs apparently when trying to setup the network interface.
In this case this would not be related to the nvidia driver at all then.

Maybe it would continue to boot if you wait a while until the timeout occurs?

Yes. I get a login prompt in text mode.

Yes. Recovery mode works. When I boot in recovery mode I still see the font resolution, so to speak, of the nvidia driver (nouveau was distinctly bigger).

I have rebooted (normal boot) again just now and I get a completely unresponsive red screen. Edit: rebooted again and back to text mode, no red screen. I’m going to let it hang there for a while, see if it boots the GUI, but I doubt it will.

The only changes I made after that first working boot were:

  • opened the nvidia control panel (didn’t change a thing)
  • increased grub hidden timeout so I can see the boot menu (my monitor takes about 12 seconds to refresh the resolution)

Sorry for the double-post, can’t edit after a few minutes.

On a hunch, I ran nvidia-xconfig, since there was no /etc/X11/xorg.conf file. It seems that did the trick. I must have triggered something when I launched the nvidia control panel.

I’ve done a couple of reboots and it seems all fine now.

Thanks a lot man I didn’t these drivers would ever work for me.

In recovery mode neither nvidia nor nouveau is used.

Please do the following then:

  • Boot normally until you get to the text mode login.
  • Reboot to recovery mode and post the file /var/log/Xorg.0.log.old (upload it to some pasting/sharing site such as and post a link)

Hopefully this will provide a clue what’s going wrong.

Yes, it’s only possible to edit a post for a period of 10 minutes.

On a hunch, I ran nvidia-xconfig, since there was no /etc/X11/xorg.conf file. It seems that did the trick. I must have triggered something when I launched the nvidia control panel.

As I already said, /etc/X11/xorg.conf should not be necessary.
But it is respected when it is present.

No idea what nvidia-settings could have changed (you say there was no /etc/X11/xorg.conf file), I think it writes ~/.nvidia-settingsrc.
But that should not cause X to crash on startup, as this is not read at that point. You should at least get to a login screen then.

Strange, but if it works now with xorg.conf in place, I guess that’s ok as well.
Just remember to remove /etc/X11/xorg.conf if you ever uninstall the nvidia driver… :wink:

I must have done something, that’s for sure. I’m glad it works, though.

Hopefully I won’t have to uninstall the driver any time soon, but yeah I’ll remember. Cheers mate, thanks again for the help.

I’m leaving the paste to the /var/log/Xorg.0.log file here for reference (not the old one, since I did a couple of boots they should be the same anyways). There should be nothing wrong with this one.

Yeah, looks ok.

I just asked for a log from the failing boot, because it might have contained some clue as to why it failed.
But it isn’t necessary now any more of course.

Actually this problem is the problem i am also handling now and as you suggested i think you can help me sort out my problem, kindly guide me with the procedures, first question is how should i uninstall all the previous installed files.

First you should tell how you actually installed the driver.

Post which ones you actually have installed.
Run that line you quoted to get the list.

To remove them, you can basically go into YaST->Software Management, search for “nvidia” and remove all packages with nvidia in the name.

This won’t help if you downloaded the .run installer from nvidia’s website though, only if you installed the driver via the packages from the repo.

And what actually is your problem?
You probably better should have opened a new thread about your problem…

yeah… ok i have installed that driver from SDB:NVIDIA Driver.
and then also from yast suggestions.

then I followed you to uninstall the whole but the problem is with this error message
"YaST got signal 11 at YCP file PackagesUI.ycp:301
/sbin/yast2: line 431: 3581 Segmentation fault $ybindir/y2base $module “$@” “$SELECTED_GUI” $Y2_GEOMETRY $Y2UI_ARGS "
while trying to uninstall.
kindly guide me what to do now.
and i am also sending the screenshots of yast kindly look into it.


and here is that Xorg.0.log.old data