Opensuse 13.1 Arduino serialport greyed out


I have spent a few days messing with this problem but just can’t figure it out. I have an Arduino Uno, but I am unable to upload anything, because the “tools>serialport” in my Arduino program is greyed out.
I understand that the problem begins with the Arduino board introducing itself as ttyACM0 (I checked it through the device viewer), which Arduino software can’t recognize. But I don’t understand what, why or how must I install for it to work.
I have searched around and found several topics on this, but I am either too noob to follow any of the Instructions or they just don’t suit my situation.

Can anyone help me?

I have the software version “Arduino 1.5.5.”. I think I tried Arduino 1.0.5. before, didn’t work.
Also, if it’s of any importance, I have the KDE interface.

And I think that the board and cable are all good, because everything worked out of the box with Arduino software on my XP.

It may be a permissions issue. Check ownerhip of /dev/ttyACM0

l /dev/ttyACM*

It will probably require the user to be a member of the ‘dialout’ group for r/w access to that serial port.

YaST >> Security and Users >> User and Group Management, select the user then ‘Edit’, navigate to ‘Details’ folder and add ‘dialout’ group. Click Okay, Okay, then logout and back in again. Check membership with


Then launch your application. Report back.

This might also be helpful to you

I went to the location:
“YaST >> Security and Users >> User and Group Management >> Edit >> Details” and checked the box next to “dialout”.

I restarted the computer and the “tools>serialport” is still grayed out in Arduino.

I wrote “groups” in the terminal, it delivered the following: “users dialout”

When I wrote " l /dev/ttyACM*", it replied “crw-rw---- 1 root dialout 166, 0 Feb 14 20:29 /dev/ttyACM0”

Finally solved the problem, thanks a lot, deano_ferrari! :slight_smile:

It was mentioned in that I need to add myself not only to “dialout”, but also “uucp” and “lock”.
I had read that before, but didn’t understand what that means at all. Thanks to your instructions, deano_ferrari, I managed to do it and now everything works just fine sofar. I can upload stuff now.

Thanks again for the support!