openSUSE 13.1 and disabled sound card on Asus Eee 1215N

Hello! I wasn’t entirely sure where to post my problem, but I’m guessing the hardware section is the correct one.

A few weeks ago I installed latest openSUSE and updated it on a regular basis, and everything seemed to work fine, including sound (note: I don’t use sound that often on my laptop, especially since it’s muted almost all the time). At some point I changed my version to Tumbleweed, since I’m not too thrilled by the idea of swapping out my system every X months, regardless of update/support cycle, but that’s not the important bit. I swapped out the repos and updated once more.
Now, about a week ago I noticed that I have no sound as my default playback device has been replaced by Dummy Output in KMix (oh yeah, I guess I should mention I’m on KDE). When I go to devices list, I see my default Intel sound card greyed out and unselectable for playback, whereas it’s still the default (and only) device for recording. alsamixer and aplay also can see the device without a problem, YaST can play a test sound on it as well (after increasing the volume sliders from 0).
Adding myself to a number of groups (including audio and pulse) didn’t help; root can’t even see the device, as the only visible option in sound settings is just the Dummy Output. This is quite bizarre.
I tried following this guide here, to no avail (though I couldn’t install kernel-source since the laptop itself is offline for the time being). A good part of the packages is up to date, including alsa-firmware (I checked).

You are the second person to report this problem recently see thread

I don’t think there has been a resolution. Try booting to the previous kernel At Grub select advanced then the older kernel

You probably should have gone with Evergreen rather then Tumbleweed. Tumbleweed is more cutting edge while Evergreen is more simple security and code fixes.

Thank you for the reply! My symptoms are a bit different than in the thread you linked - I can still see my sound card in KMix (although I can no longer test sound in YaST).

Sadly, booting with older kernel didn’t help either. When I have spare time and internet, I’ll try making a fresh install and stick to 13.1.

This is as far as I know an Optimus system, how do you handle that? Are you running Bumblebee on it? Anyhow you have two soundchips one Intel and one Nvidia, the Nvidia is almost certainly only wired to the HDMI-port, could it be that the system tries to use that as default?

I’m not running Bumblebee, I’ve been doing fine without it (last time I tried when installing Mint, it didn’t really help I think). Should I be using Bumblebee (I’ll try installing it when I get a chance to)? Could it also be the reason why it won’t let me use one already visible and recognized audio device?

If you’re pleased with the Intel graphics stay out of Bumblebee, but you should as a minimum install bbswitch to power off the Nvidia card, good for your battery and keeps the system cool. I see you run Tumbleweed, maybe that kernel powers down the Nvidia card anyway, but 13.1 with standard kernel can’t do that without bbswitch. Unfourtunatly I can’t test if powering off the Nvidia card makes any difference as the Intel HDA chip on my EE PC 1015pn has died completly.

Thanks! I’ll try that when I get the chance.

I haven’t found bbswitch during my (brief) search, but I did manage to at least get Bumblebee (for openSUSE Tumbleweed) installed. I also subscribed to nVidia drivers from Bumblebee project, I think I installed them (I know how it sounds, but I’m honestly not sure at this point) and after reboot I got my sound back. I didn’t even need to add myself to the bumblebee group.

Problem seems to be solved. Thanks everyone for help!