OpenSUSE 13.1 64bit - Screen turns off itself before login screen and keyboard starts


I just came home and can’t start up the OpenSUSE system installed on one of my partitions. Right before reaching the login screen my display turns off itself and my keyboard starts to blink.

When I hit an arrow key while starting the machine to view all the output I noticed that it crashes right after ‘Reached Graphical Interface’ (or some similar output).

I’m running OpenSUSE 13.1 64bit. I installed the proprietary nVidia drivers yesterday. It’s probably driver related, isn’t it?

Did anything similar happen to anyone here? How did you fix it?

My hardware:

AMD Phenom 9650 quad-core @2,3 GHz
nVidia GT 520 2GB

Please tell me if you need any additional information.

Regards and thanks in advance

At boot, when you reach the Grub menu, choose Advanced Options, then in there choose the Recovery option.

See if it boots then, and report back to us.

So, I chose advanced options and since my GRUB seems to run at resolution of 640*480 I could read the full names of the entries. Randomly picking the fourth option brought me to my login screen.
I entered my login details and got to my default desktop running at a very low resolution.

So far, so good.

How do I proceed now?

You can configure Grub2’s resolution in YaST->System->Boot Loader->Boot Loader Options, and this should also have effect for your desktop when running in Recovery mode.
Grub2’s auto-detection of the screen resolution doesn’t seem to work on nvidia cards (at least with the proprietary driver installed)

How do I proceed now?

So this seems to be indeed related to the graphics driver.

First, please post a list of all kernel and nvidia packages installed, maybe there is a mismatch:

rpm -qa | egrep "(kernel|nvidia)"

Then, please do a normal boot. When the screen turns off, reboot to recovery mode and post the file /var/log/Xorg.0.log.old (paste/upload it to or a similar pasting/sharing site and post a link).
This should show why the driver is not working.

Please forgive me all my typos and grammar mistakes in the previous post. I shouldn’t write after school.

Well, here’s the output of the command you wanted me to use:

david@linux-2b8b:~> rpm -qa | egrep "(kernel|nvidia)"

You can view the content of my Xorg.log.0.old file here:

Uninstall nvidia-uvm-gfxG03-kmp-default and install nvidia-uvm-gfxG03-kmp-desktop instead.
But that should not really cause this problem AFAIK.
(although it might, so try a normal boot again afterwards)

You can view the content of my Xorg.log.0.old file here:

Hm. That is from recovery mode.
Did you do a normal boot in between as I wrote?
Then it would seem that X is not even trying to start, which would imply that it is not related to the graphics driver after all.

I suppose you have the problem with kernel 3.11.10.
Can you try kernel 3.11.6? (the normal one, not recovery mode)

Replacing the package you mentioned didn’t help.

I tried the other kernel, too. It doesn’t work either.

After booting with the standard option again and rebooting into recovery mode after that I found the log file to be empty. What did I do wrong?

Yeah, I thought so.
nvidia-uvm-gfxG03-kmp is mainly needed for CUDA support.

After booting with the standard option again and rebooting into recovery mode after that I found the log file to be empty. What did I do wrong?

Hm, it shouldn’t be empty.

Two more things to try:

  • disable plymouth, by pressing ‘e’ at the boot menu screen (with the standard entry selected), search for a line starting with “linux” and append “playmouth.enable=0” at the end. Then press ‘F10’ to boot.
    Do you see the same behavior then?

  • try to boot to text mode, by adding ‘3’ to the line starting with plymouth. Does this work?
    Log in to text mode as root, then run init 5 to start the graphical system.
    Does the same thing happen now?

PS: You mentioned that your keyboard starts to blink. This normally means that there’s a kernel panic.
Could you please provide the file /var/log/messages? Might be quite big though, so you might better upload it somewhere (maybe even compressed).

Well, neither plymouth.enable=0 nor plymouth.enable=0 3 helped. Both lead to the same kernel panic.

Here’s the messages file you need:

Its size is about 3.2 mb so it’s no big deal.

Hm, so you cannot even boot to text mode?
Strange. Never seen something like this to be caused by installing the nvidia driver…
So maybe there’s another reason.

Here’s the messages file you need:

I don’t see any kernel panic in there, or anything else that could give a clue.
Even the nvidia kernel module is getting loaded without problems.

Well, can you try to uninstall the nvidia driver as a test? Does your system boot again then?

sudo rpm -e nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop nvidia-computeG03 nvidia-glG03 x11-video-nvidiaG03

(or use YaST to remove those packages)

If it is indeed caused by the nvidia driver, you could try to install it by using the .run installer from the nvidia hompage:
(though I don’t really see a possible packaging problem here)

Or maybe try with the G02 driver instead? I.e. install those packages either with YaST or zypper:
nvidia-gfxG02-kmp-desktop nvidia-computeG02 x11-video-nvidiaG02

PS: Maybe it’s caused by invalid EDID data coming from your monitor? I.e. the system boots fine, but uses an invalid screen mode. Wouldn’t explain that there’s no Xorg.0.log or the binking keyboard though.
But try to add the following to the boot options as a test before uninstalling the nvidia G03 driver:


Are you sure the card is good. I had a card go bad and had similar problems. But not exactly the same.

Not getting to command line is truly odd. Is there any other video hardware on the machines maybe video on the CPU???

AMD seems to be putting gpu’s on all their CPU’s these days.

I’m sure it’s fine because I don’t have any issues using Windows on this machine. I play many newer 3D games so I believe I’d knew in advance. But I’ll try to hook my screen up to my onboard GPU and see if it makes any difference after trying out wolfi323`s solutions.

@all: Thanks for all your patience guys. I’ll report back after doing what you said.


when I tried the command which includes rpm I got this output:

linux-2b8b:/home/david # rpm -e nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop nvidia-computeG03 nvidia-glG03 x11-video-nvidiaG03
error: Failed dependencies: is needed by (installed) libqt4-x11-32bit-4.8.5-5.9.2.x86_64 is needed by (installed) libQtWebKit4-32bit-4.8.5+2.3.3-2.6.1.x86_64 is needed by (installed) libGLU1-32bit-9.0.0-7.1.2.x86_64 is needed by (installed) wine-32bit-1.7.2-2.1.x86_64

How do I proceed here?

Adding that line you mentioned to the grub entry seems to make my computer take a bit more time to crash.

I’m quite busy now, so I’ll try out the rest in the evening.

Install Mesa-libGL1-32bit.

Did you install all that after you installed the nvidia driver?

So, I’m back.

Connecting my display to my onboard GPU didn’t help.

Most of the packages that have been installed must have been installed with opensuse updates I allowed my computer to do before downloading the drivers. Wine was installed afterwards.

I’ll try installing the mesa libs and see if they help uninstalling the driver.

In case this won’t help I’ll reinstall OpenSUSE and try the run package by nvidia. If this fails, too, I’m going to install the 32 bit version of OpenSUSE.

There must be a way to make OpenSUSE run on this computer. It runs so well on my much worse notebook. lol!

Ok. I suppose the other three packages are required by wine-32bit then.

I’ll try installing the mesa libs and see if they help uninstalling the driver.

Yes it should.
It didn’t get installed automatically as the nvidia driver provides a 32bit version of as well, which is required by those packages.

There must be a way to make OpenSUSE run on this computer. It runs so well on my much worse notebook. lol!

Yes, of course.
And it does work in recovery mode, right?
Would be interesting to know if it’s really related to the installation of the nvidia driver, or if it doesn’t work without it as well.

If it was the driver, you might try the G02 driver instead, or stick with nouveau (maybe updating that and the kernel to the latest version might be a good idea in that case).

Although a BIOS update (if possible/available) might help as well.

I reused the rpm command.
Now it says “ is needed by (installed) Mesa-32bit-9.2.3-61.9.1.x86_64”

Which package am I missing?


You could of course use YaST or zypper to uninstall the nvidia packages, that should install all missing stuff automatically then.


sudo zypper rm nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop nvidia-computeG03 nvidia-glG03 x11-video-nvidiaG03

I prefer to advise the rpm version though, as uninstalling it via YaST/zypper will mark the packages as unwanted, which might cause problems when you ever try to install them again.

But I think there are no more packages needed by Mesa-32bit, so that rpm command should work after installing Mesa-libEGL1-32bit anyway.

Progress, Yeah!

I uninstalled the nvidia driver successfully and got into textmode using the normal boot option.
I provided my login details and typed “su” afterwards to become root. Then I typed in “init 5” which did fine until “Reached Graphical User Interface”. After that it did nothing (but no crash or kernel panic).

I rebooted again and logged in. After that I typed in “startx” and it failed telling me to check /var/log/Xorg.0.log. The file says that the nvidia module isn’t loaded.

What do I do now?

“startx” doesn’t work as a normal user since years because of missing permissions, only as root.
On a default installation that is. There are ways to make it work, but they impose a security risk.

But you shouldn’t need that anyway. If Xorg fails to start when calling “init 5” (or booting to runlevel5), “startx” probably won’t work either.

What do I do now?

Remove /etc/X11/xorg.conf .
Apparently that is telling Xorg to load the nvidia driver, which isn’t installed any more.