OpenSuSE 13.1 64 bit Blueooth issues

Interesting response from the KDE dev assigned to this bug:

Sorry for all this crashes but this is Distribution fault for shipping software that is not ready, go blame the distros for screwing your bluetooth.

That’s true.
But the main problem here is that GNOME 3.10 needs bluez5 and openSUSE wants to ship both the latest KDE and GNOME (bluez4 and bluez5 cannot be shipped together since they exclude each other).
And working bluez5 support was promised by upstream to be available at about Nov. 17th.

That’s why this decision was made.

Saw a post that is available today

Bluetooth question:

My only BT experience is with iPad & external keyboard.
BT is built into my computer (not a dongle). oSuse 13.1 x64 KDE.4.11.3
I am using a usb keyboard & mouse.
I can pair a logitech keyboard - output of bluetoothctl:

[bluetooth]# info 00:1F:20:48:B3:BA
Device 00:1F:20:48:B3:BA
        Name: Logitech Tablet Keyboard IPD
        Alias: Logitech Tablet Keyboard IPD
        Class: 0x002540
        Icon: input-keyboard
        Paired: yes
        Trusted: yes
        Blocked: no
        Connected: no
        LegacyPairing: no
        UUID: Human Interface Device... (00001124-0000-1000-8000-00805f9b34fb)
        UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
        Modalias: usb:v046DpB30Ad011B

and I can connect:

[bluetooth]# connect 00:1F:20:48:B3:BA
Attempting to connect to 00:1F:20:48:B3:BA
[CHG] Device 00:1F:20:48:B3:BA Connected: yes
Connection successful
[CHG] Device 00:1F:20:48:B3:BA Modalias: usb:v046DpB30Ad011B
[CHG] Device 00:1F:20:48:B3:BA Modalias: usb:v046DpB30Ad011B

But nothing is output from that keyboard (although yesterday when I first used the GUI accepted the typing of the key).

Can the BT keyboard operate while the usb keyboard is connected? Or is the reason I get no response when trying to type on the BT keyboard due to the usb keyboard being attached?

Thanks, jon

…at the light of this, and supposing people who take care of bluez5 made a veeery optimistic forecast, in the meantime, may be at least six months, is it possible to install a working bluez4 on a opensuse 13.1???

bluez4 is still available from the KDE:KDE3 repo, but I don’t know whether this is working or not. (never used bluetooth on my PC yet, I don’t even have a bluetooth adapter)
But you also need bluedevil-1.3.2 and libbluedevil1 for bluez4 then (not bluedevil-1.3.2_bluez5 and libbluedevil2, those only work with bluez5!) to use it in KDE and this is not available anywhere for 13.1 AFAICS. Maybe the 13.1 packages would work, but I cannot guarantee you that either.

Have you tried bluedevil-2.0~rc1 from the KDE:Extra repo already? That should work better than the version included in 13.1.

I usually use bluetooth to connect my phones with laptop where there isn’t wireless network…, it is not essential but quite useful…:slight_smile:

manythanks, …I tried bluedevil-2.0~rc1 from the KDE:Extra repo, on my samsung rv520, I searched and paired my two phones (with the 13.1 version didn’t work, cannot find devices) and sent a file and it worked, on my dell latitude e6510 I had to remove the already paired devices and re-pair again and it worked (here there was already the KDE:Extra version and didn’t worked, but I didn’t tried to re-pair the phones), so, now the situation is better with 13.1… thanks again:)

Hi everyone

I just hopped to OpenSUSE 13.1 from Ubuntu and stumbled upon this issue. This is a freshly installed system (and of course all updates installed) on a Thinkpad L420 and everything else is working fantastically except for bluedevil. It is a mouse I’m trying to connect.

I have tried 2.0~rc1-16.5 from KDE:Extra but it does not even start. This is what I get:

hkt@thinkpad:~> bluedevil-monolithic 
bluedevil-monolithic: symbol lookup error: bluedevil-monolithic: undefined symbol: _ZNK9BlueDevil7Manager7devicesEv
bluedevilmonolithic(2669): Communication problem with  "bluedevilmonolithic" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 

And with sudo:

hkt@thinkpad:~> sudo bluedevil-monolithic 
root's password:
bluedevilmonolithic(2710): KUniqueApplication: Cannot find the D-Bus session server:  "Unable to autolaunch a dbus-daemon without a $DISPLAY for X11" 
bluedevilmonolithic(2709): KUniqueApplication: Pipe closed unexpectedly. 

I guess I’m off to tinker with bluetoothctl :\

I have no experience with bluetooth, but you shouldn’t have to start bluedevil manually.
Just enable and configure it in KDE’s systemsettings/“Configure Desktop” (in “Network and Connections”->“Bluetooth”).

And you shouldn’t run it as root anyway (with sudo), that won’t work!

Anyway, you seem to have an installation problem:

You seem to have an incompatible mix of packages installed.
Please show the output of:

rpm -qa | grep blue


zypper lr -d

Probably you have the wrong libbluedevil2, that one must be installed from KDE:Extra as well.

You are probably correct. I had removed the newer version earlier so I don’t know, but I tried again just now and it works. Earlier I removed and installed only bluedevil from KDE:Extra but now I manually did it for both bluedevil and libbluedevil2.

(And about manually starting bluedevil - of course I did that only because it didn’t start automatically. I wanted to see the error message.)



On a HP 8510 W I could solve the OpenSuse 13.1 Bluetooth issues.
Most things were ready to use “out of the box”. Just Bluetooth caused some headaches: There was an entry in the startmenu for BlueDevil, but there was no effect when clicking it.
I began collecting internet information. By the way: some comments about Suse 13.1 & Bluetooth were not really encouraging
After downloading some additional software, after doing steps as recommended on different pages I concluded that the situation had not improved.
I decided to delete all Bluetooth-related software in Yast and reinstall software step by step. Attached Image shows the current situation
After doing ‘rfkill unblock all’ the bluetooth icon appeared in the controllist and when clicking on it the menu opened.
I could start the Bluetooth-settings and add devices now.
First I set up my smartphone, a chinese Xiaomi 3. After clicking on connect I had to enter a code and that was it. I was connected. My old Nokia 6021 was also connecting flawlessly. I can send and receive files.
After that I installed a Bluetooth Sound System called “Switch” and a headset LG WR780. I could connect both devices but they remained dumb.
Following some forum advices I tried to install a second soundcard, but without success. Disabling of Pulse-Audio had no effect either
But after I concluded, that the notification-sounds of my smartphone came out of the laptop-speakers I knew that I was on the right track.
I found the key when clicking on the Sound-Icon, then on mixer > settings > Audio-Settings
In the window as shown below (hopefully embedding of pics is working) you can give priority to individual devices
As soon as the headset was ranked first it was active. Now I just need to connect it to get it working.
I now even can send music by bluetooth from my smartphone, listening with the bluetooth-headset (headset is connected to computer, not to phone)!
Finally I wrote a script , to make bluetooth start at boot-time, since by default bluetooth is off. I named it “Bluestar” but you can use any name for it. The script just contains just

# The following line is turning bluetooth on

rfkill unblock all

On the HP 8510W there is no hardware-button to activate Bluetooth. There is a combined switch for Wireless Network and Bluetooth.
It is a little annoying to start a terminal after booting, just to get Bluetooth running.
So I added a symbolic link in
/etc/init.d/rc5.d/S99Bluestar which is pointing to the script Bluestar
Since scripts/links in /etc/init.d/rc5.d/ will be executed in alphabetical order I gave it the name beginning with S99 to make sure that this is executed after all other routines have been started.

Welcome to the forums MikeOffenbach. A bit of advice though - you are better starting a new thread (with descriptive title matching your problem), rather than by tacking on to an old thread like this. That way, you’ll catch the attention of others who may be able to help.

Thanks for your suggestion.
I think everyone can see that I am not really used to publish information like this. Sorry to say but many postings are written just for insiders. It often takes me long time to understand the code, since most authors are refusing to add any comments to it. In industrial environment this is unthinkable!
I am not a newbee, am experienced in Robot-Programming, where it is a must to comment the instructions in your software. Possibly Linux would be more attractive, if the insiders would remember their first movements and help others on their feet.
Actually I never published any comments before and I will possibly learn how to open a new thread, embed pictures a.s.o
But when reading all the negative comments on this topic, I felt that it was almost time for a positive message. I am using OpenSuse since a very long time and I remember having had just a few technical probems i.E. with powerd.
Most software was usually running out of the box. So, after making this good experience I would have been really embarrassed if release 13.1 would have serious bugs as mentioned.
The lesson in this: before writing negative comments, try patiently and don’t believe in “much helps much”. Sometimes one bit can solve the problem.

Okay, but this forum is for those seeking help for ‘hardware’ related problems. Your post seems to be more about offering tips or advice, so probably belongs in our ‘how-to’ forum:

Anyway, thanks for contributing. :slight_smile: