OpenSUSE 12.3 UI freeze with amd catalyst > 13.04 (latest fglrx)

So as the title says i wanted to have newer drivers than the one shipped with fglrx package, so last time i tried with catalyst 13.10 beta if i recall right, created the package with their .run, installed, everything went fine. The problem though was that for some reason the UI of whatever window didn’t refreshed, or refreshed very few times. So for instance if i opened a terminal and wrote some characters i would see nothing happening for several seconds.
One “fix” (if you can call it like that) was to keep moving the terminal window, in that case it was refreshing.

I tried to see the dmesg log and i could only find an “Assertion failed in …/…/…/…/…/…/…/…/drivers/2d/lnx/fgl/drm/kernel/hal_evergreen.c at line: 69”, written only once… and no other errors of failures.
Now i’m trying with catalyst 13.12 but i have the same problem, a part from the fact that it fails to build the rpm with just a “bad exit status in blabla/rpm-tpm”, so i have to install it without the package.

My graphic card is an ATI Radeon HD5850 1GB and i’m using Gnome.

Someone has the same issues? Someone solved it?

So i installed the latest fglrx64, 13.251-1, and i have the same issue, no one else have this?

I had many, many issues with AMD and 13.1
I couldn’t even do a graphical install.

I ended up reverting back to 12.3 and everything is peachy.

Does the latest fglrx package works for you on 12.3?

I have this issue with most application redraws not working. The bug looks gnome related (it redraws fine in the “thumbnail view” in the “application overview menu”), my work around is to use a different desktop environment.