openSUSE 12.3 System Hang

I just upgraded my laptop, a Dell XPS15, NVIDIA Graphics, 8GB Memory which had been running on openSUSE 12.2 with no problems. So far everything seems to work fine as I had it configured before and I’ve done all the system patches, updates to KDE 4.10, NVIDIA proprietary drivers, etc. System installation went flawlessly including wireless configuration.

3 Times now the system has done a hard freeze. Only way to get out is hard power off and reboot. It reboots fine. 2 of the times it froze I was in YaST in the process of searching for programs and once doing my printer configuration. The third time I was in the KDE Configuration screen.

This system does not use UEFI, so I don’t think it’s related to the existing thread on that topic.

Has anyone else had this problem?

Thanks in advance.

On 03/16/2013 07:46 PM, DMCorsa wrote:
> has done a hard freeze

if you open a konsole/terminal where you can see it while doing other
stuff, and run top…what do you see move to the top of top during
the freeze…

you maybe have to wait some seconds or minutes until top shows the
problem…

oh, and how long do these hard freezes stay frozen–that is, how long
to you wait to see if it clears itself (my experience is they often
do! maybe in 5 or 50 minutes)

also, note the time of the next freeze and then look in the
/var/log/messages around that time…


dd
http://tinyurl.com/DD-Caveat

I will check var/messages next time I reboot after a freeze.

Once it freezes, it never comes back, absolutely nothing responds. I can’t even close X using the CTL-ALT-BKSP-BKSP

On 03/16/2013 09:26 PM, DMCorsa wrote:
> it never comes back, absolutely nothing responds.

so, still try having top visible…it might tell something…

and, if you know the nearly correct time for a recent freeze you
should be able to find it in the log…

even if you immediately check the log after a crash/reboot the
evidence won’t be at the end of the log…


dd

Some users with nVidia hardware have been reporting problems wrt nVidia stability - which they worked around by adding their user to group ‘video’. I suspect this is NOT the case for you (possibly your user already belongs to group video), but you could check just in case.

Ok, I will try that and leave it open while I run. Thanks.

Thanks. I checked, I was not a member of the group ‘video’. I’ve added myself and will see if things improve any. Thanks as always.

I hope it works.

Note since a complete log out/in of GNU/Linux (not just the desktop, but GNU/Linux) is necessary to apply the new user settings, in which as a reboot is often easiest in this case to confirm functionality.

I have the same problem, on a Dell Precision M6700.
Nothing seems to help and most importantly: it is not clear what is the root cause of this issue.
I did add my user to the “video” group, but it does not seem to be a fix. Moreover, the system does not get “convinced” in any way to use the nVidia drivers - I did install the proprietary packages from nVidia, but it seems that the system is still using generic Xorg stuff.

At around the time of the freezes the /var/log/messages log seems to complain about networking - and, btw, the wireless is very flaky - it goes up and down, with most of the time working in a very slow mode. Again - there is no indication on why is it so, and it might point to the overall issue.

I just upgraded the BIOS to the latest from DELL and wait and see what happens, but I’m not sure that was the problem either.

Any tips, hints, advices are more than welcome - I’m a long, very long time SuSE/openSuSE fan and I’d love to continue using it. At the current point in time, I cannot even go back to 12.2 (other issues about the installation media that does not seem to succeed booting - I tried both USB stick and CD media - but this should be an issue for a different thread).

Thanks,
–bjh

The log file /var/log/Xorg.0.log may gave some more information on this. How about copying that and pasting it into SUSE Paste and press contribute on that site, and then when it gives you a web/url-address where that pasted content is located, post here the web/url-address.

… I’m trying to visualize what you are describing. You say your install of the proprietary driver on your PC did not work and another driver is being used, and this ‘other’ driver freezes during network disconnects ?

Can you please also provide the output of the command sent inside a terminal:


/sbin/lspci -nnk | grep VGA -A2

You note you can not go back to 12.2. Does that mean you are on 12.3 ? What desktop ? What method did you using to install the proprietary nvidia driver ?

Let me take it one at a time, beginning with the last one:

  • I am running 12.3 with KDE (tried for a bit with IceWM, but still had the same issue after a little while) - it is a brand new laptop and this is the first install. The previous laptop (a Dell Precision M4300 went through several openSuSE versions over the last 5 years without a glitch - and it still has 12.2 working perfectly. When I try to use an USB stick or a CD with the KDE Live - it gives an odd error related to DRM at boot time and I cannot install at all (I would consider going back to 12.2 with the new laptop if I could make the install work).

Now, the output from lspci is this:


/sbin/lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)
        Subsystem: Dell Device [1028:053f]
        Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [Quadro K4000M] [10de:11bd] (rev a1)
        Subsystem: Dell Device [1028:153f]
        Kernel driver in use: nvidia

I will get back with details about the first part.

Thanks,
–bjh

There’s also the networking issue - the wireless connection seems to work all right for a while, then it slows down to a crawl, gets stuck - sometimes it errors. An

/etc/init.d/network restart

gets everything back for a while and then again slows down.
After some of the freezes (I note down the time - the freeze locks all up, but I can see the time on the desktop clock) and check /var/log/messages - it almost always shows a network related issue.

–bjh

I missed this part of the question: I did add the nVidia repository to YaST’s Software Management and I just updated after the repository refresh. Right now I have nvidia-computeG03, nvidia-gfxG03-kmp-desktop and x11-video-nvidiaG03 (all of them version 310.32-15.etc.

If I run nvidia-settings, it pops up a message: “You do not appear to be using the NVIDIA X driver. etc”.

Thanks - that provides a good overview insight into what might be taking place. Your PC has hybrid graphics (ie both intel and nvidia). It is possible the Intel and not the nvidia graphic driverss are being loaded at boot. Or its possible vesa or fbdev more basic drivers are being loaded.

I recommend you install primus and bumblebee, setting up your PC as noted in this thread: https://forums.opensuse.org/english/get-technical-help-here/hardware/484188-setup-bumblebee-primus-opensuse-12-3-a.html I do not know enough about hybrid graphics to point exactly where in that thread you need to go.

As to this current thread - the current thread title “openSUSE-12.3 System Hang” is not very helpful if I am correct that this is a hybrid graphics problem. So you could either join the thread I quote, or start a new thread with a title “openSUSE-12.3 hybrid (intel - nvidia) graphics problem”. I propose a new thread as I do not have the expertise to help with hybrid graphic problems and you need to attract the attention of someone who has such knowledge.

Its possible given your PC has hybrid graphics that those rpms are inappropriate . In truth I do not know. The https://forums.opensuse.org/english/get-technical-help-here/hardware/484188-setup-bumblebee-primus-opensuse-12-3-a.html thread I quoted should hopefully give more information.

Here is the Xorg log:

SUSE Paste

I recommend you start a new thread on this. Make the title of your new thread something like “openSUSE-12.3 network connection slows down and stops at times” and place the new post/thread start in our network forum area. https://forums.opensuse.org/english/get-technical-help-here/network-internet/ That should obtain the attention of our network experts (of which I am not one).

I did want to check exactly the type of the graphics card, but unfortunately I cannot use sysinfo:// as it is not an option anymore - the replacement gives a lot of detail, but exactly not what I need - up to 12.2 (actually up to the previous KDE, to be fair), sysinfo:// displayed the exact details about the graphics card. Any idea how I can properly check in 12.3 (KDE 4.10)?

Thanks,
–bjh

Thanks. That is clear that the Intel graphic driver is being loaded:;;


    51.220] (II) intel(0): EDID vendor "CMN", prod id 5920
    51.220] (II) intel(0): Printing DDC gathered Modelines:
    51.220] (II) intel(0): Modeline "1920x1080"x0.0  141.29  1920 1976 2014 2110  1080 1084 1090 1116 +hsync -vsync (67.0 kHz eP)
    52.204] (II) intel(0): EDID vendor "CMN", prod id 5920
    52.204] (II) intel(0): Printing DDC gathered Modelines:
    52.204] (II) intel(0): Modeline "1920x1080"x0.0  141.29  1920 1976 2014 2110  1080 1084 1090 1116 +hsync -vsync (67.0 kHz eP)

and also that the build of the nvidia driver you installed does not appear to play with your PC’s hybrid graphic hardware:


    20.114] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

Again, I recommend the bumblebee primus thread that I pointed to: https://forums.opensuse.org/english/get-technical-help-here/hardware/484188-setup-bumblebee-primus-opensuse-12-3-a.html

Thanks for the insights and pointers - I will go the way you suggest and see what happens. I did hear about bumblebee, but it’s new to me and didn’t play with it before. Let’s see how it goes.

Thanks,
–bjh