Opensuse 12.3 on Asus G51J - Audio not working

Hello, first of all I am pretty unexperienced with linux, i just finally did the switch from Win7, although I have some experience with a debian server.

After installing Suse on my Asus G51J Laptop i couldn`t fast boot, it would freeze all the time during booting. But with the other options it worked. I solved this problem downloading and installing the Nvidia Drivers, however since i did this I dont have any sound output anymore. So i can normally boot now, but have no Audio at all. I guess it could be another driver issue, has somebody some advice on how to fix this, and where to get drivers for this Laptop?

Asus G51J
Intel Core i7 720QM
Asus G51Jx [Linux Laptop Wiki]
8GB RAM
500GB HDD
nVidia GTS 360M

Do you see the audio card in YaST ==> Sound ?

There are a number of possibilities … (1) installing the NVIDIA drivers may have enabled any HDMI hardware on your PC and audio could be inappropriately being directed to the HDMI device, … or (2) in a very rare number of cases, after installing the proprietary driver caused permissions problems and users had to add their user to group audio to work around.

But the above is premature speculation, and its best to learn more about your pc configuration. Please with pc connected to internet, open a terminal/konsole and send the command:


/usr/sbin/alsa-info.sh

and select the UPLOAD/SHARE option, and then let the script run to completion. After it is complete it will provide you with an Internet address where your PC’s audio configuration settings were uploaded. Please copy that Internet address (only) to this thread so we examine the configuration.

Also, considering installing the application pulse audio volume control (pavucontrol) and then follow the guidance here in this blog entry to ensure you have the proper audio device selected: https://forums.opensuse.org/blogs/oldcpu/pulseaudio-basics-opensuse-pavucontrol-96/

Thank you for your answers, i find it very likely that audio is like you said redirected to the HDMI.
Here is my Asla:

http://www.alsa-project.org/db/?f=41c9d73e67151782476bd270707e7cfe8b9cb711

Thanks. I note openSUSE-12.3 with the 3.7.10-1.16-desktop kernel and version-1.0.26 of alsa running on your PC. There are two instances of the alsa driver (kernel module) snd_hda_intel running, likely one associated with the main audio (an ALC663 hardware audio codec) and one associated with the Nvidia device:


!!Loaded ALSA modules
!!-------------------

snd_hda_intel
snd_hda_intel

I noted the sound cards recognized, where the order of devices is important.


!!Soundcards recognised by ALSA
!!-----------------------------

 0 [MID            ]: HDA-Intel - HDA Intel MID
                      HDA Intel MID at 0xf4900000 irq 53
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf3080000 irq 17

The order of audio devices there is important, as it suggests your nominal audio is card-0 and Nvidia is card-1. Hence the speculation of mine that sound is going through the HDMI is likely not correct.

Further, I note this:


!!Aplay/Arecord output
!!--------------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC663 Analog [ALC663 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 1: ALC663 Digital [ALC663 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and that confirms that your PC’s nominal sound device (an ALC663) is card-0.

The mixer settings hold the clue why your PC has no audio:


**!!Amixer output**
!!-------------

**!!-------Mixer controls for card 0 [MID]**

**Card hw:0 'MID'/'HDA Intel MID at 0xf4900000 irq 53'**
  Mixer name    : 'Realtek ALC663'
**Simple mixer control 'Master',0**
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Limits: Playback 0 - 64
  Mono: Playback 44 [69%] -20.00dB] **[off]**
**Simple mixer control 'Headphone',0**
  Playback channels: Front Left - Front Right
  Front Left: Playback 64 [100%] [0.00dB] **[off]**
  Front Right: Playback 64 [100%] [0.00dB] **[off]**
**Simple mixer control 'Speaker',0**
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback **[off]**
  Front Right: Playback **[off]**

From the above it is clear that Master volume is MUTED with it set OFF. The headphones are also MUTED with them set OFF. And the nominal speaker mixer control has playback OFF. ie there are three settings blocking both speaker and headphone audio.

You need to go to the mixer and unblock these.

If you can not figure out how to do that, then you can possibly do the above by sending these amixer commands (where I am speculating a bit wrt syntax):


amixer -c 0 -- set 'Master' on


amixer -c 0 -- set 'Headphone' on


amixer -c 0 -- set 'Speaker' on

… I could have the syntax wrong for the above (for example it is CRITICAL to have spaces exactly where I have them, and the uppercase/lowercase selection is critical), and it is typically easier for users (including easier for myself) to simply unmute the audio with the mixer and not send amixer commands.

Thank you sir, it is working now :slight_smile:

Strangly enough my KMixer won`t start, but the commands worked :slight_smile:

Maybe it is running already? (should be so by default)
Look for it in the systemtray, its icon looks like this on openSUSE 12.3:
http://wstaw.org/m/2013/07/09/systray.png

Just click on it and select “Mixer” to open the Mixer window.

If the icon is not there, try to kill KMix before you start it (“killall -KILL kmix” f.e.).

I have a similar problem with my Asus X750J.
My upload is http://www.alsa-project.org/db/?f=956d670a3109cb8cb946cc0dacac1da535c35af5
Thanks.
-Sean

I note pulse audio is not running. … Are you running LXDE desktop ?

I am also puzzled as to what the ‘similar’ problem may be. Please, can you be more specific ?

Thankyou and best wishes.


Sorry, but I don’t know what ‘LXDE’ is. I’m running KDE. Is that what you’re asking?

Specifics:

  1. I can rearrange the devices from the audio (Kmixer) icon and select which work, but all the HDMI ones don’t work.
    > HDA Intel PCH (ALC269VC Analog)
    > HDA Intel PCH, ALC269VC Analog (DefaultAudio Device)
    X HDA Intel MID, HDMI 0 (HDMI Audio Output)
    X HDA Intel MID, HDMI 1 (HDMI Audio Output)
    X HDA Intel MID, HDMI 2 (HDMI Audio Output)
    X Default
  2. After rearranging the devices, I can get Amarok to work.
  3. Still, the initial “welcome” tune upon sign-in isn’t produced.
  4. Youtube fails.
  5. VMWare Player cannot connect to the device.
  6. I tried to disconnect & connect drivers through YaST. It works /sometimes/. I see two Intel devices with ‘snd-hda-intel’ drivers.
  7. If I delete and configure the drivers in the right way, I will get an Intel error message. Once I get that, that channel works but not the other one. The configuration that has worked to cause the error is setting power save to any number of seconds. If I get a device-insert error, I have to start all over. Also, this funny configuration sometimes gets reset between reboots.
  8. I have been able to get sound from all three (above) apps, but it now doesn’t work at all, so I know it’s possible to get it to work.

Similarities: Asus, laptop, Intel audio, Intel HDA drivers, multiple audio “cards,” Kmixer dies sometimes

LXDE is one of the desktops that can be chosen to be installed instead of KDE, when one installs openSUSE (from an installation DVD). It is fairly basic, not as fancy nor as glossy looking as KDE, but it is light weight so for old computers LXDE tends to be more responsive than KDE. On LXDE pulse audio is not fully installed by default.

The ‘welcome’ is supposed to be OFF. Many users did not like it, so the default setting was changed. It can be switched ON, although I have never tried to do so. Possibly look under:

Configure Desktop > Application and Systen Notifications > Manage Notifications > Applications (tab) > KDE Workspace > Login … and change the setting there

This could be a flash or a codec issue. Did you install the packman repository for multimedia ?

A VMWare Player user needs to chime in here. I use Virtual Box with pulse audio and it works fine.

Once you have it working again, do some screen prints of the setup so you can easily restore this.

Noted.

Your problem thou reads to me to be quite different. Still if audio does not work now, then the ‘Asus G51j audio not working’ subject should hopefully draw the attention of some of our audio experts.