Opensuse 12.3 - Nvidia - Akonadi - Nepomuk error

After installing the updated nVidia driver (331 20-22.1) I appear to have similar issues with opensuse 12.3 x86_64 KDE 4.10.5 as those described in relation to oS 13.1 by imabe here. In summary: programs and services that depend on Akonadi or Nepomuk will not start. In particular Kmail does not start and this is a bad time to loose email services. Akonadi self-test reports ERROR Akonadi control process not registered at D-Bus. ‘akonadictl start’ fails with driver error: “QMYSQL: Unable to connect”. Smart -H test on HDD reports: PASSED

The updated nVidia driver was installed with yast2. On completion an error message was displayed but yast2 window closed before it could be read. I know I should change this behaviour. Not sure where to look for log history. Seems my best option for now may be to downgrade the nVidia driver to 319.32-15.1.x86_64. But this is not straightforward for me. I note that 319.32-15.1 versions exist in the repository but they do not appear in the repository visible to me in yast2, named as: obs:// I do not understand this.

Can I download the relevant 319.32-15.1.x86_64 files from and install them from a local repo? If not what other action is recommended or what additional information is requred to assist assessment. Thank you for considering my support request.

You can select different versions of a package via YaST.
Look at the screenshot. There you see in the bottom right window some tabs (Description, Technical data…).
Select “Versions”.

Thanks Kieltux. Not so in my case. Hence the question. Screenshot here.

Sorry Tallowwood, my error.
I forgot, that we use a local mirror of some repositories, like the Nvidia repository… because of this “problem” (only the newest version is visible).
Local mirror with ftp and then build a personal repo with:

cd /local/suse/openSUSE12.3/Nvidia
createrepo ./
gpg -a --detach-sign repodata/repomd.xml

But it should be possible (never tried personal) to download just the needed 3 rpms (nvidia-computeG03, nvidia-gxf03-kmp-desktop and x11-video-nvidiaG03) and then install via cli.

Huh not sure if related but I have the same issue as you. I cant use
KMail or anything else that relies on Akonadi. I first installed the
Nvidia driver manually (before repo was first available), did not try
kmail yet so I cannot say if it was broken then, once the repo was put
up, I removed the manual installed drivers and went to the repo provided
ones, had some issues regarding opengl so I ended up removing them and
going back to the manual installed ones. It was after this that I first
ran Kmail and noticed it was not working. Driver version is 331.20 and I
am on 13.1.

Was I helpful? Click that little star so that I can brag about it to my
invisible friends >:)
Bring the Penguins Back!

Downgraded nVidia driver files from local repo but issue persists. Unable to start Kmail. Self-test reports that: Akonadi control process not registered at D-Bus. No resource agents found. Akonadi error: “QMYSQL: Unable to connect”. Some discussion in this bug report, but no solutions yet. I will set up alternate email services and await futher advice, if possible. Thanks for the help provided.

Solved by traditional akonadi clean up. Close all Akonadi apps. Backup ~/.local/share/akonadi & ~/.config/akonadi, delete Akonadi resources in system settings, delete ~/.local/share/akonadi & ~/.config/akonadi and rebuild Akonadi resources in system settings. Restart Akonadi apps. Seems to have worked. Toes and fingers crossed. This is not wise advice, just a guess - YMMV. Thanks to those who helped.

IME renaming ~/.local/share/akonadi is enough. It triggers a rebuild of the database from scratch.
Mind, I have serious doubts whether this has got anything to do with the NVIDIA driver, but I could be competely wrong.

Knurpht wrote:

> IME renaming ~/.local/share/akonadi is enough. It triggers a rebuild of
> the database from scratch.
> Mind, I have serious doubts whether this has got anything to do with the
> NVIDIA driver, but I could be competely wrong.

I’m about 99.9% sure the nvidia 331.20 driver is the problem. If you read
the discussion on the nvidia support site, it looks like the problem is that
sometimes the SIG mask is not being propagated correctly through
pthread_create(). In my case that lead to mysqld not exiting during session
closeout. The next time I logged in, the mysql database was still locked,
causing initialization failure in akonadi, which got passed up the line to
kmail and calendar.

I could workaround this by logging in another way (CTL+ALT+F1 or ssh) and
killing the mysqld process - then I could log into the GUI successfully.