openSuse 12.3 LXDE Mst 2 gmixer


I installed openSuse 12.3 LXDE Milestone 2

My netbook: Toshiba nb550, Prozessor AMD C-50

There is no way to control the volume of the sound. It is impossible to add the volume-control to the panel. When I try to start gmixer from the menu happens nothing.

This is the output when I try to start gmixer from the terminal:

joerg@linux-llm7:~> gmixer
** Message: pygobject_register_sinkfunc is deprecated (GstObject)
W:Failed to load icon Symbol »stock_line_in« nicht im Thema vorhanden
Traceback (most recent call last):
File “/usr/bin/gmixer”, line 1168, in <module>
GMixer(options.daemon, options.custom_mixer_cmd, options.pixmap)
File “/usr/bin/gmixer”, line 640, in init
File “/usr/bin/gmixer”, line 1013, in _build_gvolumes
UnboundLocalError: local variable ‘sep’ referenced before assignment

I have created a strace.log but I don’t know how to add it here.

Since 12.3 has not been released these questions must be posted here

I have created a strace.log but I don’t know how to add it here.

use SUSE Paste

This thread is closed for the moment.

Will be moved to Pre-realease/Beta!

moved and open again.

Hello andy04,

You are of course welcome to try and test new openSUSE versions before they are released. And it is also fine when you report problems you found in it. But please do so in the Pre-release/Beta forum. That is where your fellow testers are. And those peoblems will then not bother those who use supported versions of opeSUSE.

Also, when you post copies/pasted computer terminal text, please do so between CODE tags. You can create them using the # button in the post editor.

I have a similar problem with 12.3 milestone 2 KDE on a ThinkPad X-41. I filed a bug report at , but it seems to be getting no real activity.

Maybe if you add your experience there something will start happening.


I noticed that I am talking of 2 different bugs.
There are in the menu under “Unterhaltungsmedien” (I don’t know this word in English, sorry) two sound-mixer: the Audio Mixer and the GMixer. The Audio Mixer is working the GMixer is not working.

Here is the strace.log for the GMixer:

SUSE Paste

But there is another Bug: I have no Sound at all and this is probably the reason why there is no volume control plug-in in the panel.
I will start a new thread for this issue.

@crmrhm: sorry, but I don’t believe that the problem is similar.

@crmrhm: see here for further information:

I don’t know about openSUSE-12.3 as I have yet to install it (I just got back from a 1 month vacation with limited Internet/PC access).

On 12.1 and 12.2, on my LXDE I confess I went a step further than the install and I enabled pulse audio and installed pavucontrol. That could be a pragmatic approach to adopt on 12.3 until any basic 12.3 anomalous behaviour wrt volume control is fixed.

Please write bug reports as appropriate on 12.3.

OK I installed pulseaudio. It is working fine.
I think you have to install xmms2-plugin-pulse if you want to try out lxmusic with pulseaudio.
But unfortunately now there appears sometimes a noise while changing the volume.

The noise was really unbearable. So I tried out volti. I had to install pyalsaaudio first:

pyalsaaudio-0.7-1.4.x86_64.rpm Download Mirrors

and then volti:

PackMan :: Informationen zum Paket volti

I started the volti-mixer from a terninal. With the Master volume control I can change volume without noise. When I try to change the PCM volume exactly this noise appears again. PCM is HDMI. I think the noise has something to do with PCM.

When I tried to start volti (in the notification field) I received this error messages:

[] can’t open Master control for card Generic, trying to select first available mixer channel

[] can’t open first available control for card Generic
error: list index out of range

I had to change in the ~/.config/volti/config the value card_index = 0 to card_index = 1

The volti volume-control is now in the notification-field.

I added @volti to the /etc/xdg/lxsessio/LXDE/autostart

Now I have volume control without noise.

For me this combination ( pulseaudio and volti ) was the only way to make sound working in XFCE 11.4 and I was over 1 year happy with this. :slight_smile: