OpenSuse 12.3 LXDE Most of the Menu Entries Missing


I installed OpenSuse 12.3 yesterday on one of my laptops. The primary DE I used is KDE, however I also installed xfce and LXDE, I use them mainly for remote sessions (I already have sich setup for 12.2 on my main rig). However the issue is that the menu entries in LXDE are mostly missing, sometimes missing completely. Only Graphics and Games submenu is populated, Internet submenu exists, but is empty. The rest is gone.

As I said, sometimes the menu does not load at all leaving only Run and Logout options in the menu. Sometimes it happens during LXDE usage. It is behaving very strangely.

I alredy tried to delete .cache/menus/<file with a long name> and ahve ti re-created. It was re-cerated, but the problem stays.

Manus in KDE and XFCE are OK.

Are xdg-menu and lxmenu-data installed?

Yes, they are.

I installed it using the pattern package, so I would not expect anything missing. But I double-checked these two, they are there.

Is anyone able to confirm it is my isolated problem? Are menus working OK for everyone here?

Thanks a lot.


same problem. I had all the entries after install but after using lxmed, some of them disappeared.

No changes made with lxmed.

I can verify my experience is the same using lxmed with LXDE 0.5.5-40.1.3 on openSUSE 13.1.

Initially, lxmed suggests that various apps should be “visible” but aren’t. In fact, it looks like it doesn’t matter for <any> app whether “visible” is enabled or not.

Nevertheless, I pushed onwards and tried to add an entry.
Now, that entry exists in the Menu but as the previous post describes, multiple entries are now missing. The existing menu entries are so few, the only saving grace is that the “Run” menu item now exists and supports auto-completion (otherwise practically no app can be launched.

Thankfully, for me this is a Virtual Machine so I can just trash it and clone my template to create a new machine instead of trying to undo what lxmed did to this system.

So, beware. It seems that somewhere/sometime the past couple years the LXDE config file changed and lxmed (a separate project) hasn’t caught up or something happened in the openSUSE implementation (maybe I’ll create an LXDE in another distro and test).
AFAIK there is no GUI method that can modify the LXDE Main menu at this time. YMMV, but the best approach likely would be to edit the raw config files. For me, I’ll probably just create a bunch of startup scripts for any app and place them in a common folder.


Using 13.1, if I right click and select Applications, I get a fully populated list with each submenu fully populated. If I click on the openSUSE icon, a few entries are missing from each submenu except Office where only the first two entries appear. This suggests that there is a screen drawing issue where the popup list is very long.

Took a few minutes today to investigate lxmed further.

Bottom line:
This GUI app works fine in Fedora, but interestingly when I installed lxmed, it required a dependency which wasn’t identified in the package manifest… beesu. After installing that, lxmed worked fine in Fedora.

So, then I turned my attention to openSUSE. I then discovered that beesu has been deprecated (no longer supported) in openSUSE which in the case of lxmed likely is causing corrupted menus.

It doesn’t look like lxmed will ever work in openSUSE moving forward. DO NOT USE because there is no warning… It will corrupt your menu files. Lxmed will appear to install successfully, but once you execute “save” you’ll have a lot to repair manually.

Instead, it looks like for now the only acceptable method to edit the Main Menu is to edit the config files manually.

Relevant stuff(yes, beesu is embedded deep in the announcement):


Do not use LXMED.** It will corrupt your main menu.**

Instead, I have created simple instructions for creating new LXDE Main Menu items, slightly modified to apply to openSUSE.