openSUSE 12.3: Kein Netzwerk (eth0) nach der Installation

Hallo zusammen,
die Installation von openSUSE 12.3 auf einem Lenovo G-580 hat reibungslos geklappt (incl. UEFI dual boot mit Windows 8).
Allerdings steht nach der Installation kein Netzwerk zur Verfügung, weder eth0 noch wlan0 sind vorhanden. YaST2 liefert in den “Network Settings” im Tab “Overview” folgende Fehlermeldung:

**Attansic Ethernet controllerBusID : 0000:02:00.0
**
Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

Was muss ich jetzt tun?
Besten Dank für Eure Unterstützung!

Als erstes sollte dieser Beitrag nach Netzwerk gehören.

Dann:
Poste mal:

/sbin/lspci -nnk | grep -i -A2 net

Wobei ich da an dies denke:
https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/485001-get-your-wired-ethernet-working-attansic-ethernet-controller-1969-1091-a.html
Das gilt auch für die ID 1969:1090.

[QUOTE=Sauerland;2541145]Als erstes sollte dieser Beitrag nach Netzwerk gehören.[QUOTE]
Oh, sorry, für meine falsche Auswahl :shame:

/sbin/lspci -nnk | grep -i -A2 net
liefert

02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8162 Fast Ethernet [1969:1090] (rev 10)
           Subsystem: Lenovo Device [17aa:3979]
03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
           Subsystem: Broadcom Corporation Device [14e4:0587]
           Kernel driver in use: bcma-pci-bridge

Danke für den Link (https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/485001-get-your-wired-ethernet-working-attansic-ethernet-controller-1969-1091-a.html)! Da arbeite ich mich mal durch …

Perfekt!

Die Vorgehensweise wie unter
https://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/unreviewed-how-faq/485001-get-your-wired-ethernet-working-attansic-ethernet-controller-1969-1091-a.html
beschrieben, hat auf Anhieb funktioniert: eth0 ließ sich problemlos konfigurieren. Vielen Dank!

Gibt’s eine ähnliche Beschreibung, wie ich den störrischen Broadcom Controller zum Funken bekomme?

Broadcom Wireless – Linupedia
https://www.suse.com/releasenotes/i386/openSUSE/12.3/RELEASE-NOTES.en.html#upgrade

Funktioniert!
Besten Dank!
:slight_smile: