openSuSE 12.3 installation issues with ASRock Z87 Extreme6

Hello to everybody who take care of my problem!

Yesterday I received my new motherboard and CPU. They are ASRock Z87 Extreme6 and Intel Core i5 4670K. I was so glad until I tried to install OS. The installation process stops at the “loading udev” step. I tried to load safe mode, no ACPI mode and had no success.

So maybe someone knows known issues with such hardware as mine. My full config is:

ASRock Z87 Extreme6, specification is here
Intel Core i5 4670K
Crucial Ballistix Tactical Tracer memory modules (4x2Gb)
MSI NVidia GTX460 grachics
TP-LINK TL-WN881ND wireless card
OCZ Vertex 4 SSD
Seagate Barracuda ST1000DM003 HDD
Western Digital WD20EZRX HDD
Thermaltake TR2 600W power supply

My previous motherboard, CPU and wireless card were:

ASRock Z68 Extreme3 Gen3
Intel Core i7 2600K
Tenda wireless card

and OS installed with no problem.

Hello,

what will be shown in the last step of loading udev?
Do you get any error message or what is the last device?

I finally found the reason. It is ASMedia SATA3 controller. It doesn’t work in linux at all. I even tried the openSUSE 13.1 milestone 4 with kernel 3.10.