Opensuse 12.3 fails to boot

I dual booted Opensuse 12.3 with windows 7 about a month ago and it has stopped booting within the past few days. When I select Opensuse from the Grub 2 menu, I get the Usual “Loading Linux 3.7.10-1.16-desktop” then “Loading initial ramdisks” message and then a blank screen. I tried to reinstall Opensuse using the install dvd but that just removed windows 7 from the Grub 2 menu.

How did you partition the hard disk?

I used the default partitions and Opensuse used to work

Install any video drivers? Perhaps a kernel up date in which case you may need to reinstall the drivers.

Can you boot to safe mode? Select advanced at menu

I get the same blank screen when I try to boot into recovery mode

press esc immediately after the selection to suppress the splash screen see what the last message shown is or any failed starts etc

When I press esc I get a quick message saying “fast TSC Calibration Failed” then it continues to the blank screen

Please disable plymouth:
Press ‘e’ on your keyboard when you are at the boot menu, look for a line starting with “linux” and append “plymouth.enable=0” to it.
Then press ‘F10’ to boot.

You should see much more messages then…

Now I get this message,
" 0.000000] tsc: Fast TSC calibration failed (that part is the same as before)
doing fast boot
Creating device nodes with undev"

Hm, so it hangs quite early in the boot process.

Do older kernels work? You should be able to select one in “Advanced Options” in the boot menu.

I tried using Linux 3.7.10-1.1-desktop and got the same result

Are you able to boot to command line interface atleast.

I can open a command line in Grub 2

Do you have a live DVD?

If so boot that and run fsck against the root partition on the hard disk. It sounds like you might have a damages door file system.

Also may want to run smartctl to see if the disk has damage.

Take a picture of the kernel panic and then upload iot so we can see.

run startx and then post the output after booting in command line.

In grub2? I doubt he will have much success with that… :wink:

Try to add “init=/bin/sh” to the kernel boot options.
You should get to a text mode command line then.
Try to fsck all your partitions:

fsck -f /dev/sda1

and so on. (although /dev/sda1 maybe would be swap, so better start with /dev/sda2; have a look at “fdisk -l” to see you partitions and types)

Maybe that helps?

The same problem I have on version 13.2 several months now and I’ve tried everything I found on the web to solve and unsuccessfully.
I’m thinking to install it all over again but with a different distribution of Linux because I was disappointed with OpenSuse.

What can I say 13.2 runs great for me with absolutely no problems. With out knowing the details of your hardware it is impossible to help you.

Same here.

Btw, this thread is from 2013 and about 12.3. And it probably was a very specific problem as well.
Please open a new one for your current problems with 13.2 if you want further help. And in that case, please don’t forget to describe your actual problems in more details. Just stating that it fails to boot and you’ve tried everything you found on the net does not really offer a good starting point for suggestions…