openSUSE 12.3 and the Firefox and Thunderbird crash reporter

Today did an update from 12.2 to 12.3 KDE 64
followed the guide to do the update

Everything went perfectly and almost everything works perfectly.

The only problem I have come across so far is that every time I exit Firefox or Thunderbird (both launch and run without problem) the crash reporter opens up and reports a crash.

Running from CLI absolutely nothing gets reported.

Information in the crash reporter appears to be unuseful (at least to me)

here it is

Add-ons: %7B58D4392A-842E-11DE-B51A-C7B855D89593%7D:2.0.7,%7BBDD92442-0534-4D6F-A966-BAB7D561D781%7D:0.7.10,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:17.0.3
BuildID: 2013021500
CrashTime: 1363255917
EMCheckCompatibility: true
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1361802669
Notes: OpenGL: Intel Open Source Technology Center – Mesa DRI Mobile Intel® GM45 Express Chipset – 2.1 Mesa 9.0.2 – texture_from_pixmap

ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: release
SecondsSinceLastCrash: 406
StartupTime: 1363255898
Theme: classic/1.0
Throttleable: 1
Vendor:
Version: 17.0.3

This report also contains technical information about the state of the application when it crashed.

anybody else come across this or have any ideas.

I have tried new profiles without success and removed any addons.

Hi, haven’t seen the crash reporter, but I definitely had a couple of crashes (disappearances) of SeaMonkey, suddenly and silently when carrying out a normal operation, probably just clicking/selecting. Also had another crashed browser (think it was SeaMonkey). It probably went wrong during a power management action while away from the machine. That took out the desktop, and needed a reboot.

Also using Firefox here, but so far don’t recall a problem. Sorry, it’s a bit vague, but will return here if it happens again when on 12.3.

not sure if the following might contain any clues . . . .
but running

thunderbird -d gdb

on exit I get the following error

Program received signal SIGSEGV, Segmentation fault.0x00007fffeffdc652 in ?? () from /usr/lib64/libcairo.so.2
(gdb) bt
#0  0x00007fffeffdc652 in ?? () from /usr/lib64/libcairo.so.2
#1  0x00007fffeffdc8e4 in ?? () from /usr/lib64/libcairo.so.2
#2  0x00007fffeffd8349 in ?? () from /usr/lib64/libcairo.so.2
#3  0x00007fffeffaaed3 in cairo_surface_finish () from /usr/lib64/libcairo.so.2
#4  0x00007fffeffd541c in ?? () from /usr/lib64/libcairo.so.2
#5  0x00007fffeffd03b8 in ?? () from /usr/lib64/libcairo.so.2
#6  0x00007fffeff6e2c7 in cairo_device_finish () from /usr/lib64/libcairo.so.2
#7  0x00007fffeffd0447 in ?? () from /usr/lib64/libcairo.so.2
#8  0x00007ffff0fae282 in XCloseDisplay () from /usr/lib64/libX11.so.6
#9  0x00007fffef1307be in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
#10 0x00007ffff15d6988 in g_object_unref () from /usr/lib64/libgobject-2.0.so.0
#11 0x00007ffff2af3246 in ?? () from /usr/lib64/thunderbird/libxul.so
#12 0x00007ffff2af8f0b in ?? () from /usr/lib64/thunderbird/libxul.so
#13 0x00007ffff2af9026 in XRE_main () from /usr/lib64/thunderbird/libxul.so
#14 0x0000000000402684 in ?? ()
#15 0x00007ffff5bf0a15 in __libc_start_main () from /lib64/libc.so.6
#16 0x0000000000402701 in _start ()
(gdb) 

so appears may be something related to libcairo

tried reinstalling all associated libcairo files but problem persists

You have to change the settings in ‘Configuration of Gtk apps style’ to something other than QT curve.

Perhaps swannema means
http://storage6.static.itmages.ru/i/13/0315/s_1363327736_5410655_a1e69c2e4e.png](http://itmages.ru/image/view/938936/a1e69c2e)

BTW: I no issues at all

ahhh . . . yes, you are right

Changing to something other than qtcurve avoids the firefox/thunderbird crash on exit.

The unfortunate thing about this is that it may be a showstopper for me as far as using 12.3 goes (at least until the bug is addressed) as I do not want my gtk apps looking different to the native kde apps.

Do we know if there is a bug report on this already?

btw - openSUSE 12.2 with KDE 4.10 does not exhibit this bug with qtcurve so I wonder where the issue lies.

Yes, I can confirm that openSUSE 12.2 did not exibhit this bug and the problem lies within libcairo.

I tried swaping the libcairo1.12.8 (12.3) with the one from 12.2 (libcairo 1.12.2) and now the bug is gone.

I opened a bug report on this a few days ago because I couldn’t find anything in bugzilla - so we’ll see what comes of it.

https://bugzilla.novell.com/show_bug.cgi?id=809645

I added my two cents to the bug report. It is probably a simple fix, but I’m no coder. I like qtcurve enough to live with it until it can be patched:)

an update to KDE 4.10.2 and qtcurve 1.8.14-58.2 from the obs KDE extra repo has fixed this issue.

The qtcurve-gtk2 patch I installed today in 13.1 introduced this bug again. Had to remove the patch to get firefox to work with qtcurve. The patch is "qtcurve-gtk2 (1.8.16-2.4.1). I guess someone uploaded the old bug again with this patch.