openSUSE 12.3 & 32 bits Wifi doesn't work on HP laptop

**Hello openSUSE friends!

I have openSUSE 12.3 & 32 bits downloaded and installed but I have a huge issue with it. It’s a network issue and everybody of you know how important to use the Internet those days!

The issue is like this:
I connect to the Internet, just like I used to do in other Linux & Windows & it works just fine, I download things and I can and surf the Internet just fine, but after a while of connection to a Wifi network it says there’s no Internet, when I open the browser and try to open up a page it says no network connection, but it’s actually connected, also, I have my iPhone connected to the same network and it never says no Internet connection, actually my Internet is good, not slow at all and when it happens I turn off the wifi from the laptop button then turn it on in a second or I disconnect and connect again and it works again and after a while and disconnects.

So, how to fix this?

[size=4]Please hel[size=4]p [size=4]me fast[size=4], I need help.[/size][/size][/size][/size]
For full infromation about my laptop it’s:

HP Probook 4520s

And that’s the [size=4]official [size=4]page of my laptop. Take a look:[/size][/size]**
HP ProBook 4520s Notebook PC

Can you please use the default font and not shout to us?

What do you mean by “Henk van Velden” ?

That is the contents of my signature here and it happens to be my name.

Oh, sorry, yes, I will use the normal font from now on, thanks for telling.
Also, I’m new here.

Hi
On my HP ProBook 4525s I use the broadcom-wl packman package.
PackMan :: Package details for broadcom-wl

Can you confirm you hardware;


/sbin/lspci - nnk |grep "Network"

Hi Akiro,

The code to be entered in a console to confirm that your laptop has a broadcom card and its type should be corrected:

/sbin/lspci -nnk |grep Network

If it turns out the you have a broadcom 4312 or 4313 that hp product info says are used with you model then the broadcom-wl package should do the trick. However, you may need to blacklist modulues shipped with the stock opensuse kernel. They have a tendency to interfere with the broadcom-wl package. I have an hp laptop and do it with the modprobe.blacklist parameter during the install boot. There are a couple of ways to do it with your system as you already have opensuse installed.

The method that I use is this:

  1. Start YaST
  2. Go to System
  3. In system, click on “Boot Loader”
  4. In the boot loader setting panel, click on “Boot Loader Options” button
  5. Look at the “Optional Kernel Command Line Parameter” line. Insert the following before any of the other entries:

modprobe.blacklist=ssb,bcma,b43

making sure that there is a space between the b43 and any text following on that line.
6) Click OK
7) Reboot

After reboot: confirm that you have the broadcom-wl-kmp and broadcom-wl packages installed.

cmrntnnr

Thank you for correcting the typo (blank space) here. But would you also be so kind to use the CODE tags in the future (you get them by clicking on the # button in the toolbar of thepost edotor). They are very important in avoiding such typos as you just corrected (and the typo was very obvious because it was between CODE tags). Thus:

/sbin/lspci -nnk |grep Network

Thanks in advance

Also,
For starters, <don’t> install any of those HP drivers, they’re for very old kernels only. The only HP update you might consider installing is the BIOS firmware update.

Besides the lspci output,
I’d also recommend running the following and posting the output

systemctl -a | grep failed

TSU