[opensuse 12.2] xdmcp and permissions issues

Greetings !!

Let me first give details of the context: I’m working in a laboratory in a school… since two weeks now the heating system is down, we lost three computers due to the cold and humidity.

One computer finally survived, the power supply was dead and replaced and fortunalety we could boot again the openSuSE 12.2 that was installed on.
Problem is, the two other computers containing the students different works (unbacked up as usual) are dead (motherboard or GPU).

I couldn’t replace them quick so I tried something.

I put the two hard drives on the survivor computer and mounted the different partitions.

/dev/sdb1 → (the corresponding root partition) /media/jasonroot (acl,defaults,user)
/dev/sdb2 → (the corresponding home partition) /media/jasonhome (acl,defaults,user)

/dev/sdc1 → (the corresponding root partition) /media/jessicaroot (acl,defaults,user)
/dev/sdc2 → (the corresponding home partition) /media/jessicahome (acl,defaults,user)

…then I created the two users on the tolunay’s computer using the root account

I created a symbolic link on tolunay’s /home folder to /media/jasonroot (because most of the works were done using the root account), I did the same for jessica’s. The “home” directory for jason and jessica are not crucial actually.

ln -s /media/jasonroot /home/jason
ln -s /media/jessicaroot /home/jessica

That was the first step…

In the second step I set up the xdmcp feature in order to let jessica and jason work from a replacement computer that couldn’t simply use the SATA3 hard drives from the two dead computers because there wasn’t room to swap them.

It worked (I could login) but I got a lnusertemp error (call to lnusertemp failed (temporary directories full ?)).
I was in a hurry so I didn’t wrote down the different commands I did to fix it up. It was about chown and chmod, the history hasn’t been deleted I could check it tomorrow.

My question is:

How can I map both two users as root ? I added both users in the “root group” but it seems that we need to change the group id of different folders to “users” to avoid errors such lnusertemp… and set them in rw mode for group.
When diving on the desktop there were lot of messages asking for the root password for the tolunay’s computer I did not write them down yet but it would be nice to avoid them (there were at least ten or eleven prompt windows)…

Is this possible to avoid making too much alterations to the hard drive that have in a near future, I guess, go back to another tower to be used as the boot device ?

I know once the hard drive back to the tower that a chown root:root -R /root and chown jason|jessica:users -R /home/jason|jessica with chmod 755 -R /root and chmod 755 -R /home/jjason|jessica will restore the original settings.
I did nothing on the root directory except a chgrp users -R on /tmp and /var/tmp (with chmod 766 -R) but it didn’t fixed the lnusertemp error (I did not rolled back to the original values).

Thank for your patience ^^


The question was a non-sense.

The root access thru xdmcp is ruled by system wide settings"/etc/sysconfig" and by default it is set to No (no root access thru xdmcp).
The different messages displayed asking for root access were related to the different windows opened in dolphin referring to file system points that were owned by the root account (as before the cold damages this user was working using the root account).
I did another try and the user jason or jessica logged without any messages and with the related user account (jason@tolunay or jessica@tolunay), that’s nice.

The different chmod and chown I did to resolve the issue with the lnusertemp issue were focused on the different files starting with a dot (.) in the users home directory.

I think I would not have been forced to do so if I passed by the useradd jason -d /home/jason-s /bin/bash -g root -m I did a try and the owner and owner group were set correctly.

Sometimes we forget the good tricks…