OpenSuse 12.2 USB Mouse Problem

Hi All.
I have a acer V3-571g laptop.
I have installed opensuse 12.2 & synaptics touchpad package.
Touchpad mouse works well but when i try to plug in my usb mouse, the usb mouse led is turned off until i press one of the buttons of the usb mouse.
Then the laser led of the mouse get turn on and mouse will work until i move the usb mouse or press its buttons.If i don’t move the usb mouse or click for some moments , usb mouse get turn off again and do not move till the next mouse click.

i have tried all usb ports,and even with different usb mouses,but nothing changes.
Can anybody help me?

I 've found that when the laptop is on battery mode it works like this.I think its because of power saving or some settings like that.
When the laptop is connected to AC power, the usb mouse works well.
Anyone has a solution?

Still no solutions?
Seems everybody is on vacation:D.

Don’t know… my usb mouse works fine on battery on this laptop when
on battery.

What desktop?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.6-2.10-desktop
up 5:47, 3 users, load average: 0.15, 0.15, 0.14
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

On 09/08/2012 12:46 PM, phenomx64 wrote:
> When the laptop is connected to AC power, the usb mouse works well.
> Anyone has a solution?

check for power savings setting in the BIOS…
and, maybe you can find some in your desktop settings (but, you have to
tell us which DE before anyone could possibly tell you where they are…)

or, have you experimented with powertop? i did the other day and had a
heck of a time keeping the mouse working correctly…(it wanted to take a
nap about every three seconds–caution!)


The problem is the laptop-mode that suspend the usb ports power.
For let the usb powered on with mouse plugged you must edit the /etc/laptop-mode/conf.d/usb-autosuspend.conf in this way:


Very very thanks worked like a charm!
In addition I 'm using KDE Desktop 4.9.1. There 's not a lot bios setting in the bios.only few about boot priority & passwords. It’s a laptop bro,so no advanced bios :wink:
Thanks all again.

I did not find laptop-mode in my /etc and "find /etc -exec grep AUTOSUSPEND {} ;" found no occurence.

On 2012-12-17 09:06, serspock wrote:

> I did not find -laptop-mode- in my -/etc- and -“find /etc -exec grep
> AUTOSUSPEND {} ;-” found no occurence.

Then install it.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

laptop-mode-tools is not installed by default. If you do install it, it will activate usb autosuspend. If the mouse doesn’t support that feature, then the LED goes off and you can’t use it anymore. There is a configuration file for fixing that.

If you haven’t installed laptop-mode-tools, that’s not the problem, but perhaps another powersave program is doing the same thing. You might want to verify that a disappearing LED is indeed the issue.