Opensuse 12.2 upgrade issue: "Started LSB: SuSEfirewall2 phase 2


I upgraded my opensuse 12.1 box to 12.2 yesterday night using the instructions here: SDB:System upgrade - openSUSE

I used the zypper dup --download “in-advance” option. It pulled down around 1900 packages and installed them.

Now when I restarted the machine I saw the option of Desktop with the latest 3.4 kernel. I selected it and it ran some checks and stopped after dislaying the following message : “Started LSB: SuSEfirewall2 phase 2”.

At this screen if I use Ctrl+Alt+F1, I am shown a terminal prompt through which I can login but not through the X.

Can someone kindly help me out with this?


I also have the same problem. I would thought it has to do with Nvidia but Xorg.0.log wrote the module have been loaded.
Strange the I couldn’t find any info when I googled the problem.

Anyone else had the same/similar problem?

EDIT: I wrote this post on a Live Gnome CD of 12.2 64bit. HTH.

I, too, thought it was an Nvidia issue. But, I used that method to upgrade an old test box and when I installed the Nvidia driver the “hard way” everything worked fine. So, I decided to upgrade my regular computer but couldn’t find the page you reference a second time. Instead, I burned a Net Install CD and tried that. It failed with the error you list. After reboots and re-installs and getting different errors and plain lock-ups, I gave up and burned a Live-CD. That ran well but gave me other errors. After a dozens tries at fixes, I did an install instead of an update. Still had problems. I finally installed the Nvidia driver the hard way and got things working. However, I still get that text grub screen. Since everything else is working, I plan to leave well enough alone.

I wonder if I got the same problem as you had or have. My 12.2 system (I did not perform an upgrade, but a clean install ) is unbootable at the moment after I installed an openSUSE patch which replaced openSUSE KDM and other KDE branding from the 4.9 repo to openSUSE 12.2 oss update repo (if I recall correctly). Files where replaced with KDE branding files.

In GRUB2 I switched off the splash to see what was happening and everything stops after this last message:

starting LSB: SUSEfirewall112 phase 2 ...

Did you resolve your issue?

I’m on a openSUSE 12.2 system with kernel 3.4 and KDE 4.9 .

‘Blacklist Nouveau’ worked for me.

See here:

Opensuse 12.2 upgrade issue: "Started LSB: SuSEfirewall2 phase 2 … hangs up

I had the problem solved by using “SDB: NVIDIA the hardway.” (

(1) download “” from the NVIDIA download homepage “

(2) “# sh ./NVIDIA*” at your download directory with superuser. Follow all the directions and agree to install it.

(3) “# modprobe nvidia”

(4) “# rcxdm start”

(5) “# reboot”


Dongwoo Sheen

Hi, I’ve encountered this same problem with a clean install of 12.2. I’ve followed the instructions for nvidia drivers the hard way including adjustments to blacklisting nouveau in grub2. However, after rebooting, I’m still hanging at susefirewall2 phase 2 during boot. Can’t get to the kde login, can only login to the terminal. Did I miss something, or was there another adjustment for 12.2?

Look at your xorg log to see if it gives any clues as to where/why it (X) is failing.

Thank you very much! This also solved my problem

You shouldn’t be using manual installation of the drivers unless there is absolutely no other way, they will break on every kernel update.