OpenSUSE 12.2 - Skype microphone doesn't work


after many years of happy life with opensuse 11.2 I’m here trying the “breeze” of the new 12.2.
I’ve spent a lot of hours trying to make latest version of Skype ( working… but no way.

Using skype options I can test sound (it’s ok) and I can make a test call too but… mic doesn’t register.
I’m lost a lot of hours, I’m exhausted… :disapointed:

On Yast I see 2 audio device:

  1. 5 series/3400 (I think is the oone embedded in the motherboard of my AsRock mini-pc)
  2. nVidia corporation (I think is the one from graphic card providing HDMI output too)

here the output issuing the “arecord - l” command:

**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 2: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Here the output issuing the “aplay - l” command:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1

Basically, as I understand, I have two devices: 1 only for capture (HDA Intel) and 2 for playback (HDA Intel + HDA NVidia).
Again (as I understand) there are 3 “area” where one can do something:

A) Phonon
B) Yast
C) Kmix

About Phonon:
I’ve read the Phonon is a virtualization tool that can manage different input sound device, it’s great, it’s cool and so on… okay. I know that devices should be listed in the right order 'cause some software doesn’t care of Phonon (e.g. Skype).
I have fight with Phonon and I think I’ve reached a compromise, no more error messages from Skype (like “playback device problem” or “capture device problem”). But… MIC is not capturing nothing (but for Skype is all ok ! )

About Yast:
I’ve read somewhere that in openSUSE 12.2 one can solve microphone problems by deleting the card that you don’t want use (NVidia HDMI in my case) going in Yast → Hardware → Sound (I think the source is this SDB:Skype - openSUSE)
Nevertheless, that article is talkink about Logitech Videocamera, so I’m scared to make disasters… I decided to touch nothing in Yast.
Above sentence is not completely true. I tried to remove Pulseaudio management from both devices (you can do this in Yast using the misteryious button “Other” below on the left). Anyway, this soved nothing, so I have re-enabled Pulseaudio again on both devices.

About Kmix:
In the mixer there are no many things that one can do, apart playing with cursors to raise levels for palyback and capture devices. My capture device is at 70% of level. I think is ok.
Anyway, I see 4 tabs in the mixer window:

[Playback device] (2 devices - correct)
[Capture device] (1 device correct)
[Playback streams] (1 device called “event sounds” - I don’t want to know what is… )
[Capture streams] (0 device - correct)

Nothing more to see/do here.

I’ve played with all skype options combinations… no way… the strange thing is that (I repeat) for Skype is all ok. But that stupid microphone is died… (yes I tried to move from back connector to back connector for dozen of times… no result…)
Now I’have discovered a big post form oldcpu illustrating another approach: installing Pavucontrol could solve the problem (see Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums ) but… I’m little suspicious, how can a program that is basically a volume-control solve my problem :question:
As usual, I’m a coward and I’m always scared in installing things “only to try”… :shame:
Is pulsecontrol a solution?
It can work with Phonon and Pulseaudio installed?
Somebody can help me? :frowning:

Check in KDE - Systemsettings - Multimedia - Phonon if your mic is on top.

Hi, I don’t know if it is a “help”, but in my case I had to uninstall pulseaudio to have a working mic.
but in my case this command

arecord -vv -f S16_LE -c 2 -D hw:0,0 new.wav

thnx, ciao, Pier:-)

Yes, it’s on top in all sections:

In “audio playback” section I have two cards and “Internal audio analog stereo” is always the first one;

In “audio recording” I have only the “Internal audio analog stereo” device, so nothing to do here;

In “video recording” I see nothing 'cause I have to web camera connected to my pc


arecord doesn’t work for me… it’s strange… here some output:

giulio@linux-5wvn:~> cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.25.

giulio@linux-5wvn:~> cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf9ff4000 irq 52
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbc7c000 irq 17

Speaker test is ok:

speaker-test -Dplug:front -c2 -l5 -twav

But testing the MIC with arecord +aplay doesn’t work… it register nothing:

giulio@linux-5wvn:~> arecord -d 10 myrecording.wav
giulio@linux-5wvn:~> aplay -vv myrecording.wav


What can I do now? I go to uninstal pulseaudio? Or I uninstall NVidia hdmi device? Or I install Pavucontrol? :question:

p.s: the microphone is ok… I use it everyday with my old, crappy, damaged computer running the magnificient openSUSE 11.2 (with Gnome2 obviously :smiley: )

As I see, nobody can suggest me something. Unfortunately in this days I have not so much time to make some test, maybe in the next week…

Anyway, I’m a little bit disappointed from latest version of OpenSUSE, honestly I think that technology should simplify our life, but more time passes more I see thing getting complicated. In my opinion there was no need for big revolution after Gnome2 and opensuse 11.x, but… you know…

We will see if I will became acquainted with 12.2 and his “fashion/cool” KDE-plasma interface. For now it’s just enough for me to discover where the shutdown button is located before switching back to my old pc.
eheheheheh… :slight_smile:


After trying all possible combinations, I’ve solved.
My problem was that nott all possible device-configurations was displayed in Skye (when you’re going to adjust sound device settings in the “Option” item).
Only HDMI card was displayed and/or something useless devices named “default”, “system default” and so on… :frowning:
pavucontrol program helped, but not in the way oldCPU suggested.

If you have HDMI hardware in your PC (like me) then you should have 2 audio device too: Internal audio card + HDMI blablabla

Do what follows (KDE 4.8 plasma interface)

**STEP 1) Disable your “HDMI blablabla” device
a) Go in “dektop settings”, select “multimedia” then select Phonom
b) select the “Audio Hardware setup”
c) you will see 2 devices, disable the “HDMI blablabla” (or nvidia blablabla) by setting Profile to “Off”
d) now select “internal audio” and put “profile” to “analog stereo duplex”
e) stay again on “internal audio” and look below to “device configuration”, use the dropdown menu to set
e1) sound device = “playback…” with connector = “analog output”
e2) sound device = “recording…” with connector = “Front microphone” (in my case, otherwise choose something different)
f) click on “Apply” button and exit

STEP 2) Be sure PulseAudio is enabled
a) start YAST
b) go to the “hardware” item, then select “sound”
c) a “quite empty” windows opens, but there is all you need. You will see 1 row with your internal card and 1 row for the other “multimedia” one.
d) Ignore the multimedia row, select your internal card (the name usually includes the “chipset” word) and…
d1) set you internal card as “Primary card” by using the anonym button called “Other” in the bottom-right part of the window
d2) not finished yet, using the same meaningful button, selecte PulseAudio configuration and be sure that pulseaudio is activated (click on the checkbox if necessary)
e) click on the “ok” button
STEP 3) turn off your pc**
a) don’t logout, don’t restart, turn it off.
b) turn on it again

STEP 4) run pavucontrol
a) download pavucontrol and install it (for example by using YAST and searching in standard opensuse repositories)
b) close the kmixer program (it should be displayed on the taskbar below of the screen, so just right-click and quit)
c) start pavucontrol (for example by a terminal window, or search in KDE menus) and play a little with it (raise up levels, check if a capture device is present)
d) pavucontrol makes the miracle! all of the possible carddevices will be listed in skype!
e) go in skype, settings, sound devices and start trying combinations of card device until the test call doesn’t work. Here the conf that works for me:

STEP 5) turn off your pc again**
a) don’t logout, don’t restart, just turn it off.
b) turn on it again
c) now kmixer should start again, but pavucontrol not. That is exaclty what we want
e) go in skype and check settings again, they should be exactly as you set before*.

(*) don’t laugh, but sometimes, immediately after starting the pc, skype-settings return back to some no-sense standard configuration. After that I start working for 2-3 minutes, I go back to take a look at skype settings and… magically, all right settings are restored! :open_mouth:
I think there are some greemlins living inside openSUSE… rotfl!
In this case I would like go back to my Commodore64.

I don’t think it has anything to do with openSUSE. Sound under Linux is just a mess. For example, no matter what I set mixers sometimes my mic will not work. Though after reboot or etc, it works… I am debating if I should have pulseaudio installed or not.

On 01/19/2013 02:46 PM, giulio buccini wrote:
> (*) don’t laugh, but sometimes, immediately after starting the pc,
> skype-settings return back to some no-sense standard configuration.
> After that I start working for 2-3 minutes, I go back to take a look at
> skype settings and… magically, all right settings are restored! :open_mouth:
> I think there are some greemlins living inside openSUSE…

yep, there probably are strange things in there…

i was lucky and didn’t have the problem you (and others) had but anyway
want to THANK YOU for taking the time to document your path to success!!

openSUSE®, the “German Engineered Automobile” of operating systems!

Essentially, the point is that you need to have pavucontrol running (with pulseaudio enabled and kmixer stopped) in order to see all possible sound devices listed in the Skype configuration settings. Otherwise… you’re done! You can even spend weeks on your pc trying to make skype working…
I’ve discovered it casually, no help, no docs, only lucky. I think it’s a shame for a modern operating system.
For this reason I think that the Commodore64 was a great PC… rotfl!

I absolute agree with you. Configuring soun is absolutely not intuitive.

Are you sure that you have a sound device set for recording? Here what I have in Phonon,

as playback device:

as recording device:

After, to check if the mic works or not, open a terminal a issue the command
arecord -vv -fdat foo.wav (creates a foo.wav file in the current directory)
if you speak to the mic, you should see the rec-level moving from left to right (as bouncing ‘#’ characters).
Terminate recording by pressing CTRL-C

Hope it helps!

Massive thanks!!

I have been pulling my hair out over this for the last week.

Followed the instructions and I now have a working mic in Skype.

Have a virtual beer on me :smile:

I think PulseAudio is actually very good but (like too many things in Linux) only once you’ve tamed the beast. I think openSUSE’s standard install really doesn’t help matters: PulseAudio is enabled by default, but without pavucontrol even installed. This in my opinion is just plain madness.

One thing I wanted to add for those who have upgraded to openSUSE 12.3, I also spent time configuring my laptop internal sound card, more specifically the internal mic for Skype. On my ASUS laptop and HP laptops I thought just disabling Pulse Audio was the fix, but I found that I needed to go into YAST —> Hardware —> Sound (or Phonon) and directly edit the listed sound card, in my case the driver was snd-hda-intel. I’ve read on other forums (SDB:Intel-HDA sound problems - openSUSE) the problems people have been having with this type of card/driver.

Here’s what I found has worked:

  1. Use Pulseaudio and install pavucontrol (Pulse Audio Volume Control).
  2. YAST —> Hardware —> Sound
    a. edit selected sound card and fix/add/define these options:
    i. DMA pointer read method | position_fix —> 1 (ie set it’s value to “1”)
    ii. Use the given board model. | model —> laptop (ie set it’s value to “laptop”)

Once I had enabled these options for my laptop’s intel sound card on both the ASUS X54C and HPG60 laptops, I had a working (internal) microphone - even for Skype. I’ve seen for some that they need to un-mute the internal mic so double check that setting for yourself. Also, there is an audio tool that I found on the forums called S.M.A.R.T. ( that is a bash shell script that can help you with sound on openSUSE. Using that tool helped me determine that my HPG60 laptops weren’t recognizing the internal microphone (said it was an “unknown device”). Thanks to jdmcdaniel3 who wrote it!

Agreed, pavucontrol is very helpful. However it is not essential unless your circumstances require it. You could say the same for the 32 bit alsa plugins module.
There are a couple of issues that can arise that make the use of Skype problematic: first I think that Skype is a 32 bit app and if you run on a 64 bit openSUSE installation then you won’t automatically have the necessary plugin installed that will give Skype and other 32 bit apps access to the pulseaudio server. While PA has full control over your audio, Skype won’t see the server on your 64 bit installation, so you have to go through a bunch of hoops to make your hardware visible to Skype. Giving Skype full access to the PA server removes a lot of headaches.
Second is non-standard audio devices. On my Gnome system, I found that it was impossible to use my bluetooth headset with Skype. While Skype could see my default devices (onboard output, USB webcam mic input) I could not find a way to get Skype to see the bluetooth at all, but as soon as I installed the 32 bit plugin and used pavucontrol to activate and inactivate devices, everything worked out of the box.
So should the openSUSE developers install the 32 bit plugins and pavucontrol by default? If you only have a basic sound system and alsa sees them easily and can expose them to Skype, you don’t need either of them. There must be many such occasions where extra packages may or may not be required.

Sorry to resurrect this thread, but the problem still exists with openSuSE 13.2. I knew that the problem didn’t lie with my microphone because, in Pulase Audio Volume Control, I could see that Pulse Audio was picking up sounds I made.

After trying various remedies, I came across this thread and eagerly tried the long procedure suggested by giulio buccini above. I’m afriad it didn’t work. However, I looked at the other contributions to the thread and, while not reversing anything that gulio suggested, decided that installing the alsa 32-bit plugins couldn’t do any harm Alas, they didn’tdo any good either.

Then, more in desperation than anything else, because of the suggestion that the problem lay in the interface between Skype and Pulse Audio, I uninstalled Pulase Audio to see what would happen. That was even worse, so now I couldn’t hear anything either.

So I reinstalled, and, mirabile dictu, my microphone now works!

What the hell is going on I do not know, but thanks to everbody was has contributed. Other than there being a gremlin in openSuSE, could I suggest that the solution might just be:

~uninstall Pulse Audio
~install Skype (or take hese two steps in either order, it doesn’t matter)
~ install Pulse Audio

That’s not to say that the other steps suggested here might not have helped (I found guilio’s long post useful in terms of other information in it anyway). The only way I’m going to find out is to rebuild my system from scratch several times over, varying things every time. And I really don’t want to do that. Others may try if they wish.

Hi John,

as somebody told before, sound configuration is a mess under Linux. Happy to hear that you solved!
I’m still running OpenSUSE 12.x. I will never upgrade to 13.x. I want to spend my life with my wife and my son, not standing in front of the PC like trying to make it working.
Anyway, you are my hero 'cause you didn’t give up!

Thanks, Guilio. Except I spoke too soon. It mysteriously started working and worked for several tests as I tried to adjust the volume of my microphone. Then, no sooner had I posted here and in the Skype forum where I’d also posted than it stopped working. This time uninstalling and reinstalling Pulse Audio made no difference.

The problem with staying with an old version of openSuSE is that the repos stop being updated after a while.

I am now officialy tearing my hair out.

Skype requires 32 versions of the liibs if you run 64 bit.

Also pavolcontrol may need a tweak or two to get source and output linked up right.

Which libs need the 32-bit versions?

When I look at Pulse Audio volume control it shows that it is picking up sounds from the web cam mic. The problem lies somewhere between there and Skype.

The really peculiar thing is the fact that it has worked.